Contribute
Register

macOS 10.13.4 Update

Status
Not open for further replies.
Joined
Nov 19, 2017
Messages
8
Motherboard
Z270N-WiFi
CPU
i7-7700k
Graphics
GTX 1060 6G
installing 10.13.4 and also the patch for USB, everything seems working fine except:

When the machine going to sleep, sometimes the computer will restart itself. Anyone has that experience ?

And if the machine does not restart by itself, the screen will turns black and the computer will sleep and wake immediately going through cycles.

Same sleep question in 10.13.1/2/4.
Mostly at night the fan just make some noise and back to silence
 
Joined
Jul 12, 2016
Messages
25
Motherboard
GA-Z370N-WIFI
CPU
i5-8400
Graphics
UHD 630
Mobile Phone
  1. iOS
Same sleep question in 10.13.1/2/4.
Mostly at night the fan just make some noise and back to silence
Have a look at Settings>Energy saving>uncheck Power Nap and Wake for Network access.
Sometimes it gets re-enabled after a update...
 
Joined
Feb 28, 2014
Messages
115
Motherboard
Gigabyte GA-Z170X-UD5
CPU
i7-6700K
Graphics
RX 560
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Booting to black screen after Update
Sys def: iMac 17,1
GPU: RX580
IGFX as initial display
No graphic kexts applied.
Tried GFX0 to IGPU, fake ID for 6700k and RadeonDeInit with no luck.

Works when I boot with my USB-Installer EFI, which has iMac14,2 as System Definition. But then it shows 2x Intel HD530 and 1x RX580

Maybe iMac17,1 is the problem?
Has anyone an idea?

Did you find the problem? Same issue here. Black screen after update. RX560 DP, HD530 and iMac17,1
 
Joined
Jan 27, 2017
Messages
23
Motherboard
Gigabyte Z270 Gaming 7
CPU
i5-7600k
Graphics
Aorus Xtreme Edition 1070 8G
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Has anyone experienced upgrading from 10.13.3 to 10.13.4 broke iMessages? Update went smoothly (like real Mac) but then iMessage stopped working. I have not tried the guide for dummies from the Guides menu yet; it worked before. Is this something new?

iMessage is fine after updating from 10.13.3
Have a look at Settings>Energy saving>uncheck Power Nap and Wake for Network access.
Sometimes it gets re-enabled after a update...
Thanks, shall try.
 
Joined
Apr 17, 2014
Messages
7
Motherboard
ASUS Q534UXK (Clover v2.4k r4259)
CPU
Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz ( Kaby Lake-U)
Graphics
Intel HD Graphics 620 (Kaby Lake-U GT2) / NVIDIA GeForce GTX 950M (2GB) (3840 x 2160)
Mac
  1. Mac mini
Classic Mac
  1. Plus
Mobile Phone
  1. Android
  2. iOS
Update process went smoothly, but afterwards I'd get stuck part way through boot. Had to update CoreDisplayFixup.kext to the latest version which has been patched for 10.13.4, and all is working again. Other than that no other problems.
 
Joined
Feb 28, 2014
Messages
115
Motherboard
Gigabyte GA-Z170X-UD5
CPU
i7-6700K
Graphics
RX 560
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I confirm that with a RX560 using DisplayPort, only WhateverGreen allowed me to update to 10.3.4 without Black Screen. (iMac17,1)
 
Joined
Dec 16, 2014
Messages
35
Motherboard
ASUS P8 Z77-V PRO
CPU
i7-3770K
Graphics
HD 4000
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Updated via the Combo and the process went smoothly.

Afterwards the RealTek audio was missing (as it always is), but even a reboot did not fix it (which it usually does).

So in addition I did a kext cache refresh as suggested by toleda here and after a reboot the audio was working again.
 
Joined
Jan 28, 2014
Messages
162
Motherboard
Asus Rog Strix Z370-G Gaming (WI-FI AC)
CPU
i7-9700K OC'd @ 5.0GHz
Graphics
Vega 56
Mobile Phone
  1. Android
Updated from app store without problems, removed WhateverGreen and set in Clover/Graphics RadeonDeInit = No flag

1.png
 
Status
Not open for further replies.
Top