Contribute
Register

macOS 10.13.3 Update

Status
Not open for further replies.

T16

Joined
May 17, 2017
Messages
54
Motherboard
Asus B85M
CPU
Intel Core I-5 4590
Graphics
Nvidia GT 710
Mobile Phone
  1. iOS
Ok I got the 10.13.3 installed and everything works. Here is what I did.
1. Updated Lilu, NvidiagraphicsFix, and AppleALC
2. Updated Clover to latest version
3. Inserted the value 0xe907f537 in SMBIOS firmware features.
 
Joined
Dec 16, 2015
Messages
18
Motherboard
Gigabyte Z97X Gaming 7
CPU
Core i7 4790k
Graphics
GTX 1080
Thanks BreBo! Your solution worked for me!
 
Joined
Jan 13, 2018
Messages
27
Motherboard
Gigabyte Aorus Gaming 9
CPU
i9-7920X
Graphics
Vega Frontier
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
Pre Update Notes:
- This update may break some of your High Sierra functions, like audio and the nVidia Web drivers. Make sure you backup first.:thumbup:

- If you're using nVidia drivers for your GeForce GTX 750, 750Ti, 960, 970, 980, 980 Ti, Titans 'Maxwell' and GTX 10x0 "Pascal" graphics cards, you'll need to install the nVidia 10.13.3 Web driver(s) after the 10.13.3 update; when the drivers are updated, the link will be available in Post #1.

- For those who are using the MacPro6,1, iMac15,1, iMac17,1 or iMac18,x system definitions may need to re-apply the black screen fix. The updates to the Lilu.kext, WhateverGreen.kext and NvidiaGraphicsFixup.kext are not out; when available, they will be in the Downloads > Kexts area.

- NOTE: This update is installed differently than point updates of the past. After reboot, on Clover Boot screen you may have to choose the Install macOS from YOUR-DRIVE-NAME in order to complete the update.
Example:
Install macOS from Macintosh HDD

- The update does not convert a HFS+ formatted drive to an APFS.



Here's the step by step way to update for those who aren't using the Nvidia Maxwell/Pascal graphics cards. For Nvidia Maxwell card users, see below
:ch: Backup your current installation using Carbon Copy Cloner or SuperDuper;
:ch: Update your apfs.efi according to tonymacx86s guide How to Update + Current and Past apfs.efi Downloads; apfs.efi is unchanged;
:ch: Download the High Sierra 10.13.3 Update or Combo Update in Post #1 or the Update from Apple's Mac App Store and run it to update to 10.13.3 - the updater will reboot upon completion;
:ch: At the Clover boot screen, choose "Install macOS from (your drive name)";
:ch: Upon rebooting into Sierra, you can:
:ch: Check to see if your audio is working. If not, restart. Still no audio, post to No Audio Devices - AppleHDA Realtek Audio,
:ch: (Optional) Update to the latest version of Clover,
:ch: (Optional) Check to see if your TRIM setting has survived through the update (About this Mac > System > System Report > SATA/SATA Express) - if not, use the "trimforce" Terminal command (1); if you've used the "trimforce" command in 10.13.2, then it should "survive" the update, but check to make sure; and
:ch:Re-boot.​

For Nvidia Maxwell/Pascal graphic cards users (see 2nd and 3rd note above), you'll need to do the following once the Nvidia web driver is released for 10.13.3:
:ch: Backup your current installation using Carbon Copy Cloner or SuperDuper;
:ch: Update your apfs.efi according to tonymacx86s guide How to Update + Current and Past apfs.efi Downloads; apfs.efi is unchanged;
:ch: Download the High Sierra 10.13.3 Updater or Combo Update in Post #1 or use the Mac App Store.
:ch: Download the latest Nvidia web driver for 10.13.3 (when available).
:ch: Run the Sierra 10.13.3 Mac App Store Update - the updater will reboot upon completion;
:ch: At the Clover boot screen, choose "Install macOS from (your drive name)";
:ch: Upon rebooting, run the Nvidia web driver pkg and reboot when its completed it's installation;
:ch: Check to see if your audio is working. If not, restart. Still no audio, post to No Audio Devices - AppleHDA Realtek Audio.​


Please post help requests in the High Sierra Desktop Support Forum section (not in this thread).


1 Use the new Terminal trimforce command in the following manner:
Code:
sudo trimforce enable


[SUCCESSFUL] updated on my Skylake x299 - i9-7920x -Radeon Vega Frontier Edition - 17.1 definition.

pd : it is very important read the instructions ( I made the mistake of not reading it, and had to restart several times without knowing what was going on (clumsy on my part) thanks guys from tonymacx86.com, I do not know what we would do without your help.:
NOTE: This update is installed differently than point updates of the past. After reboot, on Clover Boot screen you may have to choose the Install macOS from YOUR-DRIVE-NAME in order to complete the update.
Example:
Install macOS from Macintosh HDD
 
Joined
Jan 7, 2012
Messages
16
Motherboard
Gigabyte GA-Z97X-UD5H
CPU
Intel Core i7 4GHz 4790K
Graphics
MSI GeForce GTX 680
Mac
  1. MacBook
  2. MacBook Air
Mobile Phone
  1. iOS
I did a fresh install of 10.13.1 and everything works. When attempting the update to 10.13.3 the update never installs, and I just Keep seeing the macOS install drive on Clover. I tried to update Lilu, AppleALC, and USBinjectall but then I ended up in a never ending boot loop. (Also I did Not install emuvaraibleuefi-64 on Clover) any suggestions would be greatly appreciated. Thanks!
Hi T16,
Did you happen to find a solution? I have the same problem with one of my machines (Asus Gene VIII). An other system updated just fine.
Thanks in advance!
 
Joined
Sep 21, 2015
Messages
43
Motherboard
Gigabyte GA-Z97X-UD7 TH LGA 1150
CPU
i7-4790K
Graphics
ASUS GTX980-4GD5
Mac
Classic Mac
Mobile Phone
[FIXED] It was my fault... didn't see that I had disconnected my USB cables...

Hi there, I was able to install everything, and it was all running smoothly, but now whenever I land in the clover boot screen, the mouse and keyboard are not working! :S so I can't move past that screen. Any ideas why this might be happening?

[Edit] It only happens if I plug in my NVidia graphics card, if I unplug it I can use the keyboard and get into clover.

Thanks
 
Last edited:
Joined
May 5, 2017
Messages
16
Motherboard
Gigabyte Z170X-UD5
CPU
Intel Core i7 6700K
Graphics
EVGA GeForce GTX 1060 6GB SSC GAMING ACX 3.0
Updated to 10.13.3 without hiccup, NVIDIA updated automatically to ".156". The system does seem a bit laggy. Moving between desktops is glitchy. Possibly the system needs to "settle" for a bit. Will update tomorrow with other insights.
I have almost exactly the same configuration you have but have really struggled, off and on, for a couple of months trying to make mine work. Would you mind sharing your config with me?
 

elfcake

Banned
Joined
Nov 26, 2012
Messages
1,740
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have almost exactly the same configuration you have but have really struggled, off and on, for a couple of months trying to make mine work. Would you mind sharing your config with me?
What problems are you having?
 
Status
Not open for further replies.
Top