Contribute
Register

macOS 10.13.1 Update

Joined
Mar 9, 2011
Messages
672
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Trim is okay with some SSDs with HFSJ+.
APFS is okay with certain SSDs some has issues.
I wouldn't recommend migrating to APFS its new and has bugs.
my hack is working ok with APFS but a bit slow boot. I have trim enabled but is it possible to disable trim? Maybe that is the issue?
 

elfcake

Banned
Joined
Nov 26, 2012
Messages
1,742
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
does anyone know what the size of the download is? I've done the download twice, once at about 977mb and the second time at 1.47gb plus I did a fresh install and went directly into the 10.13.1 update and received the warning below

If the definition of insane is, doing the same thing over and over again and expecting a different result, then I am insane.
 

Attachments

  • IMG_5678.jpeg
    IMG_5678.jpeg
    145.1 KB · Views: 214
Last edited:

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,566
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Joined
Sep 1, 2016
Messages
372
Motherboard
GA-Z170N Gaming 5
CPU
i7-6700K
Graphics
RX 580
Easy upgrade. Updated Clover, then ran updater from the App Store. On restart, selected "Install macOS from Enterprise," and it did its thing from there. Prompted for NVIDIA drivers after installation, sound intact. Life is good.

Screen Shot 2017-11-01 at 5.55.52 PM.png
 
Last edited:
Joined
Jan 6, 2017
Messages
21
Motherboard
Mac Pro
CPU
386
Graphics
ATI
Mac
  1. Mac Pro
- Updated Clover to the latest version
- installed new apfs into EFI/EFI/CLOVER/drivers64UEFI
- Rebooted a twice. Installed new NVIDIA drivers.
- Deleted com.apple.mediaanalysisd.plist as it was causing slowdowns, hiccups, and lag.
- All good.
 
Joined
Mar 9, 2017
Messages
70
Motherboard
ROG STRIX Z370-G GAMING
CPU
i5-9400F
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  • Downloaded and installed the update from App Store
  • Removed GPU from Mobo
  • Updated nVidia Web Drivers
  • Placed back GPU into Mobo
  • Updated apfs.efi into /drivers64UEFI
Full working.
 
Joined
Mar 15, 2014
Messages
21
Motherboard
Z87E-WIFI
CPU
E3-1246v3
Graphics
GT 710 or RX 570
Classic Mac
  1. Performa
Mobile Phone
  1. Android
I was having some issues with KPs because of a kext for a now-incompatible peripheral (le sigh). I had kept it around in the my 10.11 and 10.12 folders under EFI/Clover/kexts, and it might have been in some old cache as well. I solved this by deleting the /OSX Install Data folder, removing the kexts from EFI/Clover/kexts/, rebuilding kernelcaches (kextcache -u /; kextcache -system-prelinked-kernel; kextache -system-cache), and rerunning the installer for 10.13.1 through the Mac App Store. It doesn't really make sense for me to have to rebuild caches, and my guess is that this did nothing, but I decided to 'go overboard'. Oh, I guess removing the peripheral from my PC could have done it also, but I'm actively using it in Windows.

ED: I'm using AppleALC + lilu to get onboard audio (which I never use, just did it for completeness sake) to work (ALC898 on a Gigabyte Z87-UD4H). The update to 10.13.1 did not affect this at all. I'm experiencing some instability with iTunes but there's already a long thread about that and I don't think it's an issue specific to 10.13.1.
 
Joined
May 21, 2013
Messages
11
Motherboard
Lenovo ThinkPad T430 (Clover)
CPU
i5-3320M
Graphics
HD4000, 1366x768
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Successful "update" to 10.13.1 from 10.13.0

- Downloaded full macOS 10.13.1 (5 gigs) since the 10.13.1 update gave me the OSInstall.mpkg error.
- Copied over relevant kexts and added apfs.efi to EFI
- Installed macOS 10.13.1, took ~20 minutes and a couple of reboots.
- Flushed kext cache to get audio up and running.
sudo touch /System/Library/Extensions && sudo kextcache -u /
- Removed kexts from EFI (had to leave apfs.efi in place, since the install upgraded my drive to APFS)
- Rebooted and voilà. =)


EDIT: Added the part where I removed the kexts again.
 
Last edited:
Joined
Jan 6, 2012
Messages
442
Motherboard
GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000
Mobile Phone
  1. iOS
does anyone know what the size of the download is? I've done the download twice, once at about 977mb and the second time at 1.47gb plus I did a fresh install and went directly into the 10.13.1 update and received the warning below

If the definition of insane is, doing the same thing over and over again and expecting a different result, then I am insane.

For me, it took adding FakeSMC.kext to /EFI/Clover/Kexts/Other and removing EmuVaribleUefi-64.efi from the /EFI/Clover/drivers64UEFI directory and starting the install/update again from the App Store. After installation was complete, I removed FakeSMC.kext and put EmuVariableUefi-64.efi back into its original directory.

-bth
 

elfcake

Banned
Joined
Nov 26, 2012
Messages
1,742
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Successful "update" to 10.13.1 from 10.13.0

- Downloaded full macOS 10.13.1 (5 gigs) since the 10.13.1 update gave me the OSInstall.mpkg error.
- Copied over relevant kexts and added apfs.efi to EFI
- Installed macOS 10.13.1, took ~20 minutes and a couple of reboots.
- Flushed kext cache to get audio up and running.
sudo touch /System/Library/Extensions && sudo kextcache -u /
- Removed kexts from EFI (had to leave apfs.efi in place, since the install upgraded my drive to APFS)
- Rebooted and voilà. =)


EDIT: Added the part where I removed the kexts again.
How did you download the full 10.13.1? App Store does not give me the option.
 
Top