Contribute
Register

macOS 10.12.5 Update

Status
Not open for further replies.
Joined
Aug 1, 2015
Messages
3
Motherboard
Asrock Z97M OC Formula
CPU
i5 4430
Graphics
Gigabyte GTX780 Windforce OC
Updated from 10.2.1 to 10.2.5, only needed to update nvidia web driver, everything else was working perfectly.

This board worked allmost out of box with only Atheros kext needed and small tweak in linux for uefi boot priorities when i first installed Mac OS X on this board.
 
Joined
Jan 28, 2017
Messages
36
Motherboard
Asus N552VW
CPU
i7-6700HQ
Graphics
HD 530 + GTX 960m
After the update,I can boot only The fake-id=0x12345678 because I have a laptop 4k and I need the mac-pixel-clock v2 for the Sierra 10.12.5
Can you help me?
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,087
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
After the update,I can boot only The fake-id=0x12345678 because I have a laptop 4k and I need the mac-pixel-clock v2 for the Sierra 10.12.5
Can you help me?
This is a Desktop Support forum section. For help with your Laptop you should post in the relevant Sierra Laptop Support forum section.
 
Joined
Jan 6, 2017
Messages
4
Motherboard
GA-H170N-WIFI
CPU
i5 6500
Graphics
Intel HD Graphics 530 (2xHDMI, 1xDVI)
Mac
  1. iMac
Mobile Phone
  1. iOS
Intel HD 5xx/6xx Graphics (Skylake & Kabylake) users:

There are changes to the new 10.12.5 Intel graphics drivers which may cause black screen or hang on boot. If you can't boot to desktop after updating, uncheck Inject Intel in Clover boot menu under Options/Graphics Injector/Inject Intel:


When you reach the desktop, install the following kexts to /Library/Extensions using KextBeast:

Lilu.kext
IntelGraphicsFixup.kext



You may also install the kexts before you update. The addition of these kexts should allow you to boot- we are looking into using Clover's KextstoPatch for a permanent solution.

Please post a reply if this has/hasn't worked for your system. :thumbup:

Source:
http://www.insanelymac.com/forum/topic/322239-pre-release-macos-sierra-10125/page-3#entry2418219


Intel HD 530

gIOScreenLockState 3, hs....

Tried even the boot from USB with the two KTexts
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,624
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Intel HD 530

gIOScreenLockState 3, hs....

Tried even the boot from USB with the two KTexts

Keep in mind that EFI/Clover/kexts is ignored when FakeSMC.kext is installed to the system volume and config.plist/SystemParameters/InjectKexts="Detect".
 
Joined
Sep 28, 2011
Messages
243
Motherboard
GA-Z68XP-UD3
CPU
i7
Graphics
Sapphire R9 280X 3GB
Classic Mac
  1. LC
  2. Power Mac
Mobile Phone
  1. iOS
Problem with black screen on my GA-Z68XP-UD3 using iMac 12.2 definition

10.12.4 to 10.12.5 via the App Store update.... I have the black screen after clover screen. Luckily have an 10.12.4 clone but it's a little old. The last update to 10.12.4 went smoothly that I didn't bother cloning my latest state. Learned my lesson!

UPDATE: Many thanks to el_charlie! He saved my butt!

el_charlie suggested installing "NvidiaGraphicsFixup with Lilu in Clover/Kexts/Other"

I glanced over that recommended install of "NvidiaGraphicsFixup with Lilu in Clover/Kexts/Other" thinking it was more for newer motherboards and graphic cards. Didn't think it applied to my four year old plus setup.

Thanks again el_charlie and tonymac86 site!
 
Last edited:
Joined
May 30, 2016
Messages
569
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
  2. SE/30
Mobile Phone
  1. iOS
Cloned to USB SSD, made sure I could boot off clone without issues
upgraded main drive via app store
rebooted, couldnt log in! it would start logging in and then would boot me back to the login screen. tried a few times, rebooted. first time after that it booted me, tried again and it worked - weird.
updated nvidia driver, all set!
 
Joined
Apr 19, 2017
Messages
14
Motherboard
Alienware 17 R3
CPU
i7-6700HQ
Graphics
GTX 970M
Mobile Phone
  1. iOS
I updated. Two things broke, my Ehternet driver and my Graphics driver. But everything seems to break my graphics driver and an nvidia update popped up after I installed my ethernet kexts. All is well now, so it could of gone worse IMO. Thanks Apple for the update!
 
Status
Not open for further replies.
Top