Contribute
Register

MacMan's Build: ASUS TUF Z390-PRO GAMING - i9-9900K - Vega 64 - Updated for 10.14.6 and NVRAM Support

Joined
Aug 7, 2018
Messages
33
Motherboard
Gigabyte Z390M Gaming
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Hey @MacMan, I am trying to install macOS Catalina using the same MoBo, and I came across the exact issue that you described where the installation just stops loading. However, I wasn't able to install the patch you provided because terminal comes back with this error:

File Doesn't Exist, Will Create: /Volumes/EFI/EFI/CLOVER/config.plist
Merge: ":ACPI:DSDT:" Entry Does Not Exist

I had to do 3 things otherwise it didn't work for me:
  1. navigate to the directory in terminal containing config.plist
  2. copy the file to be merged into that directory
  3. run the command to merge
also keep an eye on how the EFI was mounted - it changes the directory path:
  • /Volumes/EFI/EFI/CLOVER/ or
  • /Volumes/ESP/EFI/CLOVER/
 
Joined
May 11, 2020
Messages
20
Motherboard
Asus TUF z390 PRO Gaming
CPU
i5 9600k
Graphics
Gigabyte Radeon RX 5500 XT OC
Mac
  1. Mac Pro
I had to do 3 things otherwise it didn't work for me:
  1. navigate to the directory in terminal containing config.plist
  2. copy the file to be merged into that directory
  3. run the command to merge
also keep an eye on how the EFI was mounted - it changes the directory path:
  • /Volumes/EFI/EFI/CLOVER/ or
  • /Volumes/ESP/EFI/CLOVER/

Thanks for the help, I was able to figure out how to get the patch on last night but would you be willing to help me with another issue I am facing? I got to the Language selection and I installed MacOS Catalina but when it does it's automatic restart and I try to boot into Catalina my verbose hangs again and shows this:

IMG_0368.jpg

Im not sure what to do at all so any help would be appreciated. Thanks!
 
Joined
Aug 7, 2018
Messages
33
Motherboard
Gigabyte Z390M Gaming
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
@MacMan:

Is the SSDT-PMC.aml needed in "patched"?
How about OctoTUF.mb, can u apply a screenshot, please? Never saw this kind of.

the OctoTUF.mb is a Multi Beast config file - essentially you can load all the settings in multibeast by pressing the "load" button.

1591059487112.png
 
Joined
Jun 2, 2020
Messages
14
Motherboard
ASUS TUF Z390-Pro Gaming
CPU
i7-9700K
Graphics
RX Vega 56
Hello All, first of all many thanks Macman for this really helpful guide and all the stuff put together so far.

I was wondering if someone could help me as I don't know what I am doing wrong. Right so, I have followed the guide and I installed Catalina 10.15.3 just fine. I have MSI Vega 56 and a Fenvi wifi card.

The problem is that I am stuck at the same spot as @KTBall1004 meaning the install does all fine and then on the first boot that does the OS setup it gets stuck to the Apple logo at 0%.

I have done all the patches just fine I just don't know what is the problem.

I am suspicious that it is probably the graphics. What I have done so far:
- I have removed all PCI-E devices to boot just in case they were causing conflicts
- Disabled SIP in recovery but still nothing
- Tried to boot using the Vega 56 video card same behavior the only difference is instead of an apple logo I get a white screen with the cursor (hence I think this is video related issue)

Now comparing to the OP I have i7 9700k though I have checked and it has the same Graphics so the drivers and patches should work just fine since I booted and installed. Funny part is that if I will leave it for long then the screen will turn off and if I will move the mouse it will turn on which makes me feel that basic Graphics functionality is all right.

If is not the graphics then there is a chance that this might be related to the fact I formatted my Samsung SSD Evo as APFS?

I am also trying to see if the problem is related to Kext cache (since I get the lilu rebuild message) but I would guess it wouldn't need any kext rebuild on the first startup. So running with the -f boot flag gives me this (image IMG_20200605_081220.jpg), could be Audio related problem? hmm...

Will continue trying to fix. If anyone has any tips let me know.

Update - #1: I managed to fix this problem by adding the FakeSMC and various sensors kexts thanks @MkVIGTI. Though now I have a different problem, I was "smart" enough to paste all the kexts from the EFI folder USB in the extension folders, and my hackintosh now reboots when it tries to load the OS giving me APFS errors.
 

Attachments

  • IMG_20200605_074325.jpg
    IMG_20200605_074325.jpg
    8.2 MB · Views: 35
  • IMG_20200605_081220.jpg
    IMG_20200605_081220.jpg
    6.8 MB · Views: 71
Last edited:
Joined
Oct 7, 2019
Messages
24
Motherboard
ASUS TUF Z390 PRO Gaming
CPU
i7 9700
Graphics
MSI Vega 56
Update - #1: I managed to fix this problem by adding the FakeSMC and various sensors kexts thanks @MkVIGTI. Though now I have a different problem, I was "smart" enough to paste all the kexts from the EFI folder USB in the extension folders, and my hackintosh now reboots when it tries to load the OS giving me APFS errors.

@dalaranunion
Just to confirm, you are making changes to the /EFI partition on the drive you installed the OS too? Not the Bootable USB.

APFS error sounds like you don't have the correct items in the EFI partition. Make sure you have all the items I listed in the proper folders. The ApfsDeiverLoader driver goes in the EFI/EFI/CLOVER/Driver/UEFI folder

Path should be EFI/EFI/CLOVER/ [then path below]

KEXT/Other Folder
  • AppleALC
  • CalDigitHDProDrv
  • EnergyDriver
  • IntelMausiEthernet
  • Lilu
  • FakeSMC
  • FakeSMC*various sensors*
Driver/UEFI Folder
  • ApfsDeiverLoader
  • AudioDxe
  • DataHubDxe
  • FSInject
  • OsxAptioFix3Drv
  • PartitionDxe
  • SMCHelper
  • vBoxHfs
ACPI/patched Folder
  • SSDT-EC
  • SSDT-PMC
  • SSDT-UIAC (aml/dsl)
  • SSD-USBX
 
Joined
Apr 18, 2014
Messages
18
Motherboard
ASUS TUF Z390M-Pro Gaming
CPU
i7-8700K
Graphics
RX 570
MkVIGTI

I already added but it gets stuck in the Apple with a white line, and I do not go from there.
 
Top