Contribute
Register

Mac OSX 10.12 with X99 Broadwell-E family and Haswell-E family

Status
Not open for further replies.
Joined
Nov 21, 2015
Messages
205
Motherboard
Gigabyte GA-X99P-SLI MB
CPU
i7 6800K
Graphics
RX480
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
I updated to 10.12.2 last night, downloaded latest Nvidia graphics, ran AGDFix.app

Everything running ok so far
 
Joined
Nov 21, 2013
Messages
149
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I downgraded to a GTX 970, but my GTX 1080 is still installed in the system. The problem is at startup I get a message unable to load Nvidia driver manager. Uninstallation followed by a fresh installation doesn't work. Also now DPCI Manager won't run, saying "integrity check failed". I have ensured I have SIP disabled.
 
Joined
Oct 12, 2010
Messages
730
Motherboard
X299-WU8
CPU
i9-9880XE
Graphics
Vega 64
Mac
  1. iMac
  2. Mac Pro
I downgraded to a GTX 970, but my GTX 1080 is still installed in the system. The problem is at startup I get a message unable to load Nvidia driver manager. Uninstallation followed by a fresh installation doesn't work. Also now DPCI Manager won't run, saying "integrity check failed". I have ensured I have SIP disabled.
#Remove
AppleALC.Kext
Try with regular patch with graphics.
I thing problem with AppleALC not graphics driver.
 
Joined
Jan 11, 2011
Messages
52
Motherboard
GA-X99-Designare
CPU
i7-6850K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Guide update 23-07-2016

Mac OSX 10.12 with X99 Broadwell-E family and Haswell-E family



X99Gaming G1 wifi
5960X
GTX 970
Samsung SM951 256GB AHCI
Corsair 780T
Corsair H115i


I install Mac OSX 10.12 (16A239j) with X99 LGA2011-V3 platform. It’s fully supported now we don’t need add FakeCPUID anymore. 5960X needs only CloverPatch.
I update bios F22J Support Intel Xeon E5-2600 v4, E5-1600 v4 series, Core i7 6000 series CPU
The Samsung SM951 AHCI model is fully supported by Mac OSX Pro.


OSX 10.12 Installation Notes:


Set Mac osx Installer (I updated files)
Remove DSDT and SSDT
Update Clover to latest (_v2.3k_r3652_Special Edition).
Update nvidia latest web drivers.
Set patch 1 Change 15 Port Limit To 30 in XHCI Kext 10.12(99-series)
Set patch 2 5960XPatch 10.12 by Brumbaer
Creative Sound worked with AppleALC.kext
Install X99_Injector USB 3.kext and set your DSDT XHC to XHCI
You have to set IOCPUNumber to VoodooTSCSync.kext.

BIOS Configuration for USB 3 Flash drive with clover

  1. Intel USB 3.0 XHCI Mode Enabled
  2. CSM Disable
  3. XHCI-Hand-off-Enabled
  4. EHCI-Hand-off-Enabled
BIOS Configuration for USB 2 Flash drive with clover

  1. Intel USB 3.0 XHCI Mode Smart Auto
  2. CSM Disable
  3. XHCI-Hand-off-Enabled
  4. EHCI-Hand-off-Enabled
After installation you have to set DSDT and SSDT.

I get Script to generate a SSDT for Power Management

https://github.com/P...ha/ssdtPRGen.sh

AppleALC

https://github.com/vit9696/AppleALC

AppleALC Boot Arguments 10.12 you have to add -alcbeta
-v darkwake=0 npci=0x3000 nvda_drv=1 -alcbeta

SCALED RESOLUTIONS FOR YOUR MONITOR

https://comsysto.github.io/Display-...or-with-HiDPI-Support-For-Scaled-Resolutions/
Enable HiDPI Mode
sudo defaults write /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled -bool true
Set your DisplayProductName
Set your DisplayProductID
Set your DisplayVendorID
Set Scale Resolutions
Download your file then overrides your display vendorId like this.

Example for my Monitor:
sudo cp ~/Downloads/DisplayProductID-79f.plist /System/Library/Displays/Contents/Resources/Overrides/DisplayVendorID-4c2d/DisplayProductID-79f

Now graphics work very well after clover update.We have to set nvda_drv=1 and patched AppleGraphicsControl.kext







XCPM for unsupported Processor
https://pikeralpha.wordpress.com/2016/07/26/xcpm-for-unsupported-processor/


Look Files
config.plist
Kexts
Mac osx Installer
 
Joined
Jan 11, 2011
Messages
52
Motherboard
GA-X99-Designare
CPU
i7-6850K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Guide update 23-07-2016

Mac OSX 10.12 with X99 Broadwell-E family and Haswell-E family



X99Gaming G1 wifi
5960X
GTX 970
Samsung SM951 256GB AHCI
Corsair 780T
Corsair H115i


I install Mac OSX 10.12 (16A239j) with X99 LGA2011-V3 platform. It’s fully supported now we don’t need add FakeCPUID anymore. 5960X needs only CloverPatch.
I update bios F22J Support Intel Xeon E5-2600 v4, E5-1600 v4 series, Core i7 6000 series CPU
The Samsung SM951 AHCI model is fully supported by Mac OSX Pro.

Hi nmano, I have been following this thread for the past few days since it matches close to what I am looking for. I really appreciate your efforts to make X99 Sierra combination work and I would like take this thread as guide for my new build. I hope you may not mind if I bother you in the process, your support means a lot to me to attempt the build. My first question

"I update bios F22J Support Intel Xeon E5-2600 v4, E5-1600 v4 series, Core i7 6000 series CPU"
Current bios of my board (X99-Designare) is F2, can be upgraded to F4c, any suggestions?

Thanks a lot.
 
Joined
Jan 11, 2011
Messages
52
Motherboard
GA-X99-Designare
CPU
i7-6850K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
BIOS Updated to F4c
 
Joined
Nov 21, 2013
Messages
149
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
#Remove
AppleALC.Kext
Try with regular patch with graphics.
I thing problem with AppleALC not graphics driver.
thanks for your response. But I do not have AppleALC installed, instead I'm using VoodooHDA.kext.

My hardware specs are: MSI X99a Godlike Gaming Carbon, E5 2699 v4, 128GB, Asus GTX 970, MSI GTX 1080.

The problems I'm generally having are with the aforementioned graphics driver, and failed integrity check with DPCI Manager (don't know if any other apps will have the same problem)

Bluetooth: I use the built-in bluetooth, and have Apple's magic trackpad 2. The bluetooth preferences does not have "Turn Bluetooth Off" option enabled. Further my trackpad connects and disconnects repeatedly.

Spotlight: breaks after performing few searches at boot. After that doesn't show any results. Tried removing disk drives and adding back to force indexing, but didn't work.

Dictionary: Apple's dictionary app only has wikipedia. Tried multiple fixes given on various fora, but to no avail.

Kindly help.
 
Joined
Oct 4, 2014
Messages
254
Motherboard
ASUS X299 Sage/10g
CPU
i9-10980XE
Graphics
Radeon VII
Sorry, exactly how, where, and when do you do this?

Use brumbaer's patches as listed here instead of patching AppleGraphicsPolicy every time you update your system:

Code:
<dict>
                <key>Comment</key>
                <string>Brumbaer's GDP Patch 1</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                RURJRAA=
                </data>
                <key>Name</key>
                <string>AppleGraphicsDevicePolicy</string>
                <key>Replace</key>
                <data>
                RURJSQA=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>Brumbaer's GDP Patch 2</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                dW5sb2FkAA==
                </data>
                <key>Name</key>
                <string>AppleGraphicsDevicePolicy</string>
                <key>Replace</key>
                <data>
                dW5sb2FlAA==
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>Brumbaer's GDP Patch 3</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                RGVmYXVsdAA=
                </data>
                <key>Name</key>
                <string>AppleGraphicsDevicePolicy</string>
                <key>Replace</key>
                <data>
                bm9uZQAAAAA=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>Brumbaer's GDP Patch 4</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                Q29uZmlnTWFwAA==
                </data>
                <key>Name</key>
                <string>AppleGraphicsDevicePolicy</string>
                <key>Replace</key>
                <data>
                Q29uZmlnTWFxAA==
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>Brumbaer's GDP Patch 5</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                RmVhdHVyZUNvbnRyb2wA
                </data>
                <key>Name</key>
                <string>AppleGraphicsDevicePolicy</string>
                <key>Replace</key>
                <data>
                RmVhdHVyZUNvbnRyb20A
                </data>
            </dict>
 
Joined
Oct 4, 2014
Messages
254
Motherboard
ASUS X299 Sage/10g
CPU
i9-10980XE
Graphics
Radeon VII
I am not able to boot into clover at all to install Sierra. Clover will not start. Is this probably a processor problem? Do I have to patch the installer in some way if I'm using an x99 system and E5-2630v3?

Someone please help. :(

Thanks. I got it working from doing a reinstall and thankfully the problems I ran into the second time around were ones that people had solutions posted for.
How did you get Sierra installed? I can't even get Clover to boot and I also have the x99-E WS and a E5-v3 processor. Did you have to put in fake CPUID? or anything?
 
Joined
Jul 1, 2015
Messages
71
Motherboard
Asus X99 e-ws
CPU
Xeon E5-1660 v3
Graphics
EVGA GTX 980 ti
Mobile Phone
  1. iOS
I am not able to boot into clover at all to install Sierra. Clover will not start. Is this probably a processor problem? Do I have to patch the installer in some way if I'm using an x99 system and E5-2630v3?

Someone please help. :(


How did you get Sierra installed? I can't even get Clover to boot and I also have the x99-E WS and a E5-v3 processor. Did you have to put in fake CPUID? or anything?

Have you gone back and double checked your install preferences of things? I banged my head against a wall on and off for a month trying to fix my graphics issues when all I needed was a fresh install. Maybe you missed a step somewhere. Also I'd go through this thread and other threads as well since it's more than likely your issue has been addressed before. I'm not an expert so I can't offer any advice that doesn't relate exactly to something I've encountered.
 
Status
Not open for further replies.
Top