Contribute
Register

Mac OSX 10.12 with X99 Broadwell-E family and Haswell-E family

Status
Not open for further replies.
Joined
Apr 7, 2012
Messages
141
Motherboard
Asus Maximus X Formula
CPU
i7 8700K
Graphics
VEGA
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I'd also like to see what to do for a 5960X, please?
 
Joined
Dec 31, 2012
Messages
598
Motherboard
Asus Sage 10/G X299
CPU
i9-10980XE
Graphics
AMD Radeon VII
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
I'd also like to see what to do for a 5960X, please?
It's not a big trouble with 5960x...
Prepare an USB stick as in this thread https://www.tonymacx86.com/threads/...ierra-on-any-supported-intel-based-pc.200564/;
- After Step 2 (it's not mandatory to install Multibeast) use Mount Any EFI app included here and select USB EFI. Overwrite it with the one included in EFI-USB zip;
- Follow Step 4 of the unibeast install guide. After installed Sierra reboot and select your USB stick as drive. Start selecting the SSD where you installed Sierra. When logged in OSX download and install clover (to run apps from anywhere use this command in terminal
Code:
sudo spctl --master-disable
). When the EFI will be mounted overwrite it with the one included in EFI-FINAL.
- Install nvidia web drivers if required by your graphics card. Patch AppleGraphicsControl.kext and use cloverconfigurator (google it to find) to enable in an easy way nvidia web drivers. Go to "System Parameters" tab and check "NvidiaWeb"...of course remove boot line nv_disable=1
I tried to be clear...ask if you have any problems.
 

Attachments

  • EFI-USB.zip
    21.9 MB · Views: 174
  • EFI-FINAL.zip
    21.9 MB · Views: 187
  • Mount Any EFI.app.zip
    287.9 KB · Views: 131
Joined
Dec 31, 2012
Messages
598
Motherboard
Asus Sage 10/G X299
CPU
i9-10980XE
Graphics
AMD Radeon VII
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Joined
Jan 19, 2015
Messages
94
Motherboard
Asus X99A-USB3
CPU
Intel Core i7-6850K
Graphics
Asus Strix 970
I see you use a broadwell cpu so at first uyou need right fakecpuid...and about allocation memory error use osxaptiofixdrv-free2000 instead of others you have. You must create a 10.12 in EFI/CLOVER/kext dir and put there kexts you will use with sierra

Thanks!

osxaptiofixdrv-free2000 will solve the error. But it still hangs there, no further output.
 
Joined
Jan 19, 2015
Messages
94
Motherboard
Asus X99A-USB3
CPU
Intel Core i7-6850K
Graphics
Asus Strix 970
Using FakeCPUID=0x0306F2 will reach the `PCIE configuration ends`, but it still hangs.

Anyway, things are getting better.
 
Joined
Dec 31, 2012
Messages
598
Motherboard
Asus Sage 10/G X299
CPU
i9-10980XE
Graphics
AMD Radeon VII
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Using FakeCPUID=0x0306F2 will reach the `PCIE configuration ends`, but it still hangs.

Anyway, things are getting better.
If your USB3.1 controller is onboard disable it from bios. anyway attach a screenshot where your pc hangs.
 
Joined
Jan 19, 2015
Messages
94
Motherboard
Asus X99A-USB3
CPU
Intel Core i7-6850K
Graphics
Asus Strix 970
If your USB3.1 controller is onboard disable it from bios. anyway attach a screenshot where your pc hangs.

Seems to be a problem about USB.


with USB 3.1 controller off,
XHCI enabled, EHCI enabled


IMG_5792.JPG
 
Joined
Jul 13, 2014
Messages
5
Mac
Classic Mac
Mobile Phone
It's not a big trouble with 5960x...
Prepare an USB stick as in this thread https://www.tonymacx86.com/threads/...ierra-on-any-supported-intel-based-pc.200564/;
- After Step 2 (it's not mandatory to install Multibeast) use Mount Any EFI app included here and select USB EFI. Overwrite it with the one included in EFI-USB zip;
- Follow Step 4 of the unibeast install guide. After installed Sierra reboot and select your USB stick as drive. Start selecting the SSD where you installed Sierra. When logged in OSX download and install clover (to run apps from anywhere use this command in terminal
Code:
sudo spctl --master-disable
). When the EFI will be mounted overwrite it with the one included in EFI-FINAL.
- Install nvidia web drivers if required by your graphics card. Patch AppleGraphicsControl.kext and use cloverconfigurator (google it to find) to enable in an easy way nvidia web drivers. Go to "System Parameters" tab and check "NvidiaWeb"...of course remove boot line nv_disable=1
I tried to be clear...ask if you have any problems.

i tried to use this on my rampage v extreme with problems this is what i have View attachment 217912

i have no idea what i did wrong
 

Attachments

  • IMG_0489.JPG
    IMG_0489.JPG
    2.9 MB · Views: 95
Status
Not open for further replies.
Top