Contribute
Register

Mac OS X Compatibility for the Clevo W670SZQ (System76 Kudu Professional)

Joined
May 2, 2014
Messages
95
Motherboard
Bangho Max 1524 (Clover)
CPU
i7-3632qm/HM76
Graphics
Intel HD4000/1366x768
Mac
MacBook Pro
Mobile Phone
iOS
Done renaming IGPU

But now i have Device (IGPU) with no Method (_DSM) coded

i suppose it will work with something like this


"
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x02)
{
"AAPL,ig-platform-id",
Buffer (0x04)
{
0x05, 0x00, 0x62, 0x01
}

}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}

"

Compile with no errors but i don't know if name and buffer are correct for me

or should i patch with Toleda repo for IB7 HD4000 Laptop
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Done renaming IGPU

But now i have Device (IGPU) with no Method (_DSM) coded

i suppose it will work with something like this


"
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x02)
{
"AAPL,ig-platform-id",
Buffer (0x04)
{
0x05, 0x00, 0x62, 0x01
}

}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}

"

Compile with no errors but i don't know if name and buffer are correct for me

or should i patch with Toleda repo for IB7 HD4000 Laptop
Can't say much about the correct value for ig-platform-id (except that the one above is wrong, and lacks any hda-gfx injection) because your profile lacks information about your screen resolution.

Please provide complete details in your profile/signature
(Profile/Settings link in upper right corner of this site)

System: manufacturer/model
CPU: detailed CPU model + motherboard chipset
Graphics: all graphics devices + laptop internal screen resolution

For example, typical Ivy laptop:
System: HP ProBook 4540s
CPU: i5-3320m/HM76
Graphics: HD4000, 1366x768

Use CPU-Z on Windows to find CPU (Core iX-xxx) and motherboard chipset (HMxx). For a laptop, these details are important and affect critical installation procedures.
 
Joined
May 2, 2014
Messages
95
Motherboard
Bangho Max 1524 (Clover)
CPU
i7-3632qm/HM76
Graphics
Intel HD4000/1366x768
Mac
MacBook Pro
Mobile Phone
iOS
It is ivy bridge

Intel i7 3632qm

MB chipset hm76

Graphics HD4000 built in screen res 1366 x 768

I see that i've no PEGP nor HDAU devices. Is that a problem?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
It is ivy bridge

Intel i7 3632qm

MB chipset hm76

Graphics HD4000 built in screen res 1366 x 768

I see that i've no PEGP nor HDAU devices. Is that a problem?
You don't have to worry about HDAU for Ivy laptops.

Use:
"HD4000 Low Resolution"

and:
"Audio Layout 12" (change layout-id to match your AppleHDA)

Make sure you adjust your profile to reflect your specs.
 
Joined
May 2, 2014
Messages
95
Motherboard
Bangho Max 1524 (Clover)
CPU
i7-3632qm/HM76
Graphics
Intel HD4000/1366x768
Mac
MacBook Pro
Mobile Phone
iOS
Yes!
those are de patches i applied in the beginning and when erasing HDAEnabler sound started working but never with any patch nor using voodooHDA i was able to get audio in HDMI out on led tv
This is the one thing that troubles my mind

Already donde the patch for Appleintelframbufercapri that you suggested

That's why i was trying with toleda patchs and setting PEGP and HDAU


i don't know what else to do.i'll keep trying to find the solution

thank you for all your efforts

bye
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Yes!
those are de patches i applied in the beginning and when erasing HDAEnabler sound started working but never with any patch nor using voodooHDA i was able to get audio in HDMI out on led tv
This is the one thing that troubles my mind

Already donde the patch for Appleintelframbufercapri that you suggested

That's why i was trying with toleda patchs and setting PEGP and HDAU


i don't know what else to do.i'll keep trying to find the solution

thank you for all your efforts

bye
Did you repair permissions & rebuild cache after doing the capri patch?
Do you see the HDMI output device in SysPrefs->Sound when one is connected?

Post ioreg: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html
 
Joined
May 2, 2014
Messages
95
Motherboard
Bangho Max 1524 (Clover)
CPU
i7-3632qm/HM76
Graphics
Intel HD4000/1366x768
Mac
MacBook Pro
Mobile Phone
iOS
Did you repair permissions & rebuild cache after doing the capri patch?
Do you see the HDMI output device in SysPrefs->Sound when one is connected?

Post ioreg: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html
So
i did rebuild cache and repair perms

not working
i have always Internal Speakers and Digital Out on Syspref/Sound/Outs

Here is copy of ioreg when HDMI led conected

My dsdt is now whit IGPU rename patch and Toleda HD4000 laptop, now i'll try repatching with your HD4000 low res

bye
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
So
i did rebuild cache and repair perms

not working
i have always Internal Speakers and Digital Out on Syspref/Sound/Outs

Here is copy of ioreg when HDMI led conected

My dsdt is now whit IGPU rename patch and Toleda HD4000 laptop, now i'll try repatching with your HD4000 low res

bye
Make sure you apply the patch against vanilla AppleIntelFramebufferCapri.kext. Verify the patch actually has an effect by comparing md5 of AppleIntelFramebufferCapri before and after the patch.

You should not see a digital out unless HDMI is connected. If you see otherwise, indicates problem with your patched AppleHDA.
 
Joined
Jan 30, 2014
Messages
6
Motherboard
Clevo W650SH
CPU
intel core i7-4700 @ 2.40ghz
Graphics
Intel HD4600
Mac
Classic Mac
Mobile Phone
Koalaman, thanks for posting your experiences trying to get OSX on the Clevo w670szq .
I've got a very similar laptop and have been struggling to get it booting after installation, even after applying all patches. This was months ago so I forget what exactly went wrong.
Any chance you'll be posting that guide you mentioned? Did you manage to get it fully working?

Cheers!



---
Clevo w650SH
intel core i7-4700 @ 2.40ghz
Graphics Card
NVIDIA® GeForce® GT 740M - 2.0GB DDR3 RAM
Intel 4th Gen Integrated Graphics Controller (rev 6)
SSD & SATA HDD
MOBO W65_67SH
Bios AMI v1.0.03 (12/04/2013)
16gb ram
Windows 7/Ubuntu 14.04 dual boot
 
Joined
Jul 19, 2012
Messages
1,865
Mac
Classic Mac
Mobile Phone
iOS
More or less it was fully working. I'm not sure how useful a guide would be, but give me a day to post all my source files for audio etc.
 
Top