Contribute
Register

Mac OS X 10.6.3 Update - The Official Thread

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,566
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
MTGhost said:
I also updated to 10.6.3. From looking at the spreadsheet no one has a setup like mine. I still haven't found a fix for the F8 BIOS and the F8 DSDT not working. I tried the F8 DSDT after the 10.6.3 update and I still get a kernel panic. If I keep the F7 DSDT everything works OK.

After the 10.6.3 update my sound (889a) and USB devices work fine when I initially boot my computer. If I shutdown my computer before it goes into sleep mode it will shutdown properly. I have a wired mouse and keyboard.

The problems arise after my computer goes into sleep mode. When I bring it out of sleep mode my keyboard doesn't work. The mouse works fine. Also, my computer will not go back into sleep mode. It shuts down as if it is going into sleep mode and then comes right back on. When I shut down my computer at this point it goes into a mode where it isn't off and I can't get it to come back on with either a mouse or keystroke. I have to hold the power until is completely shuts down. I unchecked the Allow power button to put computer to sleep and that didn't make any difference.

I'll check out the F8 DSDT- should be ok though.

As far as USB goes, roll back to the 10.6.2 IOUSBFamily as stated in the blog post, and you should have no such errors. Good luck!
http://tonymacx86.blogspot.com/2010/03/ ... pdate.html
 
Joined
Jan 16, 2010
Messages
75
Mac
Classic Mac
Mobile Phone
For now the best solution for me is to configure the dsdt to have just two EHC ports
just like fatsenanigen said (as in iMac's 11,1)
the only problem is that it can't mount USB 1.0 devices which I "solved" by hooking them to the hub in my Dell LCD (this is why iMac's ehc ports can mount USB 1.0 ports - they use a HUB). other USB 2.0 work's just fine no matter where they are plugged, they are appearing under one of the EHC ports.
there is a discussion about the subject in applelife.ru forum which have couple of suggestions for dsdt edits that may solve this but I haven't succeeded so far.
I believe (or hope) that Gigabyte will address this issue in future bios
(as they did with audio and rtc in latest bios releases)
 
Joined
Mar 22, 2010
Messages
5
Motherboard
osx 10.6.8
CPU
Core2Duo
Graphics
x3100
Mac
Classic Mac
Mobile Phone
Tony I have a problem.
After the upgrade to version 10.6.3 my sound is not working as it should.
Sound strange belches. you have any advice on this?
I use VoodooHDA. My system is 64 bit
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,566
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
osxuser said:
Tony I have a problem.
After the upgrade to version 10.6.3 my sound is not working as it should.
Sound strange belches. you have any advice on this?
I use VoodooHDA. My system is 64 bit

If you post your specs, I'd be able to help better- there are also current audio solutions at the 10.6.3 Update post on my blog. VoodooHDA hasn't been an issue with the 10.6.3 update though- you should boot into 32-bit mode and see if it makes a difference. Good luck! :mrgreen: :ugeek:
 
Joined
Mar 22, 2010
Messages
5
Motherboard
osx 10.6.8
CPU
Core2Duo
Graphics
x3100
Mac
Classic Mac
Mobile Phone
Tony tell me what you write you could help me
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,566
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
osxuser said:
Tony tell me what you write you could help me

Well- the answer can change depending on your computer specs- please post your system components in your signature- under Control Panel. It's in the Menu Bar near the top of this page. ;)

If you're referring to how to enable 32-bit, type arch=i386 at the Chameleon prompt. Or add arch=i386 to your com.apple.boot.plist under Kernel Flags. Good luck!
 
Joined
Feb 27, 2010
Messages
26
Mac
Classic Mac
Mobile Phone
Fresh install of 10.6.0, using BootCD method. Once 10.6.0 was up and running I then updated to 10.6.3 and used MultiBeast with the following settings:

Chameleon
Chamelion 2.0 RC4 by AsereBLN
Audio
VoodooHDA
Network
RealtekR1000SL
DSDT
DSDT -GA-P55A-UD3
Extras
64-Bit com.apple.boot.plist
iMac11,1 smbios.plist
tonymacx86 Theme
Standard Snow Leopard Kexts
fakesmc.kext
JMicronATA.kext
Utilities
ShowAllFiles
Kext Utility
Disk Utilities
Rebuild Caches
Repair Permissions

Bios settings are as recommended in BootCD tutorial.

Looking at my Extra's folder there seems to be a lot of extra things in there that MultiBeast did not install

10.6.3 Geekbench score is 7629, 10.6.0 score was 7964, both of these numbers seem low for the specs that I have.

Everything except sleep and wake from sleep is working (using a USB audio adaptor for sound).
Any ideas on getting sleep working would be appreciated.
 

Attachments

  • screenshot_01.jpg
    screenshot_01.jpg
    95.4 KB · Views: 122

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,566
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Crucial said:
Bios settings are as recommended in BootCD tutorial.

Looking at my Extra's folder there seems to be a lot of extra things in there that MultiBeast did not install

You can go ahead and remove most of the kexts in your /Extra. I think you may have installed all of the Snow Leopard Kexts instead of just some. Or maybe you chose EasyBeast by mistake? All you need is fakesmc.kext really. The NullCPUPowerManagement kext prevents sleep. Good luck- and if you need to compare- check out the files in MY EFI in my signature. It's a good pack for any Gigabyte with nVidia and no graphics edits to the DSDT. You may or may not need NVenabler.

Good luck!
 
Joined
Feb 27, 2010
Messages
26
Mac
Classic Mac
Mobile Phone
Tony,
Big thank you.
Sleep now works correctly with no USB problems.

Extras / Extensions is down to:
fakesmc.kext
JMicronATA.kext
LegacyHDA_ALC888B.kext

Geekbench is up to 8575 (up by over 900 points).

The one step backwards is that my boot drive is now orange, but that is not a big deal.
 
Joined
Jan 13, 2010
Messages
28
Mac
Classic Mac
Mobile Phone
:) Hi Tony

Today I updated my iMac ;) to 10.6.3
Also I installed Chameleon RC4-AsereBLN-1.1.9

Everything works fine now
I have no issues at all

Mine's a vanilla system :lol:




******************************************************************
I chose these components to assemble a PC so that it matches latest iMac 27"

Intel DP55WG MainBoard/ Intel Core i5-750 Processor
2 x2 GB DDR3 RAM @ 1333/ 2x 500GB SATA HDD/ 24X Optiarc DVD Writer
512 MB XFX nVidia 9800GT card/ 22" Dell S2209W Display
 

Attachments

  • About Mac.tiff
    34.6 KB · Views: 212
Top