Contribute
Register

Mac OS X 10.6.3 Update - The Official Thread

Joined
Feb 4, 2010
Messages
106
Motherboard
Hackintosh ?
CPU
Intel Core i7-860
Graphics
GeForce GTS 250
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Replied in that thread.

That didn't work either.
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,555
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Musicalchairs said:
Replied in that thread.

That didn't work either.

Ouch- sorry about that. Well- checked out that DSDT- the edits seem correct, although I don't have any board with 889 to test. I guess you might try VoodooHDA- there is a new version that look promising. I may try to make a kext just for the 88x series.
 
Joined
Feb 4, 2010
Messages
106
Motherboard
Hackintosh ?
CPU
Intel Core i7-860
Graphics
GeForce GTS 250
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Do i need LEGACYHDA in /E/E if i try VOODOOHDA ?
Where is this new version ?

By the way. Multibeast didn't allow me to install HDAEnabler 889. Came up with an error before rebuilding cache & repairing permissions.

Had to do it myself with KEXT HELPER & then used MULTIBEAST to rebuild cache and repair permissions
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,555
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Musicalchairs said:
Do i need LEGACYHDA in /E/E if i try VOODOOHDA ?
Where is this new version ?

By the way. Multibeast didn't allow me to install HDAEnabler 889. Came up with an error before rebuilding cache & repairing permissions.

Had to do it myself with KEXT HELPER & then used MULTIBEAST to rebuild cache and repair permissions

Ah- that bug is solved in the new one. You won't need LegacyHDA or HDAEnabler if you use VoodooHDA. Here's the VoodooHDA post for a version that's currently being developed. The link is near the bottom of the post- and you'll need to translate the page to make heads or tails out of it. ;)
http://www.projectosx.com/forum/index.php?showtopic=483

Haven't had a chance to test- but it looks really decent- possibly will be changing the name as well. Here's a post of a user here:
viewtopic.php?f=16&t=915&hilit=voodoohda
 
Joined
Apr 2, 2010
Messages
3
Mac
Classic Mac
Mobile Phone
Hi Everyone. First off here are my specs

motherborad asus gene II
process i7 930
Video Card nvidia 250 GTS

I upgraded to 10.6.3 , and everything is working except for my sound. The sound was working before I upgraded. For my specific board, the only one that works is the voodoo text that I found here: http://www.insanelymac.com/forum/index. ... pic=201758

I tried downloading the new voodoo that was on this thread (a few posts above me that tony mentioned), but it caused my system to crash at startup. I had to restart in safemode, and delete the kext.

I tried using the 10.6.2 hda installer that only provided, but after installation I still have no sound.

Has anyone else had any luck to get there sound working? I also tried all other methods, legacy, and whatever else was on tonys blog, but they didn't seem to work. I use this machine for video editing, so I need sound. I'm thinking about downgrading back to 10.6.2.

Is there anyway to downgrade without having to use time machine (I didn't use it to backup my hd)... Yes I know, big mistake.

I'm really looking to stay on the newest update thought. Let me know if anyone has figured out how to make sound work on the 10.6.3 with my board.

Thanks guys!
 
Joined
Feb 4, 2010
Messages
106
Motherboard
Hackintosh ?
CPU
Intel Core i7-860
Graphics
GeForce GTS 250
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
tonymacx86 said:
Musicalchairs said:
Do i need LEGACYHDA in /E/E if i try VOODOOHDA ?
Where is this new version ?

By the way. Multibeast didn't allow me to install HDAEnabler 889. Came up with an error before rebuilding cache & repairing permissions.

Had to do it myself with KEXT HELPER & then used MULTIBEAST to rebuild cache and repair permissions

Ah- that bug is solved in the new one. You won't need LegacyHDA or HDAEnabler if you use VoodooHDA. Here's the VoodooHDA post for a version that's currently being developed. The link is near the bottom of the post- and you'll need to translate the page to make heads or tails out of it. ;)
http://www.projectosx.com/forum/index.php?showtopic=483

Haven't had a chance to test- but it looks really decent- possibly will be changing the name as well. Here's a post of a user here:
viewtopic.php?f=16&t=915&hilit=voodoohda

Tested that VOODOOHDA + PREF PANE and it crashed my system.
Wouldnt allow me to boot back into OSX.
Didn't think to start in SAFEMODE and delete the kext & pref pane that came with it.

Glad I didnt though, cause I just got back after reinstalling and updating my system to 10.6.2.

Everything works the way it should (Vanilla), except for sound which is using LEGACYHDA in /E/E & HDAENABLER in /S/L/E.

As Vanilla as I can be with a working DSDT

If I update to 10.6.3 while on a P55A-UD6 with DSDT (DSDT includes EDITS FOR 10.6.2)

- I will have to revert back to 10.6.2 APPLEHDA to keep sound working.
- Fix SATA showing as EXTERNAL when they are INTERNAL by placing IOAHCIBlockStorageInjector.kext in /E/E
- Hang out for DSDT edits/A Fix for LOSS OF POWER TO USB after WAKE FROM SLEEP

Good job so far Tony and Forum, if it wasn't for all of you I wouldnt have been able to REINSTALL and get back to the HAPPY PLACE I find myself now as a devoted 10.6.2 OSX user :)
 
Joined
Feb 8, 2010
Messages
163
Motherboard
Gigabyte GA-Z87X-UD4H
CPU
i5-4670K
Graphics
RX 580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
found this thread http://www.insanelymac.com/forum/lofive ... 83101.html detailing a change in an Info.plist in IOAHCIFamily.kext which prevents internal SATA hard drives from showing as external. although its not a 'vanilla' solution like IOAHCIBlockStorageInjector as involves editing an Apple kext.

the plist is attached below and belongs in /System/Library/Extensions/IOAHCIFamily.kext/Contents/PlugIns/IOAHCIBlockStorage.kext/Contents/
 

Attachments

  • Info.plist
    2.1 KB · Views: 207
Joined
Mar 5, 2010
Messages
21
Mac
Classic Mac
Mobile Phone
...Personally, I have 4 installs personally lol, mostly for more testing. :)

Fantastic simple idea! I'm going to create a test install for upgrades right now!
 

beelzebozo

Super Moderator
Joined
Mar 31, 2010
Messages
3,731
Motherboard
ASUS z170-Deluxe
CPU
i7 - 6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
wtfduck said:
Hi Everyone. First off here are my specs

motherborad asus gene II
process i7 930
Video Card nvidia 250 GTS

I upgraded to 10.6.3 , and everything is working except for my sound. The sound was working before I upgraded. For my specific board, the only one that works is the voodoo text that I found here: http://www.insanelymac.com/forum/index. ... pic=201758

I tried downloading the new voodoo that was on this thread (a few posts above me that tony mentioned), but it caused my system to crash at startup. I had to restart in safemode, and delete the kext.

I tried using the 10.6.2 hda installer that only provided, but after installation I still have no sound.

Has anyone else had any luck to get there sound working? I also tried all other methods, legacy, and whatever else was on tonys blog, but they didn't seem to work. I use this machine for video editing, so I need sound. I'm thinking about downgrading back to 10.6.2.

Is there anyway to downgrade without having to use time machine (I didn't use it to backup my hd)... Yes I know, big mistake.

I'm really looking to stay on the newest update thought. Let me know if anyone has figured out how to make sound work on the 10.6.3 with my board.

Thanks guys!

did you try the voodoo kext on multibeast?

I didn't have to change any audio kexts when i went from 10.6.0 to 10.6.3.. i used the one from multibeast.
 
Top