Contribute
Register

Mac os Sierra Screen flickering after sleep problem

Status
Not open for further replies.
Joined
Jan 14, 2014
Messages
4
Motherboard
MSI Z170M Mortar
CPU
i7-6700K
Graphics
GTX 1060
specs>
i7 6700k
gtx 1060 with nvidia web drivr running and cuda support
8 gb ram
msi z170m mortar

After wake up from sleep and log in,when first time swich to other desktop screen start to flicker,that does not happen if pc wasnt put to sleep.After reconecting hdmi cable screen bring back to normal.

18575928_2300340316857277_263522325_o.jpg
 
Joined
Jun 9, 2013
Messages
10,755
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Joined
Jun 9, 2013
Messages
10,755
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
I must use nullpowermanagment becouse of overclocked cpu.

You do not need NullCPUPowermanagement with Clover. Overclocking requires a Patched SSDT i don't recommend Overclocking with OS X/macOS anyway. Cant expect sleep to work without implementing Native Powermanagement.
 

etx

Joined
May 21, 2017
Messages
32
Motherboard
GA-Z270X-Ultra Gaming
CPU
i7-7700K
Graphics
GTX 1060+Vega 56
Mac
  1. MacBook Pro
I'm having the exact same issue with a new build. First hackintosh in 10 years! It's working great except for this one glitch. Did you figure anything out?

intel i7-7700k
Gigabyte z270x-ultra MB
32 GB Ram
EVGA Nvidia 1060 6GB working with the Nvidia Web Drivers

Got it hooked up to a LG widescreen display over Display Port.

It happens when the machine wakes from sleep. If I simply turn the monitor off and back on it seems to reinitialize and everything is fine.
 
Joined
Jan 14, 2014
Messages
4
Motherboard
MSI Z170M Mortar
CPU
i7-6700K
Graphics
GTX 1060
I'm having the exact same issue with a new build. First hackintosh in 10 years! It's working great except for this one glitch. Did you figure anything out?

intel i7-7700k
Gigabyte z270x-ultra MB
32 GB Ram
EVGA Nvidia 1060 6GB working with the Nvidia Web Drivers

Got it hooked up to a LG widescreen display over Display Port.

It happens when the machine wakes from sleep. If I simply turn the monitor off and back on it seems to reinitialize and everything is fine.
nope,i tried conecting another display with dvi cable and all seams to be ok,but when i again conect my main display and wake up from sleep problem appears and turning off/on doesnt slove problem ,but it instantly gone when unplug hdmi cable and again plug it in.Maybe my hdm to vga adapter is makeing problem.I will try to adapt dvi to vga, becouse i allready tried everything what VoiletDragon said and that i think can affect to this.
 

etx

Joined
May 21, 2017
Messages
32
Motherboard
GA-Z270X-Ultra Gaming
CPU
i7-7700K
Graphics
GTX 1060+Vega 56
Mac
  1. MacBook Pro
I wonder if this is just a bug in the Nvidia web drivers for Pascal as they are so new?
 
Joined
Jan 14, 2014
Messages
4
Motherboard
MSI Z170M Mortar
CPU
i7-6700K
Graphics
GTX 1060
I wonder if this is just a bug in the Nvidia web drivers for Pascal as they are so new?
I can check if its related to web driver by disabling it and using pc after sleep,but it seams that the solution is using it without sleep mode for a while.btw sorry for bad english
 

etx

Joined
May 21, 2017
Messages
32
Motherboard
GA-Z270X-Ultra Gaming
CPU
i7-7700K
Graphics
GTX 1060+Vega 56
Mac
  1. MacBook Pro
The graphics without the web driver are even more glitchy so I don't think that will help. I'm just going to deal with having to reset my display every time I wake it. I'd rather save money on my utility bills.

Hopefully an updated driver in the future will remedy the issue.
 

etx

Joined
May 21, 2017
Messages
32
Motherboard
GA-Z270X-Ultra Gaming
CPU
i7-7700K
Graphics
GTX 1060+Vega 56
Mac
  1. MacBook Pro
After some more testing tonight I found that disabling the auto-logout under security in the System Prefs > Security & Privacy > General I do not get the graphics glitch anymore. So I guess it's something to do with the login view so this just bypasses it.

Good enough fix for now! Sleep working well and no more glitch with a Kabylake chipset.

Scratch that, after a longer sleep it appears to still be doing it.
 
Last edited:
Status
Not open for further replies.
Top