Contribute
Register

Mac Audio - my Hackintosh based Music Player

Status
Not open for further replies.
Joined
Dec 15, 2011
Messages
907
Motherboard
Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
CPU
i5-2500K, i3-3225, i7-3770S
Graphics
HD 3000, HD 4000, HD 5000
Mac
  1. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Thanks!

A little update:

The case still did not arrive...:beachball: In the meantime, I've done the following:
-Updated to Multibeast 5.3 -> Everything works. The only issue is, that the power LED sometimes stays on instead of blinking while sleep (as before) Any suggestions?

-The BT and WiFi Modules arrived
Mac Audio BT and WiFi.jpg

Wifi works perfectly, but the BT module was vexation and fried the 3.3VSB pin on my custom solutions header...:banghead: (see next post)

-Drilled a third hole for the antennas (two for WiFi, one for BT)
Mac Audio Antenna mounting (G4-Cube.locals in Konflikt stehende Kopie 2016-12-13).jpg


-The ATV died today and I had to do an "emergency replacement"
Mac Audio emegrency replacemenmt.jpg


MacTester
 
Last edited:
Joined
Dec 15, 2011
Messages
907
Motherboard
Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
CPU
i5-2500K, i3-3225, i7-3770S
Graphics
HD 3000, HD 4000, HD 5000
Mac
  1. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Tonight, I've "saved" the DQ77KB's life... The whole story: a few weeks ago, I've connected the BT module as I did it for my G5 & G4 Cube project.
Red = 3.3V
Black = GND
Yellow = USB +
Green = USB -
This was no good idea... Why?? Apple engineers are clever and change the wire colors sometimes! :banghead: :thumbdown: The DQ77BK did not boot and sent a bad smell to my nose instead... Fortunately "only" the 3.3VSB pin on the "Custom Solutions" header was killed. Everything else still works normal.

To allow the reuse of the poor "harmed" DQ77KB, I've done the following:

1. No more connections to the DQ77KB before I know, if everything is correct.... Here is the correct (for this module) pinout - Tested on my old DP35DP MOBO:
Black = 3.3V (stupid)
Red = GND (stupid too)
Yellow = USB -
Green = USB +
Mac Audio BT 1.jpg


2. Solder a 3.3V voltage regulator into the wiring and use the 5VSB pin on the CS header
Mac Audio BT 2.jpg


Mac Audio BT 3.jpg


Everything works flawless now - but the case still did not arrive... :beachball:

MacTester
 
Last edited:
Joined
May 27, 2012
Messages
767
Motherboard
DQ77KB
CPU
i7-3770S
Graphics
HD4000
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Tonight, I've "saved" the DQ77KB's life...

2. Solder a 3.3V voltage regulator into the wiring and use the 5VSB pin on the CS header
Everything works flawless now - but the case still did not arrive... :beachball:

MacTester
Sorry to hear about your mishap. Still no case, what a bummer. FYI I came across this on ebay recently, it has the voltage regulator and capacitors (SMD components) on a small board.

http://www.ebay.com.au/itm/271147139358
 
Joined
Dec 15, 2011
Messages
907
Motherboard
Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
CPU
i5-2500K, i3-3225, i7-3770S
Graphics
HD 3000, HD 4000, HD 5000
Mac
  1. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Thanks for this link. They are incredible cheap...

MacTester
 
Joined
Nov 25, 2010
Messages
1,210
Motherboard
MSI Z77MA-G45
CPU
i7-3770k @ 4.3 GHz
Graphics
R9 280X
Mobile Phone
  1. Android
Black = 3.3V (stupid)
Red = GND (stupid too)
Yellow = USB -
Green = USB +

Black = 3.3v and Red=GND ???

Is it an A1181 BT, Mactester?

I've done 5 of these into four different motherboards and have never had any issue with red going to 3.3v power and black to ground.

The D+ and D- I have accidentally reversed too, but all that happened was a missing BT in the Sys Info screen.

Very strange.
 
Joined
Dec 15, 2011
Messages
907
Motherboard
Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
CPU
i5-2500K, i3-3225, i7-3770S
Graphics
HD 3000, HD 4000, HD 5000
Mac
  1. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Joined
Nov 25, 2010
Messages
1,210
Motherboard
MSI Z77MA-G45
CPU
i7-3770k @ 4.3 GHz
Graphics
R9 280X
Mobile Phone
  1. Android
It's too bad that your CS 3.3 supply got toasted.

That sucks.

Not much surprises me anymore with hardware, but this issue sure did.
 
Joined
Nov 25, 2010
Messages
1,210
Motherboard
MSI Z77MA-G45
CPU
i7-3770k @ 4.3 GHz
Graphics
R9 280X
Mobile Phone
  1. Android
Yes, I'm 100% sure about that. They are just crazy!


Yes. This is the module which I've bought:
http://rover.ebay.com/rover/0/e1140...tem=190813763736&ssPageName=ADME:L:OU:CH:3160

It's the third BT module that I've used for a Hack and have never seen such a crap before... :banghead:

MacTester


MacTester I have attached a pic of the BT module that I used in all 3 of my Cubes. You can clearly see that the pinout on the module is a direct reversal of the one shown in your photos. The red power wire is opposite to the antenna side. On your module, the red wire is on the antenna side of the chip. The sequence of red/green/yellow/black is the same, except its in reverse order on the plug compared to my photo below.


screenshot48oa.jpg



That likely explains the fact that you've essentially got yours set up 'backwards' to get it to work. Maybe have a peek at your other A1181's to see if they're the same as mine pictured here.

Why it fried your 3.3V header, I have no idea. Maybe due to power running in reverse??? If this is something to watch for, I want to nail this issue down to prevent it from happening again. Unfortunately you were the unlucky one this time.
 
Joined
Dec 15, 2011
Messages
907
Motherboard
Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
CPU
i5-2500K, i3-3225, i7-3770S
Graphics
HD 3000, HD 4000, HD 5000
Mac
  1. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
I have only one realistic explanation for this issue. The worker on the cable confection machine had a bad day and inserted the cable the wrong way. No one noticed that, because the connectors were fitted the wrong way on both ends of the cable harness ...

... but then, a couple of years later, MacTester had the idea to cut off one of those connectors... :banghead:

MacTester
 
Joined
Nov 25, 2010
Messages
1,210
Motherboard
MSI Z77MA-G45
CPU
i7-3770k @ 4.3 GHz
Graphics
R9 280X
Mobile Phone
  1. Android
Sad but true. Wonder if that eBay vendor even knows ?

At least now we know to watch for this next time.
 
Status
Not open for further replies.
Top