Contribute
Register

M.2 (single-sided type) Wi-Fi/Bluetooth Solution

Joined
Oct 23, 2016
Messages
331
Motherboard
HP EliteBook 1030 G1 (Clover)
CPU
m7-6Y75
Graphics
HD515, 3200x1800
Workaround:
Wi-Fi:

[14e4:43a3] on hackintosh may have problem after 10.11.x. I found IO80211Family.kext in 10.10.5 (see attached file) can works on 10.11.6, 10.12.6, 10.13.5, 10.14, but it may cause panic.
Of course, many of the older kexts may not compatible with the latest versions of OS X/macOS.
Below KernelToPatches found in google can solve the panic:
Code:
                                <key>Comment</key>
                                <string>disable Invalid waitq panic, 10.11.6</string>
                                <key>Disabled</key>
                                <false/>
                                <key>Find</key>
                                <data>
                                SI09lHlkADHASIne
                                </data>
                                <key>MatchOS</key>
                                <string>10.11.6</string>
                                <key>Replace</key>
                                <data>
                                uAQAAADpfQAAAJCQ
                                </data>

                                <key>Comment</key>
                                <string>disable Invalid waitq panic, 10.12.6</string>
                                <key>Disabled</key>
                                <false/>
                                <key>Find</key>
                                <data>
                                SI09A4djADHASIne
                                </data>
                                <key>MatchOS</key>
                                <string>10.12.x</string>
                                <key>Replace</key>
                                <data>
                                uAQAAADpnwAAAJCQ
                                </data>

                                <key>Comment</key>
                                <string>disable Invalid waitq panic, 10.13.5</string>
                                <key>Disabled</key>
                                <false/>
                                <key>Find</key>
                                <data>
                                SI09miNqADHASIne
                                </data>
                                <key>MatchOS</key>
                                <string>10.13.x</string>
                                <key>Replace</key>
                                <data>
                                uAQAAADpnwAAAJCQ
                                </data>

                                <key>Comment</key>
                                <string>disable panic("Invalid waitq: %p", waitq), 10.14</string>
                                <key>Disabled</key>
                                <false/>
                                <key>Find</key>
                                <data>
                                SI09BPFyADHASIne
                                </data>
                                <key>MatchOS</key>
                                <string>10.14.x</string>
                                <key>Replace</key>
                                <data>
                                uAQAAADppwAAAJCQ
                                </data>
BlueTooth:
[0a5c:6412] also has problems. Solution:
  1. If losing BT (not found in BIOS), remove AC adapter then plug it back, BT found in BIOS again.
  2. When power on, in clover GUI, must rebooting using clover reboot button or press R to reboot clover
  3. Using Tluck's DEBUG version BrcmPatchRAM
  4. Must boot verbose, BT works.
Notice
  • MacBook Retina
  • [14e4:43a3] hardware
  • plan to buy above
Overview
DW1820A [14e4:43a3] was natively supported by OS X/macOS, but it has problems with certain laptops.
The purpose of this thread is try to solve these problems.
Contents are under construction.
WikiDevi
Background
I/O Kit driver
IO80211Family.kext
AirPortBrcm4360.kext
Disassemble
Code:
$ otool -tVj
Debug
Code:
msgbuf=1024000 debug=0xFF7 wl_msg_level=0xFFFFFFFF wl_msg_level2=0xFFFFFFFF keepsyms=1
Working Status
HP EliteBook 1030 G1 10.11.6 no problems
HP Elitebook Folio 1020 G1 10.10.x no problems
HP Elitebook Folio 1020 G1 10.11.6 two problems
Problem 0:
Code:
00000000000192ff        49 8b bf 18 05 00 00    movq    0x518(%r15), %rdi
0000000000019306        be 10 00 00 00  movl    $0x10, %esi
000000000001930b        ba 04 00 00 00  movl    $0x4, %edx
0000000000019310        e8 8a 67 ff ff  callq   _osl_pci_read_config
0000000000019315        83 f8 04        cmpl    $0x4, %eax
0000000000019318        0f 85 9a 00 00 00       jne     0x193b8
000000000001931e        45 84 e4        testb   %r12b, %r12b
0000000000019321        74 38   je      0x1935b
0000000000019323        48 8d 05 e6 62 64 00    leaq    _wl_msg_level(%rip), %rax
000000000001932a        8b 18   movl    (%rax), %ebx
000000000001932c        41 8b b7 b8 14 00 00    movl    0x14b8(%r15), %esi
0000000000019333        48 8d 3d 12 1c 47 00    leaq    0x471c12(%rip), %rdi ## literal pool for: "WLAN adapter PCIE config space was not restored (stateNumber = %d)\n"
Code:
ARPT: 5.946631: WLAN adapter PCIE config space was not restored (stateNumber = 2)
ARPT: 5.956237: wl0: fatal error, reinitializing, total count of reinit's[1], @'wl_nocard_war':4312
common error, solved.
 

Attachments

Last edited:
Joined
Aug 3, 2012
Messages
12
Motherboard
HP 250 G6
CPU
Kaby Lake 2.9ghz Intel Core i7
Graphics
Intel HD Graphics 620 1536MB
Mac
MacBook
Hi Livacore,

I had this card (dw1820A) lying around, so I placed it in my HP 250 G6. I had the issue where the laptop refused to boot. So I followed your advice on this thread, using your attached kext, and applied the patches you provided to prevent any KP's on boot.
I can now boot to osx (10.13.3). I also have working WIFI and Bluetooth.

Sometimes OSX will boot with no errors at all, however, I do get random restarts when I start OSX using this kext. What I noticed was on startup/rebooting, OSX would sometimes take 2 or 3 reboot attempts to get back to the desktop, as I would get random kernel panics for a WAITQ relating to the IO80211Family. I assume this is because of the incompatibility you mentioned. The patches I applied from this thread don't seem to prevent the random KP reboot every time. Did you get anywhere with the vanilla 10.13.x version of IO80211Family.kext?

Thanks for the solution. I can at least use WIFI and Bluetooth natively now.
 
Joined
Oct 23, 2016
Messages
331
Motherboard
HP EliteBook 1030 G1 (Clover)
CPU
m7-6Y75
Graphics
HD515, 3200x1800
Hi Livacore,

I had this card (dw1820A) lying around, so I placed it in my HP 250 G6. I had the issue where the laptop refused to boot. So I followed your advice on this thread, using your attached kext, and applied the patches you provided to prevent any KP's on boot.
I can now boot to osx (10.13.3). I also have working WIFI and Bluetooth.

Sometimes OSX will boot with no errors at all, however, I do get random restarts when I start OSX using this kext. What I noticed was on startup/rebooting, OSX would sometimes take 2 or 3 reboot attempts to get back to the desktop, as I would get random kernel panics for a WAITQ relating to the IO80211Family. I assume this is because of the incompatibility you mentioned. The patches I applied from this thread don't seem to prevent the random KP reboot every time. Did you get anywhere with the vanilla 10.13.x version of IO80211Family.kext?

Thanks for the solution. I can at least use WIFI and Bluetooth natively now.
Hi, this solution is to make dw1820A working at least.
To debug, make sure the patch is applied, and post kernel panic log.
 
Joined
Nov 28, 2016
Messages
71
Motherboard
Medion E6424 - Clover
CPU
i5-6267U
Graphics
HD 550 1920x1080
Mac
MacBook Pro
@livacore
What causes the actual incompatibility on certain laptops? It would be great to find a solution to patch through DSDT
 
Joined
Mar 16, 2013
Messages
45
Motherboard
Nexstgo NS14N1HK005P
CPU
i5-8250U
Graphics
HD 620
before the kernel patch, my laptop will boot 1 in 3 times, now everything works, but still panic sometimes
 
Joined
Jun 4, 2017
Messages
24
Motherboard
HP 14 ac-132la - F.27 Rev.A - Clover
CPU
i7-6500U
Graphics
HD 520 1366x768
Mac
MacBook Pro
Mobile Phone
Android
Hi guys.. Another solution that I found out was to modify the Mojave 4360 kext, adding in its entries of "IONameMatch" = "pci14e4,43a3" to load the driver for this card.
In order for this to work I deleted the new drivers, AirPortBrcmNIC.kext and AirPortBrcmNIC-MFG.kext found in S/L/E and within the IO802 kext.
Remember update caches..

With this card, all is experimentation, but I love it...
Keep me posted if someone find it useful and your experience..
 
Joined
Mar 16, 2013
Messages
45
Motherboard
Nexstgo NS14N1HK005P
CPU
i5-8250U
Graphics
HD 620
Hi guys.. Another solution that I found out was to modify the Mojave 4360 kext, adding in its entries of "IONameMatch" = "pci14e4,43a3" to load the driver for this card.
In order for this to work I deleted the new drivers, AirPortBrcmNIC.kext and AirPortBrcmNIC-MFG.kext found in S/L/E and within the IO802 kext.
Remember update caches..

With this card, all is experimentation, but I love it...
Keep me posted if someone find it useful and your experience..
is the speed mixed at 300Mbps?
 
Joined
Mar 16, 2013
Messages
45
Motherboard
Nexstgo NS14N1HK005P
CPU
i5-8250U
Graphics
HD 620
can someone explain how those kernel patch works, it's working very good on my macOS 10.14.0 but i want to update to 10.14.1
 
Joined
Jun 4, 2017
Messages
24
Motherboard
HP 14 ac-132la - F.27 Rev.A - Clover
CPU
i7-6500U
Graphics
HD 520 1366x768
Mac
MacBook Pro
Mobile Phone
Android
@Hugotai man.
I had to remove this patch, because even with it, it keeps crashing my system. I'm on 10.14.1.
I use the method above or the SSDT patch to spoof the card so it loads the right driver in order to keep the installation vanilla.
 
Joined
Mar 16, 2013
Messages
45
Motherboard
Nexstgo NS14N1HK005P
CPU
i5-8250U
Graphics
HD 620
@Hugotai man.
I had to remove this patch, because even with it, it keeps crashing my system. I'm on 10.14.1.
I use the method above or the SSDT patch to spoof the card so it loads the right driver in order to keep the installation vanilla.
yea, there are still random crashes, but the system will be very slow after maybe 30 mins if i keep the mojave io80211family.kext and use the spoof id in dsdt, or add the 43a3 id to the 4360.kext, do you have this problem?
 
Top