Contribute
Register

m.2 Drives Showing as External

Status
Not open for further replies.
Joined
Mar 10, 2018
Messages
53
Motherboard
Asus x99 Deluxe II
CPU
i7-6950x
Graphics
Radeon 6800 XT
Mac
  1. MacBook
Mobile Phone
  1. iOS
Hello all,

I have two m.2 NVMe drives in my x99 Hackintosh build. Following the work of @kgp (and his guide linked below, section E.5) M.2/NVME Configuration), I edited SSDT-NVMe-extern-icon-patch.aml using correct values from IORegistry and was able to solve the issue for one external drive, but not both. I also tried editing the .aml file to copy/paste the sections and enter the values from IORegistry for the 2nd drive, but that does not work. Any thoughts on possible solutions?


My build follows (an older version of) this guide:
https://www.tonymacx86.com/threads/...high-sierra-10-13-on-x99-full-success.227001/

Asus x99 Deluxe II
i7 6950x
Aorus 1080 Ti Waterforce (PCIe_1)
NVMe x 2 (1 in PCIe_4, one in m.2 slot)
MacOS 10.13.5
Dual boot Windows 10
 
Joined
Mar 10, 2018
Messages
53
Motherboard
Asus x99 Deluxe II
CPU
i7-6950x
Graphics
Radeon 6800 XT
Mac
  1. MacBook
Mobile Phone
  1. iOS
Any thoughts on this? @RehabMan perhaps you have some insight?

Here's the code for the .aml file that works for one of my harddrives, but I'm not sure the syntax needed to edit it to be able to do more than one drive.


Code:
/*
 * Intel ACPI Component Architecture
 * AML/ASL+ Disassembler version 20160422-64(RM)
 * Copyright (c) 2000 - 2016 Intel Corporation
 *
 * Disassembling to non-symbolic legacy ASL operators
 *
 * Disassembly of iASLeYcZ1J.aml, Mon Jul  8 13:16:57 2019
 *
 * Original Table Header:
 *     Signature        "SSDT"
 *     Length           0x000000C4 (196)
 *     Revision         0x02
 *     Checksum         0x09
 *     OEM ID           "hack"
 *     OEM Table ID     "nvme"
 *     OEM Revision     0x00000000 (0)
 *     Compiler ID      "INTL"
 *     Compiler Version 0x20160422 (538313762)
 */
DefinitionBlock ("", "SSDT", 2, "hack", "nvme", 0x00000000)
{
    External (_SB_.PCI0.BR2D, DeviceObj)    // (from opcode)
    External (_SB_.PCI0.BR2D.H000._ADR, UnknownObj)    // (from opcode)

    Scope (\_SB.PCI0.BR2D)
    {
        Device (NVME)
        {
            Name (_ADR, Zero)  // _ADR: Address
            Name (_SUN, One)  // _SUN: Slot User Number
            Method (_INI, 0, NotSerialized)  // _INI: Initialize
            {
                Store (0x0F, \_SB.PCI0.BR2D.H000._ADR)
            }

            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {
                If (LEqual (Arg2, Zero))
                {
                    Return (Buffer (One)
                    {
                         0x03                                           
                    })
                }

                Return (Package (0x02)
                {
                    "built-in",
                    Buffer (0x0A)
                    {
                        "NVMe SSD"
                    }
                })
            }
        }
    }
}
 
Joined
Mar 10, 2018
Messages
53
Motherboard
Asus x99 Deluxe II
CPU
i7-6950x
Graphics
Radeon 6800 XT
Mac
  1. MacBook
Mobile Phone
  1. iOS
For anyone else that runs into this problem:

I was able to copy the entire patch .aml file and replace the values with the second drive.
 
Joined
May 14, 2019
Messages
19
Motherboard
Asus deluxe II (unlocked Bios)
CPU
i7-5930K
Graphics
rx580
can your share your EFI for asus deluxe II mod bios, please.
i do not have succes boot after following the work of @kgp
 
Status
Not open for further replies.
Top