Contribute
Register

Lost in HD Audio

Joined
Feb 8, 2016
Messages
13
Motherboard
Gigabyte H97-D3H
CPU
i5-4660
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Hey guys.

I try to get Audio via DP working. But right now I got lost. I don't know what is audio is installed and what should be installed.
Hopefully there is someone who can bring me back on track.

My Specs/Situation

Mainboard Audio is working fine. (See Picture, sry for german OS)
Display (DELL S2417DG is connected via DP to my GTX 1060)
Clover and Nvidia WEB drivers are up to date.
I read several guides and tried different things and probably installed a lot of things.
I think, I should see "DisplayPort" in Output Devices, right?

Any Help would be appreciated. Let me know if u need more specific details.

Regards Kenny

Bildschirmfoto 2018-03-11 um 17.08.01.png
 
Joined
Feb 8, 2016
Messages
13
Motherboard
Gigabyte H97-D3H
CPU
i5-4660
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
No native HDMI/DP audio on non native hardware.
See AppleHDA HDMI Audio/Post #1/cloverHDMI
I tried running this script again. Nothing changed. Output is:

Agreement
The audio_cloverHDMI script is for personal use only. Do not distribute
the patch, any or all of the files for any reason without permission.
The audio_cloverHDMI script is provided as is and without any warranty.

File: audio_cloverHDMI-130_v0.8.command
Release Mode
EFI partition is mounted
Password:
HDMI audio codec(s)
Nvidia: 0x10de0084
Integrated Graphics is not installed/enabled
Install AMD/Nvidia HDMI audio (y/n): y
Nvidia discrete graphics card 10de1c03 found on PEG0@1/GFX0@0
Nvidia HDMI audio is enabled
Script exits when another HDMI audio method is installed
Remove existing HDMI audio method, restart, run cloverHDMI
To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,101
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Nvidia HDMI audio is enabled
Script exits when another HDMI audio method is installed
Remove existing HDMI audio method, restart, run cloverHDMI
Ignored the script output.
 
Joined
Feb 8, 2016
Messages
13
Motherboard
Gigabyte H97-D3H
CPU
i5-4660
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Ignored the script output.
Sorry

Agreement
The audio_cloverHDMI script is for personal use only. Do not distribute
the patch, any or all of the files for any reason without permission.
The audio_cloverHDMI script is provided as is and without any warranty.

File: audio_cloverHDMI-130_v0.8.command
Release Mode
EFI partition is mounted
Password:
Print: Entry, ":KernelAndKextPatches", Does Not Exist
Edit config.plist: Add KernelAndKextPatches/KextsToPatch - Fixed
No HDMI audio codec(s) detected, continue (y/n): y
HDMI audio codec(s)
Integrated Graphics is not installed/enabled
Install AMD/Nvidia HDMI audio (y/n): y
Nvidia discrete graphics card 10de1c03 found on PEG0@1/PEGP@0
Nvidia HDMI audio is not enabled
Install Nvidia HDMI audio ssdt (y/n): y
Download SSDT-HDMI-NVIDIA-PEG0 ...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 44888 100 44888 0 0 140k 0 --:--:-- --:--:-- --:--:-- 140k
/Volumes/EFI/EFI/CLOVER/ACPI/patched/SSDT-HDMI-NVIDIA-PEG0.aml installed

Install finished, restart required.
To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
 
Joined
Nov 1, 2017
Messages
2
Did you solve this by removing the installed HDMI audio method? How exactly do you do that?
 
Top