Contribute
Register

<< Solved >> Loop on printing information

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,495
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
also if you have made changes, then upload your new zipped EFI, makes it easier to try and diagnose your issues
 
Joined
Dec 6, 2021
Messages
134
Motherboard
Gigabyte Z690 Aero G DDR4
CPU
i7-12700K
Graphics
RX 6600
Mac
  1. MacBook Pro
  2. Mac Pro
also if you have made changes, then upload your new zipped EFI, makes it easier to try and diagnose your issues
Yes. I will once installed.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Yes. I will once installed.
Yes please post the EFI (without serial numbers) once everything is installed. I'd like to compare it with the previous one.

By the way, was XHCI Handoff previously enabled in BIOS or you enabled it just now?
 
Joined
Dec 6, 2021
Messages
134
Motherboard
Gigabyte Z690 Aero G DDR4
CPU
i7-12700K
Graphics
RX 6600
Mac
  1. MacBook Pro
  2. Mac Pro
Yes please post the EFI (without serial numbers) once everything is installed. I'd like to compare it with the previous one.

By the way, was XHCI Handoff previously enabled in BIOS or you enabled it just now?

@CaseySJ XHCI Handoff disabled in Bios since yesterday.

Currently, I am stuck on the keyboard and mouse issue.

I tried the USB map comes with the Z590I EFI, I am able to choose the language with the mouse, but then the system shows I need to pair Bluetooth keyboard (attachment 1.jpg), tried with a wired keyboard, but not working.

Then I tried to disable the USBTOOLBOX.kext, USBPorts.kext, and enable USBInjectAll.kext (xhciportlimit disabled, if xhciportlimit enable will be stuck and show the same error message as before), the mouse cursor still works, but the system shows I need to connect a mouse and a keyboard ((attachment 2.jpg,3.jpg).
 

Attachments

  • 1.jpg
    1.jpg
    80.3 KB · Views: 20
  • 2.jpg
    2.jpg
    54.9 KB · Views: 18
  • 3.jpg
    3.jpg
    55.4 KB · Views: 17

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,495
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
@CaseySJ XHCI Handoff disabled in Bios since yesterday.

Currently, I am stuck on the keyboard and mouse issue.

I tried the USB map comes with the Z590I EFI, I am able to choose the language with the mouse, but then the system shows I need to pair Bluetooth keyboard (attachment 1.jpg).

Then I tried to disable the USBTOOLBOX.kext, USBPorts.kext, and enable USBInjectAll.kext (xhciportlimit disabled, if xhciportlimit enable will be stuck and show the same error message as before), the mouse cursor still works, but the system shows I need to connect a mouse and a keyboard ((attachment 2.jpg,3.jpg).
try pressing spacebar at that screen

also, still no files attached
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ XHCI Handoff disabled in Bios since yesterday.

Currently, I am stuck on the keyboard and mouse issue.

...
XHCI Handoff in BIOS (not XhciPortLimit in config.plist) should be enabled.

macOS is just looking for any keyboard even though it says Bluetooth keyboard. Do you have a direct wired USB keyboard instead of a Logitech keyboard that uses the RF Unifying Receiver?
 
Joined
Dec 6, 2021
Messages
134
Motherboard
Gigabyte Z690 Aero G DDR4
CPU
i7-12700K
Graphics
RX 6600
Mac
  1. MacBook Pro
  2. Mac Pro
try pressing spacebar at that screen

also, still no files attached

Hello @Feartech @UtterDisbelief @CaseySJ
I attached the EFIs.

EFI_0.7.7 is modified from Asus Z590I

EFI_0.8.0 is the one that has the USB issue.


---------------------------------------------------
Updates:

Hello,
@Feartech @UtterDisbelief @CaseySJ

Today, I tested the EFI_0.8.0.zip in the attachment, which has the USB error during booting that we have trying to fix, but after I finished the installation with @Leesureone 's EFI (attachment EFI_0.7.7.zip), I can use EFI_0.8.0.zip to boot into the system, but all the USB devices (wired mouse, wired keyboard, usb flash drives) are not working.

So looks like the same issue that we are working on: USB

Then I copied USBToolBox.kext, and UTBMap.kext from @Leesureone 's EFI to the EFI_0.8.0 and update the config, OpenCore can boot into the installation process. So the issue is USB!

My question is do we have to map USB in Windows before starting the installation process?

The other two issues are:
1. This motherboard has I-225 V (V3), but when I copy the info from Z690 Aero G, the system shows the cable plugged, but I cannot visit any website, do I need to flash the firmware for I-225 V. Also, how to set the value of AAPL, slot name in device properties?
(Updates solved https://www.tonymacx86.com/threads/loop-on-printing-information.320211/post-2323674)

2. Currently, I am using Intel wireless (FENVI T919 is on the way), and WIFI can work. I installed IntelBluetoothFirmware.kext and BlueToolFixup.kext, Bluetooth can turn on and off, but cannot discover any devices. My phone's Bluetooth can discover this build. Do you have any suggestions on this?


Thanks for your help!
 

Attachments

  • EFI_0.7.7.zip
    11.2 MB · Views: 18
  • EFI_0.8.0.zip
    1.6 MB · Views: 19
Last edited:
Joined
Dec 6, 2021
Messages
134
Motherboard
Gigabyte Z690 Aero G DDR4
CPU
i7-12700K
Graphics
RX 6600
Mac
  1. MacBook Pro
  2. Mac Pro
XHCI Handoff in BIOS (not XhciPortLimit in config.plist) should be enabled.

macOS is just looking for any keyboard even though it says Bluetooth keyboard. Do you have a direct wired USB keyboard instead of a Logitech keyboard that uses the RF Unifying Receiver?
Thanks! After enabling XHCI Handoff, the wired keyboard and wired mouse are working, start installation now.
 
Last edited:
Joined
Dec 6, 2021
Messages
134
Motherboard
Gigabyte Z690 Aero G DDR4
CPU
i7-12700K
Graphics
RX 6600
Mac
  1. MacBook Pro
  2. Mac Pro
I just finished the installation, Wake up/sleep tested a few times, works perfectly! Thanks @Leesureone !

Currently, working on the ethernet, looks like having some issues, can get the IP from the router, but cannot visit the website.
 
Top