Contribute
Register

Logic doesn't use my powerful Hackintosh.

Joined
Dec 19, 2018
Messages
96
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Classic Mac
PowerBook
Mobile Phone
Android, iOS
I have the same issue, wondering if you fixed it.
 
Joined
Sep 6, 2013
Messages
17
Motherboard
Asus X299 Mark 2
CPU
i9-7900X
Graphics
RX 570
Mac
iMac
Finally I made a total new installation with Mojave and with Imac pro system def.
I made a mix of these :
https://www.tonymacx86.com/threads/unibeast-install-macos-mojave-on-any-supported-intel-based-pc.259381/
https://www.tonymacx86.com/threads/imac-pro-x299-live-the-future-now-with-macos-10-14-mojave-successful-build-extended-guide.255082/
It was very painful and I got a lot of problems to fix but now it's working great… for the moment (3 weeks only).
I don't know if problem was fixed by Mojave or by the Imac pro def.
I guess Logic works better with Imac pro def…
I can't remember what I took in each tutorial.
I just remember I made the USB Mojave installer by following the usual guide and I took the KGP EFI folder from the imac-pro tutorial. Many thanks to KGP by the way…
Sorry if I do not have a better "scientific" explanation. I'm just happy to be out of this nightmare.
 
Joined
Dec 19, 2018
Messages
96
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Classic Mac
PowerBook
Mobile Phone
Android, iOS
Finally I made a total new installation with Mojave and with Imac pro system def.
I made a mix of these :
https://www.tonymacx86.com/threads/unibeast-install-macos-mojave-on-any-supported-intel-based-pc.259381/
https://www.tonymacx86.com/threads/imac-pro-x299-live-the-future-now-with-macos-10-14-mojave-successful-build-extended-guide.255082/
It was very painful and I got a lot of problems to fix but now it's working great… for the moment (3 weeks only).
I don't know if problem was fixed by Mojave or by the Imac pro def.
I guess Logic works better with Imac pro def…
I can't remember what I took in each tutorial.
I just remember I made the USB Mojave installer by following the usual guide and I took the KGP EFI folder from the imac-pro tutorial. Many thanks to KGP by the way…
Sorry if I do not have a better "scientific" explanation. I'm just happy to be out of this nightmare.
I was able to fix it also by using the iMac 18,3 on Mojave
 
Joined
Sep 6, 2013
Messages
17
Motherboard
Asus X299 Mark 2
CPU
i9-7900X
Graphics
RX 570
Mac
iMac
I tried iMac 18,2 with High Sierra and it was not good for me...
 
Joined
Feb 10, 2013
Messages
7
Motherboard
GA-Z170X-UD3
CPU
i5-6600k
Graphics
Asus GTX 1070
Anyone experiencing logics curser to lag or not visually moving? I have NVIDIA GPU and brute forced the web driver.

OS: Mojave
Logic 10.4.1
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
2,669
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Anyone experiencing logics curser to lag or not visually moving? I have NVIDIA GPU and brute forced the web driver.

@nicktumi,

There are no official Nvidia drivers for Mojave and not likely to be for a while ...
Even if you brute force load the Nvidia Driver in Mojave, MacOS will not have accelerated UI as there is no Metal 2 support.

Try disabling your Nvidia Card using rehabmans software method and switch to using the IGPU for MacOS (use Lilu + WhatEverGreen to configure) it should run Logic just fine as Logic is not GPU heavy.

Cheers
Jay
 
Last edited:
Top