Contribute
Register

Logic doesn't use my powerful Hackintosh.

Joined
Dec 19, 2018
Messages
109
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
I have the same issue, wondering if you fixed it.
 
Joined
Sep 6, 2013
Messages
42
Motherboard
Asus X299 Mark 2
CPU
i9-7900X
Graphics
RX 570
Mac
  1. iMac
Finally I made a total new installation with Mojave and with Imac pro system def.
I made a mix of these :
https://www.tonymacx86.com/threads/...ojave-on-any-supported-intel-based-pc.259381/
https://www.tonymacx86.com/threads/...ojave-successful-build-extended-guide.255082/
It was very painful and I got a lot of problems to fix but now it's working great… for the moment (3 weeks only).
I don't know if problem was fixed by Mojave or by the Imac pro def.
I guess Logic works better with Imac pro def…
I can't remember what I took in each tutorial.
I just remember I made the USB Mojave installer by following the usual guide and I took the KGP EFI folder from the imac-pro tutorial. Many thanks to KGP by the way…
Sorry if I do not have a better "scientific" explanation. I'm just happy to be out of this nightmare.
 
Joined
Dec 19, 2018
Messages
109
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
Finally I made a total new installation with Mojave and with Imac pro system def.
I made a mix of these :
https://www.tonymacx86.com/threads/...ojave-on-any-supported-intel-based-pc.259381/
https://www.tonymacx86.com/threads/...ojave-successful-build-extended-guide.255082/
It was very painful and I got a lot of problems to fix but now it's working great… for the moment (3 weeks only).
I don't know if problem was fixed by Mojave or by the Imac pro def.
I guess Logic works better with Imac pro def…
I can't remember what I took in each tutorial.
I just remember I made the USB Mojave installer by following the usual guide and I took the KGP EFI folder from the imac-pro tutorial. Many thanks to KGP by the way…
Sorry if I do not have a better "scientific" explanation. I'm just happy to be out of this nightmare.

I was able to fix it also by using the iMac 18,3 on Mojave
 
Joined
Sep 6, 2013
Messages
42
Motherboard
Asus X299 Mark 2
CPU
i9-7900X
Graphics
RX 570
Mac
  1. iMac
I tried iMac 18,2 with High Sierra and it was not good for me...
 
Joined
Feb 10, 2013
Messages
7
Motherboard
GA-Z170X-UD3
CPU
i5-6600k
Graphics
Asus GTX 1070
Anyone experiencing logics curser to lag or not visually moving? I have NVIDIA GPU and brute forced the web driver.

OS: Mojave
Logic 10.4.1
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,854
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Anyone experiencing logics curser to lag or not visually moving? I have NVIDIA GPU and brute forced the web driver.


@nicktumi,

There are no official Nvidia drivers for Mojave and not likely to be for a while ...
Even if you brute force load the Nvidia Driver in Mojave, MacOS will not have accelerated UI as there is no Metal 2 support.

Try disabling your Nvidia Card using rehabmans software method and switch to using the IGPU for MacOS (use Lilu + WhatEverGreen to configure) it should run Logic just fine as Logic is not GPU heavy.

Cheers
Jay
 
Last edited:

MBI

Joined
Apr 10, 2020
Messages
2
Motherboard
Asus Tuf2 x299
CPU
7940x
Graphics
Nvidia 1080TI
I tried iMac 18,2 with High Sierra and it was not good for me...

Did you ever solve this issue? I have a very similar setup and get good Geekbench. But Logic is barely using 3.0ghz on the CPU's (7940X) and logic is at 100% on all threads. Im on High Sierra and using an Nvidia 1080ti - so cannot upgrade OS. All other apps work fine. Just logic does not want to tap into the available power.
 
Joined
Sep 6, 2013
Messages
42
Motherboard
Asus X299 Mark 2
CPU
i9-7900X
Graphics
RX 570
Mac
  1. iMac
Look at my post #12, MBI.
My problem was solved with Imac Pro def + Mojave.
I really have no real explanation but, more than one year later, Logic still works great and use all my overclocked 7900X until 5GHz.
I'm under Catalina now.
If Logic and making music is what you do the most, maybe you should try another video (AMD Radeon i.e.) and leave High Sierra. I really hate high Sierra...
 

MBI

Joined
Apr 10, 2020
Messages
2
Motherboard
Asus Tuf2 x299
CPU
7940x
Graphics
Nvidia 1080TI
Thanks for the reply. I will look to upgrade at some point.
 
Top