Contribute
Register

[LOCKED] Guide - New ATI Kexts from iMac 10.6.7 - 5XXX/6XXX

Status
Not open for further replies.
Joined
Nov 12, 2010
Messages
37
Mac
Classic Mac
Mobile Phone
Re: Guide - New ATI Kexts from MBP 10.6.7 Update - 5XXX/6XXX

I'm a bit confused. Just need some clarification on all of this. Currently have a GTX 275 working well, only having GraphicsEnabler=Yes. I just purchased a XFX HD5870 and wanted some clarification on what to do. I've already updated to 10.6.7 via Software Update as well.

1.) Do I just run Multibeast and check the new ATI Drivers, shut down, replace GTX 275 with HD5870? Will I have to change GraphicsEnabler=Yes to No?

2.) What is Kabyl bootloader? Checked the new Multibeast and didn't see it anywhere.

Sorry for the noob questions. Haven't been able to keep up with what's going on but as always, thank you in advance. I would be lost without this site.
 
Joined
Feb 10, 2010
Messages
4
Mac
Classic Mac
Mobile Phone
Re: Guide - New ATI Kexts from MBP 10.6.7 Update - 5XXX/6XXX

phenom7 said:
I'm a bit confused. Just need some clarification on all of this. Currently have a GTX 275 working well, only having GraphicsEnabler=Yes. I just purchased a XFX HD5870 and wanted some clarification on what to do. I've already updated to 10.6.7 via Software Update as well.

1.) Do I just run Multibeast and check the new ATI Drivers, shut down, replace GTX 275 with HD5870? Will I have to change GraphicsEnabler=Yes to No?

2.) What is Kabyl bootloader? Checked the new Multibeast and didn't see it anywhere.

Sorry for the noob questions. Haven't been able to keep up with what's going on but as always, thank you in advance. I would be lost without this site.

FWIW, I went from a GTX 260 to a 6870, so similar to your story, but not quite. I followed the same steps as you, but left GE=Yes, not knowing any better (at least for my setup). Upon reboot, the 6870's fan would go full blast, and I'd get a black screen, and nothing further. Luckily, using my Windows boot, I was able to change GE=No (using MacDrive to access the OSX drive), and was able to boot into SL with QE/CI.

However, I'm getting the DVD crash, Geekbench crash, and most likely other openGL related errors. However, since I don't game while in OS X, I haven't been motivated to get to the bottom of it. It's still bugging me though, and I'd like to get a backup drive first before running more tests and suggestions.
 
Joined
Mar 28, 2011
Messages
1
Mac
Classic Mac
Mobile Phone
Re: Guide - New ATI Kexts from MBP 10.6.7 Update - 5XXX/6XXX

So far things are working well for me BUT I can't seem to get all the way to 2560X1600 without "red snow" on the screen. All other resolutions are OK (to a Gateway XHD3000 with Diamond 5770PE51G). Any thoughts?
 
Joined
Nov 12, 2010
Messages
37
Mac
Classic Mac
Mobile Phone
Re: Guide - New ATI Kexts from MBP 10.6.7 Update - 5XXX/6XXX

goldenaustin said:
phenom7 said:
I'm a bit confused. Just need some clarification on all of this. Currently have a GTX 275 working well, only having GraphicsEnabler=Yes. I just purchased a XFX HD5870 and wanted some clarification on what to do. I've already updated to 10.6.7 via Software Update as well.

1.) Do I just run Multibeast and check the new ATI Drivers, shut down, replace GTX 275 with HD5870? Will I have to change GraphicsEnabler=Yes to No?

2.) What is Kabyl bootloader? Checked the new Multibeast and didn't see it anywhere.

Sorry for the noob questions. Haven't been able to keep up with what's going on but as always, thank you in advance. I would be lost without this site.

FWIW, I went from a GTX 260 to a 6870, so similar to your story, but not quite. I followed the same steps as you, but left GE=Yes, not knowing any better (at least for my setup). Upon reboot, the 6870's fan would go full blast, and I'd get a black screen, and nothing further. Luckily, using my Windows boot, I was able to change GE=No (using MacDrive to access the OSX drive), and was able to boot into SL with QE/CI.

However, I'm getting the DVD crash, Geekbench crash, and most likely other openGL related errors. However, since I don't game while in OS X, I haven't been motivated to get to the bottom of it. It's still bugging me though, and I'd like to get a backup drive first before running more tests and suggestions.

So would I be better off just using ATI Experimental + GraphicsEnabler=Yes? Is there that much of a benefit using the native drivers? If there are problems, I don't even want to bother trying to deal with the new drivers. Thanks!
 
Joined
Nov 30, 2010
Messages
161
Motherboard
10.9.1
CPU
i7 4771
Graphics
GTX770 EVGA
Mac
Classic Mac
Mobile Phone
  1. Android
Re: Guide - New ATI Kexts from MBP 10.6.7 Update - 5XXX/6XXX

phenom7 said:
So would I be better off just using ATI Experimental + GraphicsEnabler=Yes? Is there that much of a benefit using the native drivers? If there are problems, I don't even want to bother trying to deal with the new drivers. Thanks!
If you use the Apple DVD player, love running certain benchmarks, or play certain games that don't seem to work with the new kexts - then yes I would just load the ATI Exp. Bootloader, with GE=Yes and call it a day. I recently switched from a GTX 285 to an AMD 5870 and all I did was swap cards, install the Chameleon ATI Exp. Bootloaded, and reboot.

You can start with that and easily switch to the new kexts later too. Eventually the new kexts will be completely understood and there will be a trouble free install method. (and or they will be added to the next released global update)
 
Joined
Nov 15, 2010
Messages
79
Motherboard
Gigabyte ga-z77x-ud5h
CPU
i5
Graphics
GTX-660
Mac
Classic Mac
Mobile Phone
Re: Guide - New ATI Kexts from MBP 10.6.7 Update - 5XXX/6XXX

Just updated my system and everything works except the DVD player.

Small price to pay for additional ports ;)

Thanks Notshy!!!
 
Joined
Mar 7, 2011
Messages
1
Mac
Classic Mac
Mobile Phone
Re: Guide - New ATI Kexts from MBP 10.6.7 Update - 5XXX/6XXX

Has anyone actually got a 6970 running properly? I was just about to go out and buy one when I saw the news but then I haven't actually seen anyone using one who got it working completely.
 
Joined
Aug 12, 2010
Messages
1,586
Motherboard
X58A-UD3R v2
CPU
i7-930
Graphics
5770
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
Re: Guide - New ATI Kexts from MBP 10.6.7 Update - 5XXX/6XXX

xxhaagendazs said:
Has anyone actually got a 6970 running properly? I was just about to go out and buy one when I saw the news but then I haven't actually seen anyone using one who got it working completely.

I would not buy a card without direct evidence that someone has it working. I thought Rominator had already posted about this card.
 
Joined
Feb 1, 2011
Messages
327
Motherboard
GA-P55-USB3
CPU
Core i5 760
Graphics
ATI 5770
Mac
Classic Mac
Mobile Phone
Re: Guide - New ATI Kexts from MBP 10.6.7 Update - 5XXX/6XXX

Has anyone tried mixing and matching the MBP kexts with the stock ones?

I think most of the actual driver code is in the ATIX3000 code. The MacBook Pro 2011 model ships with 6xxxM series ATI cards, so it wouldn't surprise me if the only meaningful code is related to the 6000 kexts, and the rest is just 'what came out of CVS' when Apple's build server produced the update package (and therefore might not be ready for the primetime, and might be largely untested).

However, I might try just replacing the ATI5000 controller, and then patch in ATISupport and ATIFramebuffer, and leave the X3000 kexts alone (and other combinations).

When I get the time... But has anyone yet attempted similar?
 

Div

Joined
Mar 28, 2011
Messages
31
Mac
Classic Mac
Mobile Phone
Re: Guide - New ATI Kexts from MBP 10.6.7 Update - 5XXX/6XXX

goldenaustin said:
FWIW, I went from a GTX 260 to a 6870, so similar to your story, but not quite. I followed the same steps as you, but left GE=Yes, not knowing any better (at least for my setup). Upon reboot, the 6870's fan would go full blast, and I'd get a black screen, and nothing further. Luckily, using my Windows boot, I was able to change GE=No (using MacDrive to access the OSX drive), and was able to boot into SL with QE/CI.

However, I'm getting the DVD crash, Geekbench crash, and most likely other openGL related errors. However, since I don't game while in OS X, I haven't been motivated to get to the bottom of it. It's still bugging me though, and I'd like to get a backup drive first before running more tests and suggestions.

In regards to you getting the fan to go full blast and black screen, can you explain to me what "Luckily, using my Windows boot, I was able to change GE=No (using MacDrive to access the OSX drive), and was able to boot into SL with QE/CI." these steps you did? So I don't have to reinstall Mac OSX.
 
Status
Not open for further replies.
Top