Contribute
Register

List of Confirmed Radeon HD 7xxx Series (10.8.3+)

Status
Not open for further replies.
Joined
Nov 19, 2012
Messages
27
Motherboard
Asus P8Z77-V
CPU
I7-3770K
Graphics
GTX 760 + HD 4000
The kext that you downloaded and installed them using kextbeast is a kext that I edited and hacked before

Yes I know and thank you for that.Is there any difference for Sapphire and XFX kext.I want to know is suppose to find my graphic card as 7xxx ,not 7850 series?Sometimes Moviest just freeze for less than a second and the HDD make a sound just like when I have to put it to sleep,but this is rare and the freeze is very very short ,it is less than one second.Graphic acceleration is working properly I tested with DVD Player(it does not crash) I have tested some Renders and opengl bench.Just this problem for the Video freezing in Movist as the HDD makes some sound the freezing occur,but as I said is for less than a second. It is weird and it is never been happened with HD4000.
 
Joined
Jun 12, 2012
Messages
350
It IS supposed to say 7xxx Series, don't worry.

Although the freezing issue is not something I can say I know anything about...
 
Joined
Dec 10, 2012
Messages
129
Motherboard
GA-Z77X-UD5H F14 Bios
CPU
i73770K
Graphics
MSI Radeon 7950 3GB
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
I did that as you without changing any,thing in the kexts just install them using Kextbeast.I used the Sleep trick and it Worked!I am using I7 3770k with HD4000 set as primary on Asus P8Z77-V, XFX 7850 DD Edition,32gb Corsair. ML 10.8.3

------------------------------------

I have that same MB (Asus P8z77-v), but can't boot in normal mode with a MSI 7950 (3gb) using UniBeast, Multibeast, and 10.8.3. Boots in -z only.

From what I'm seeing, Clover bootloader is having the best success over Chameleon.

I haven't worked with Clover, but those getting it to work are 'Injecting' GraphicsEnabler=Yes.
 
Joined
Mar 19, 2013
Messages
9
Motherboard
Windows
CPU
2500K
Graphics
HD7850
Mac
Classic Mac
Mobile Phone
SUCCESS:

View attachment 49975

View attachment 49976

Gigabyte AMD Radeon HD 7850 2 GB GDDR5 DVI-I/HDMI/2x mini-Displayport PCI-Express 3.0 Graphic Card GV-R785OC-2GD

Device ID hack is enough. :) Thanks for those that reply.


Hey arkkum, I have the same model as you do. I'm bit of a noob into the hackintosh world, could you please explain the steps you followed to get the card working? Thanks :)
 
Joined
Mar 19, 2013
Messages
26
Motherboard
Lenovo X250
CPU
i5-5300U
Graphics
HD 5500
Mobile Phone
  1. Android
Is the DVI-VGA adapter working? :( Because i have a ASUS HD7770-DC-1GD5-V2 graphics card and i will buy soon computer parts like :

i3-3225/3220
4GB DDR3 1333MHz
MSI H77MA-G43 ( http://biosrepo.wordpress.com/msi/ on this website i have a flashed 1.9 bios :D )
ASUS DVD-RW Drive

And i don't have a monitor(excepting a 37'/42' TV) with DVI or HDMI. Stupid Samsung SyncMaster S22B150 with VGA...
 
Joined
Jun 24, 2011
Messages
1
Motherboard
Mac Pro
CPU
i5
Graphics
7850
Mac
Classic Mac
Mobile Phone
Saw your edits for the kext for the 7850 and was wondering if you have a sec to help me out. I have the same exact card....got 10.8.3 ML installed on the drive, installed the kext files with kextbeast. When i go to boot with unibeast, last line i get is boot0:done and then a bunch of gibberish. It just hangs there. I am able to boot in to the drive just fine without the 7850 and works with the HD4000 im using. If you have the time and want to help me, I'd appriciate it. =] Would there be any way you can send me your /Extra and boot that you are using or the steps you used to make the boot drive?
 
Joined
Mar 16, 2013
Messages
2
Motherboard
GA-Z77-DS3H
CPU
intel 3470
Graphics
sapphire 7850
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
Mobile Phone
Hey, I read the list of the working 7850's. Now, I'm newcomer and have a (noobish) question:
I have a sapphire 7850 that should work by editing the kext files. But, will I be able to install Mac OS X on a computer with this card or do I absolutely have to install it with an other card? (or integrated)
I'm asking this because I'm going for the Intel i5 3470, which has only HD 2500 graphics, which is not supported .. right?
Thanks for your help :)
 
Joined
Mar 19, 2013
Messages
9
Motherboard
Windows
CPU
2500K
Graphics
HD7850
Mac
Classic Mac
Mobile Phone
Hey guys.

I got my OS X fully working except for the HD7850. I thought it was GIGABYTE, I was wrong, it is Sapphire Dual-X 2GB.

So I downloaded the kext's from the original post and installed them with Kext Beast.

Now, after rebooting, if I dont specify GraphicsEnabler=No, I stay in a black screen. If I write GraphicsEnabler=No it boots up, but then I get a white screen with the black cursor moving.

Should I have edited the kexts somehow before installing them? Please help this poor noob -.-
 
Status
Not open for further replies.
Top