Contribute
Register

List of AMD Radeon Navi cards in Catalina That work.

Joined
May 15, 2016
Messages
4,966
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Thanks for the post! Could you please clarify if this means fully native support or just native drivers and still requires a power table? I'm running a Vega 64 and although there was native driver support, the fan and power control took a while to figure out. I'd like to avoid all that by upgrading, but only if it's true plug 'n play.
So far all brands and configurations are reported working. They have fan and power control but softpowertables can customize them. The Vega cards worked as long as they were reference designs. Apple waited longer on these Navi drivers but there is room for improvement.
 
Joined
Sep 22, 2010
Messages
81
Motherboard
ASUS PRIME Z270-P
CPU
i7-7700K
Graphics
Vega 64
So far all brands and configurations are reported working. They have fan and power control but softpowertables can customize them. The Vega cards worked as long as they were reference designs. Apple waited longer on these Navi drivers but there is room for improvement.
Great! So no need to fix fans after boot and stuff. Good to know. Ty!
 
Joined
Aug 3, 2018
Messages
6
Motherboard
MSI MPG Z399 Gaming Plus
CPU
9600K
Graphics
Rx 5700 XT
XFX RX 5700 XT RAW II works with agpdmod=pikera.
However, 1440p gets display artifacts with red lines going across the screen. I'm unsure if it's the XFX card or Catalina since the same issue happened with iGPU display out.
 
Joined
Oct 25, 2019
Messages
50
Motherboard
Gigabyte Z390 Designare
CPU
I7-9700K
Graphics
RX 5700 XT
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Can confirm Sapphire Pulse 5700XT working on Catalina 10.15.1. SMBIOS 19,1, WEG, adgpmod=pikera, GB Designare z3390. Acceleration is enabled. I was worried about the fans stop working when OS Drivers are loaded but under load GPU fans start spinning again. Meaning the card is noiseless on idle/Office work. LuxMark Results are according to all the benchmarks you can see on various YT-Channels.
 
Joined
Oct 10, 2015
Messages
191
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Can confirm Sapphire Pulse 5700XT working on Catalina 10.15.1. SMBIOS 19,1, WEG, adgpmod=pikera, GB Designare z3390. Acceleration is enabled. I was worried about the fans stop working when OS Drivers are loaded but under load GPU fans start spinning again. Meaning the card is noiseless on idle/Office work. LuxMark Results are according to all the benchmarks you can see on various YT-Channels.
Recent Radeon cards tend to keep the fan at 0rpm until the temperature reaches 50°C.
 
Joined
Apr 27, 2012
Messages
5
Motherboard
ASRock H110 Pro BTC+
CPU
i7-6700K
Graphics
5700
Mac
MacBook Pro
Mobile Phone
Android, iOS
Sapphire Pulse 5700 works here!

Just in case if anyone interest, my build:

ASRock H110 pro BTC+
i7 6700K
Sapphire Pulse Rx580
MacOS 10.15.1 with WEG 1.3.4

I replaced the card and tried to boot with agpdmod=pikera only to boot up with black screen, so I removed WEG and the system can now boot up with no issue.
 
Joined
Mar 31, 2010
Messages
125
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i9-9900KS
Graphics
RX 5700 XT
Got myself a Sapphire Nitro+ Radeon RX 5700 XT and tried to install it in my case but it won't fit! The card is a monster and over 300mm long.
Tried to remove some of the hard drive cages with a dremel but it still won't fit in my Fractal R3 case.
 
Top