Contribute
Register

List of AMD Radeon Navi cards in Catalina That work.

Joined
Jul 3, 2010
Messages
165
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
Installed my new Sapphire Pulse 5700XT but it won’t boot unless I safe boot. Deleted Whatevergreen out of Library/Extensions and added the adgpmod=pikera line. What did I do wrong? Thanks!
 
Joined
May 15, 2016
Messages
4,874
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Installed my new Sapphire Pulse 5700XT but it won’t boot unless I safe boot. Deleted Whatevergreen out of Library/Extensions and added the adgpmod=pikera line. What did I do wrong? Thanks!
Try disabling the IGPU in bios
 
Joined
Jul 3, 2010
Messages
165
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
Try disabling the IGPU in bios
It was already disabled. Just to verify, Whatevergreen.kext should be deleted in /library/extensions and in the EFI partition’s kexts/other folder? And, if so, Do I need adgpmod=pikera too?

Edit: Nevermind, I got it to work. The Shikigva=60 variable was still in my config and once I deleted it, the Sapphire Pulse 5700XT boots! Thanks!!

Edit2: Actually, I spoke too soon. I had to do one more step. Had to remove Inject ATI and Oronico frame buffer from the Graphics section. Now it boots up reliably.
 
Last edited:
Joined
May 7, 2017
Messages
8
Motherboard
MSI-Z270M-MORTAR
CPU
i7-7700
Graphics
RX 5700 XT
Mac
MacBook Pro
Mobile Phone
Android, iOS
It was already disabled. Just to verify, Whatevergreen.kext should be deleted in /library/extensions and in the EFI partition’s kexts/other folder? And, if so, Do I need adgpmod=pikera too?

Edit: Nevermind, I got it to work. The Shikigva=60 variable was still in my config and once I deleted it, the Sapphire Pulse 5700XT boots! Thanks!!
So here is what you did:

1. still kept the latest WEG
2. removed Shikigva=60
3. added adgpmod=pikera

am I right? Thanks.
 
Joined
Oct 30, 2019
Messages
3
Motherboard
Asus STRIX Z390-H GAMING
CPU
i9-9900K
Graphics
5700 XT
Ended up going with the Asus Rog Strix 5700xt and so far everything is working great. I did exactly what was recommended by @iDrakus here: https://www.tonymacx86.com/threads/the-everything-works-asus-z390-i-gaming-i7-8700k-sapphire-rx580-pulse-build.272572/page-262#post-2028045

1. Use the Catalina DGPU config from page 1 of that post
2. Replaced Lilu and WEG kexts with the latest downloaded from the downloads area
3. Replaced the config.plist with the one from iDrakus linked above

So far things are running nicely at 2k @ 144hz. Hope this helps anyone else working through this.

2019-11-07 at 11.34 AM.png
 
Joined
Jul 3, 2010
Messages
165
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
So here is what you did:

1. still kept the latest WEG
2. removed Shikigva=60
3. added adgpmod=pikera

am I right? Thanks.
Actually, I spoke too soon. I had to do one more step. Had to remove Inject ATI and Oronico frame buffer from the Graphics section. Now it boots up reliably.
 
Joined
Jul 3, 2010
Messages
165
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
So here is what you did:

1. still kept the latest WEG
2. removed Shikigva=60
3. added adgpmod=pikera

am I right? Thanks.
yes.
 
Joined
Jan 3, 2011
Messages
5
Motherboard
AsRock Z87 Extreme4
CPU
i7 4770K
Graphics
GTX 780 Ti
Mac
iMac, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac
Mobile Phone
Android, iOS
Thank you guys for this info.
 
Joined
Sep 22, 2010
Messages
80
Motherboard
ASUS PRIME Z270-P
CPU
i7-7700K
Graphics
Vega 64
macOS Catalina Beta 15.1 version 2 now includes the new AMDRadeon6000kext and supporting kexts to allow support for the new Navi cards.
Whatevergreenkext either needs to be disabled or removed or you can use this boot argument. agpdmod=pikera
Thanks for the post! Could you please clarify if this means fully native support or just native drivers and still requires a power table? I'm running a Vega 64 and although there was native driver support, the fan and power control took a while to figure out. I'd like to avoid all that by upgrading, but only if it's true plug 'n play.
 
Joined
May 31, 2016
Messages
632
Motherboard
Z170X-UD5 TH
CPU
i7-6700K
Graphics
GTX 1080
Mac
iMac, MacBook, MacBook Pro, Mac mini
Classic Mac
PowerBook, Quadra
Mobile Phone
iOS
Thanks for the post! Could you please clarify if this means fully native support or just native drivers and still requires a power table? I'm running a Vega 64 and although there was native driver support, the fan and power control took a while to figure out. I'd like to avoid all that by upgrading, but only if it's true plug 'n play.
This is speculation, but I think power and fan control will always be necessary as none of the cards we have access to are 'stock' apple configurations, nor are we using the same cooling systems and sensors apple uses... so to get the most out of the cards we CAN get, tweaking will always be necessary. (My 0.02)
 
Top