Contribute
Register

Lion Retail Install on G41M-Combo

Joined
Jan 11, 2011
Messages
25
Mac
Classic Mac
Mobile Phone
UPDATED 26 July 2011 All Working 100% :headbang:

Hi All I am starting this for those who have a G41M-Combo Mother Board from Gigabyte in the hopes we can work together to get our system running Rock Solid.

So Far I now have Stable system with the following Specs:

Mother Board - G41M-Combo
Processor - Core Duo E6500 (Actually a core 2 duo just not marketed as such)
GPU- Gigabyte GT430
Ram - 2x4GB 1066 DDR3

I don't think there is a need to rewrite the base guide I used so I will link and then outline the changes I made.

I used this guide to get me started
http://www.insanelymac.com/forum/index. ... pic=256729

Basically Followed the above guide up till post install then I made some changes for this particular M-B and I have uploaded the files you will need to get to where I am.

Required Files Available at: UPDATED 25 July 2011
http://www.mediafire.com/?6q38vdk0tfz5bh5

This above link includes:
Chameleon-2.0-RC5-r1083.pkg

Chameleon 2 rc5 r755

DTDT for G41M-Combo Bios Rev F3

Extra Folder with Required Kext for this MB and smbios for macro 3.1
Note within the Extra/Extensions folder is NVEnabler you unless you require this for your graphics card just delete it.

Kexts for Network, audio and IOPCIFamily.kext (Fixes pci configuration hang) to be installed in S/L/E with the help of Kext Wizard

Kext Wizard and Chameleon Wizard

Follow the Guide above then once you are up to post install you will need to:

Step 1:
copy the Extra folder and the dsdt.aml file provided in the Required Files to the New Installation Hard Drive Root.

Step 2:
You will need to modify the com.apple.Boot.plist provided in the Extra folder for you particular Graphics Card under:

<key>device-properties</key>
<string>***Your Combined Graphics and Ethernet String goes Here</string>
Unless of course you have the same graphics card as me
http://www.gigabyte.com/products/produc ... id=3611#ov

Note: if using a Graphic string you must remove NVEnabler.kext from /Extra/Extensions folder, and set
<key>Graphics Enabler</key>
<string>Yes</string>
to
<key>Graphics Enabler</key>
<string>No</string>


The Reason I needed to have both the Graphics and Ethernet combined strings was because without the Ethernet String I was unable to log into the Mac App Store. Once I added the Ethernet String I was Good To Go.

For More info on generating EFI Strings see here
http://www.insanelymac.com/forum/lofive ... 14349.html

Step 3:
Open Kext Wizard (Application folder in Required Files) then switch to the install tab and drag in the 3 .kext files (S/L/E Folder in Required Files) make sure to select your new installation HDD and System/Library/Extentions as the destination. Then Click install

Step 4:
If you know how to manually install Chameleon install Chameleon RC5 r755
if not just install Chameleon-2.0-RC5-r1083.pkg by double clicking (Ensure you point to the New Install HDD)
Then open Chameleon Wizard (Application folder in Required Files) Select the "Folder on disk tab. Then click the Select Button and browse to where you have downloaded and unzipped the required files ->Chameleon -> Chameleon RC5 r755 Lion Folder and click open. This will grey out the first 2 Install Method options leaving you with update selected click Update boot1h. Then ensure your new install partition is selected as Target Partition and click install.

The Reason you need to have 755 installed is this will repair the FaceTime Registration error everyone is complaining about.

As I said if you can install manually go for it, I just put these instructions in to make it as easy as possible for noobs like myself.

Step 5:
Reboot with -v -f and your good to go.

OK You still with me lets discuss some of the issues in no particular order:

Issue 1:When booting I must use the kernel flags -v -f or it just reboots itself
I realise I could add these to the boot flags in com.apple.Boot.plist however would prefer to wait until I have figured out how to boot normally.



RESOLVED :oops:
This issue was caused by me being a noob my apologies to anyone who followed this guide earlier.

Basically if you are using graphics string in com.apple.Boot.plist you don't need a Enabler for Graphics such as NVEnabler. You also don't need
<key>Graphics Enabler</key>
<string>Yes</string>
it should be
<key>Graphics Enabler</key>
<string>No</string>

Graphics Enabler Yes is used if you have a DSTD file that has been patched for your graphics card.


Conclusion
Anyway Guys I have been running lion since DP2 with the same issue and is stable enough to use for my main computer. No Kernel panics or dramas apart from what the one I have listed.

I have also noticed a massive speed improvement due to now having 64bit kernel and extensions, I assume because the 8gb of ram is now being used. It is also worth noting on the performance side I use The Adobe Suite for my business (Graphic and web design with a little motion graphics and flash) and have adjusted performance setting to utilise the available RAM this is also true for VMWare Fusion.

Anyway I hope you guys can help me and other noobs to get this system running even better, I look forward to your responses.
 
Joined
Jul 18, 2011
Messages
1
Motherboard
Gigabyte GA-G41M-ES2L
CPU
Intel Core 2 Duo E7500, 2.93GHz
Graphics
EVGA GeForce 9800 GTX+
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
I don't recall that Apple stated that they support Intel Core Duo processors, neither does tonymacx86's Lion Installation Guide.

If you got it to work, then I could also use your help since I am not using the G41M-Combo, but I am using a G41M-ES2L v1.3 motherboard with:

- Intel Core 2 Duo E7500 (2.93GHz, 3MB L2, 1066MHz FSB, 64 bit SSE4.1)
- 4GB DDR2-6400 (800MHz, 128 bit Dual Channel, 2GB Corsiar + 2GB PNY)
- 120GB WDC SATA-I HDD Primary (160GB IDE ATA/133 as Time Machine)
- EVGA GeForce 8400GS 512MB PCI-E x16 V1.1 (VGA output momentarily)
- IDE DVD burner from Sony DRU-V200A
- CoolerMaster 550W PSU + Vortex Plus CPU Cooler for LGA775
- USB Logitech H330 Headset (onboard audio works) + Std. USB Keyboard/Mous (Dell)

Thanks!
 
Joined
Jan 11, 2011
Messages
25
Mac
Classic Mac
Mobile Phone
2theheavens said:
I don't recall that Apple stated that they support Intel Core Duo processors, neither does tonymacx86's Lion Installation Guide.

If you got it to work, then I could also use your help since I am not using the G41M-Combo, but I am using a G41M-ES2L v1.3 motherboard with:

- Intel Core 2 Duo E7500 (2.93GHz, 3MB L2, 1066MHz FSB, 64 bit SSE4.1)
- 4GB DDR2-6400 (800MHz, 128 bit Dual Channel, 2GB Corsiar + 2GB PNY)
- 120GB WDC SATA-I HDD Primary (160GB IDE ATA/133 as Time Machine)
- EVGA GeForce 8400GS 512MB PCI-E x16 V1.1 (VGA output momentarily)
- IDE DVD burner from Sony DRU-V200A
- CoolerMaster 550W PSU + Vortex Plus CPU Cooler for LGA775
- USB Logitech H330 Headset (onboard audio works) + Std. USB Keyboard/Mous (Dell)

Thanks!

Hi There I thought the same with Core Duo not being supported and I believe this is true however after researching the e6500 while it is only marketed as a core duo it is infact the same chip as the e7500 with less l2 cache. So It is in fact a dual core duo. Just not labeled as one. I have this running so can fully verify that it is a core 2 duo.

Your Chip is definitely supported as is your motherboard
There is a guide for your motherboard available at
http://wiki.osx86project.org/wiki/index ... 0#Gigabyte

Good Luck and let me know if I can help any other way
 
Joined
Mar 5, 2011
Messages
15
Motherboard
I didn't read
CPU
the RULES
Graphics
so ignore me
Just want to report that I've got Lion installed successfully by following Tony's guides.

I used iBoot and MultiBeast to install SL 10.6.3 on a clean partition. I then upgraded the system to 10.6.8. I used MultiBeast to roll back USB driver and install the Nvidia drivers.

I then downloaded Lion from App Store and xMoved it to my 8GB USB flash drive. I rebooted my machine with the Lion USB flash drive and installed it on top of the existing SL. The Lion installation process took 33 minutes and completed successfully.

Everything's fine here except the onboard audio. This is good enough for me as I have a usb audio dongle.

Very Happy playing with the Lion now!!!

Thanks a lot guys for all the useful tools and information!!!!
 
Joined
Jan 11, 2011
Messages
25
Mac
Classic Mac
Mobile Phone
maymayhk said:
Just want to report that I've got Lion installed successfully by following Tony's guides.

I used iBoot and MultiBeast to install SL 10.6.3 on a clean partition. I then upgraded the system to 10.6.8. I used MultiBeast to roll back USB driver and install the Nvidia drivers.

I then downloaded Lion from App Store and xMoved it to my 8GB USB flash drive. I rebooted my machine with the Lion USB flash drive and installed it on top of the existing SL. The Lion installation process took 33 minutes and completed successfully.

Everything's fine here except the onboard audio. This is good enough for me as I have a usb audio dongle.

Very Happy playing with the Lion now!!!

Thanks a lot guys for all the useful tools and information!!!!

Hi have you had any dramas with MacApp store, FaceTime etc?
Also getting onboard audio is a two second job just need to install the voodoohda.kext supplied in the required recourses above. This particular kext will have onboard working 100%.

I found that a fresh install was best for me, as had some issues with some of the stuff I had installed on my Snow Leo, Also like to keep a previous os partition or hdd n case of emergency.

Anyway good to see we can have these boards running perfect. Lion is a definite improvement.
 
Joined
Mar 5, 2011
Messages
15
Motherboard
I didn't read
CPU
the RULES
Graphics
so ignore me
krischef18 said:
Hi have you had any dramas with MacApp store, FaceTime etc?
Also getting onboard audio is a two second job just need to install the voodoohda.kext supplied in the required recourses above. This particular kext will have onboard working 100%.

I found that a fresh install was best for me, as had some issues with some of the stuff I had installed on my Snow Leo, Also like to keep a previous os partition or hdd n case of emergency.

Anyway good to see we can have these boards running perfect. Lion is a definite improvement.

Thanks for the advice about the onboard audio driver. Will try that later. Yep, I am able to logon to AppStore and browse around. Just wondering what kind of webcam you are using for facetime? I've tried my old logitech messenger cam, it seems that Lion does not like it.

Thanks again!!!
 
Joined
Jan 11, 2011
Messages
25
Mac
Classic Mac
Mobile Phone
maymayhk said:
krischef18 said:
Hi have you had any dramas with MacApp store, FaceTime etc?
Also getting onboard audio is a two second job just need to install the voodoohda.kext supplied in the required recourses above. This particular kext will have onboard working 100%.

I found that a fresh install was best for me, as had some issues with some of the stuff I had installed on my Snow Leo, Also like to keep a previous os partition or hdd n case of emergency.

Anyway good to see we can have these boards running perfect. Lion is a definite improvement.

Thanks for the advice about the onboard audio driver. Will try that later. Yep, I am able to logon to AppStore and browse around. Just wondering what kind of webcam you are using for facetime? I've tried my old logitech messenger cam, it seems that Lion does not like it.

Thanks again!!!
No Worries at all, the cam I am using is a logitech c905 and works out of the box in face time, Skype, photo booth, initial setup request for user image. See link below.

http://www.logitech.com/en-au/webcam-co ... vices/5868

I was stoked to find the version of the kext in the resources, thanks to another user with our board on the osx86 hcl. as the version I had been using all through snow leopard provided sound but volume up and down didn't work. This one has been modded specifically for our board and as such gives us working audio 100% with volume control and all. Not that it was a huge issue but always nice when it just works.

Always good to here from a fellow apple hackintosher let us know how you go.
Cheers
Kris
 
Joined
May 20, 2011
Messages
50
Motherboard
Nvidia GA-Z68X-UD3H-B3
CPU
i7 2600K
Graphics
MSI N560GTX-TI
Mac
  1. MacBook
  2. MacBook Air
  3. Mac mini
  4. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Krischef18, many thanks for posting this guide!!!

I think I need to change my video card as I hear support for Nvidia 7800GT is gone, I do have 9600GT that I can throw in this system (needs to come out of my windows machine) but first I need to get a replacement for that machine.. Anyways, does anyone know if 9600 is supported?


Again, many thanks!!!
 
Joined
Mar 18, 2011
Messages
1
Motherboard
mac os x lion 10.7.4
CPU
intel e7400 2.8 ghz
Graphics
nvida 9500gs 7500
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. Android
  2. Other
I'm using the same motherboard with PS / 2 connectors lion all kext tried did not work, but work has tonymacx86 froze last vodoops2 kext did not click at all please help.

note: google translation

I'm turkish & kurdish
 
Joined
Jul 11, 2011
Messages
4
Motherboard
EP45-UD3R
CPU
E7400
Graphics
Geforce 9800GT
Mac
Classic Mac
Mobile Phone
  1. Other
Hi krischef18
I am at Step 2(post install) now
How to make this
<key>device-properties</key>
<string>***Your Combined Graphics and Ethernet String goes Here</string>

- what it will look like?
- Does your com.apple.Boot.plist( in D/L from http://www.mediafire.com/?6q38vdk0tfz5bh5) already combined Graphics and Ethernet ?
- If so, still need a Kexts for Network (AtherosL1cEthernet.kext) to put at S/L/E ?
 
Top