Contribute
Register

Lion Installed, but Having 2 Issues

Status
Not open for further replies.
Joined
Apr 13, 2011
Messages
153
Motherboard
Hackintosh
CPU
i-7 950
Graphics
NVidia GTX 285
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Finally got Lion to install, but now having two issues.

1) My internal drives are showing as external drives, and I'm not sure how to fix this.

2) I keep getting messages about "System Extensions cannot be used" with what SEEMS to be some of the audio kexts from Multibeast?
 
Joined
Jun 23, 2011
Messages
389
Motherboard
Asus p8Z68-v pro
CPU
2600k
Graphics
GTX 570
Mac
Classic Mac
Mobile Phone
  1. Android
psionicsin said:
Finally got Lion to install, but now having two issues.

1) My internal drives are showing as external drives, and I'm not sure how to fix this.


Isn't there a boot option in Multibeast for this?
 

samisnake

Moderator
Joined
Mar 7, 2011
Messages
3,726
Motherboard
MSI Z97i Gaming ACK
CPU
i5-4670K
Graphics
GTX 670
IOAHCIBlockStorageInjector.kext from multibeast will sort the drives
 
Joined
Dec 29, 2010
Messages
54
Mac
Classic Mac
Mobile Phone
1.) JBMicro kexts will take care of the drive icon issue.

2.) not sure on system extensions. Have not seen that before.
 

Attachments

  • Screen shot 2011-08-22 at 8.56.05 AM.png
    Screen shot 2011-08-22 at 8.56.05 AM.png
    100.6 KB · Views: 214
Joined
Jun 29, 2011
Messages
679
Mac
Classic Mac
Mobile Phone
Neat, how did you finally get Lion to work? Also, IOAHCIBlockStorageInjector will probably fix the problem with your internal driver. You can install it in Multibeast (located under Drivers->Kexts->Disk).
 
Joined
Apr 13, 2011
Messages
153
Motherboard
Hackintosh
CPU
i-7 950
Graphics
NVidia GTX 285
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
TheSmartGuy said:
Neat, how did you finally get Lion to work? Also, IOAHCIBlockStorageInjector will probably fix the problem with your internal driver. You can install it in Multibeast (located under Drivers->Kexts->Disk).

I re-created the DVD. Took a long while for it to install though. Can I run Multibeast without having to unplug all of my extra drives and RAM, and without having to boot with iBoot? Attempts so far have left me with an "Installation Failed" error.
 
Joined
Jun 29, 2011
Messages
679
Mac
Classic Mac
Mobile Phone
psionicsin said:
TheSmartGuy said:
Neat, how did you finally get Lion to work? Also, IOAHCIBlockStorageInjector will probably fix the problem with your internal driver. You can install it in Multibeast (located under Drivers->Kexts->Disk).

I re-created the DVD. Took a long while for it to install though. Can I run Multibeast without having to unplug all of my extra drives and RAM, and without having to boot with iBoot? Attempts so far have left me with an "Installation Failed" error.

"Installation Failed" errors are sometimes caused by Multibeast being unable to run System Utilities. Instead of installing System Utilities when you install a kext in Multibeast, install "Kext Utility" (located under "OSx86 Software"). After the installation in Multibeast, run Kext Helper. It does the same thing as System Utilities, except with less failure.
 
Joined
Apr 13, 2011
Messages
153
Motherboard
Hackintosh
CPU
i-7 950
Graphics
NVidia GTX 285
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Ok. Lion was failing all over the place. It's now...2:30am. I've been at this since near 12noon lol. This sucks.

Currently I have a BRAND SPAKING NEW FRESH INSTALL of 10.6.8 again. Can't get audio to work for some reason as I thought I installed al of the kext needed. This is so confusing.
 
Joined
Oct 20, 2010
Messages
11
Mac
Classic Mac
Mobile Phone
psionicsin, how were you able to install Lion?
I have the same board, but I have not been able to boot,
Thanks!
 
Status
Not open for further replies.
Top