Contribute
Register

Lion HDMI Audio - Part 1: Requirements

Status
Not open for further replies.

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Walgus said:
Just tried it and no luck unfortunately. Tried doing a few cold boots and unplugging the power cord but nothing, only HDMI audio worked well, tried internal speaker and any other output line but nothing on this board.
Attach a copy of IOReg (IORegistryExplorer/File/Save a Copy As...).
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Walgus said:
Just tried it and no luck unfortunately. Tried doing a few cold boots and unplugging the power cord but nothing, only HDMI audio worked well, tried internal speaker and any other output line but nothing on this board.
My mistake. If you have couple of minutes, try this. Install as is for on board audio and then patch for GTX 570 as above. Thanks.
 

Attachments

  • AppleHDA.kext.zip
    1.2 MB · Views: 66
Joined
Jul 4, 2011
Messages
55
Motherboard
ASRock z68 Fatal1ty Professional Gen3
CPU
i5 2500k
Graphics
EVGA GTX 570 HD
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
toleda said:
Walgus said:
Just tried it and no luck unfortunately. Tried doing a few cold boots and unplugging the power cord but nothing, only HDMI audio worked well, tried internal speaker and any other output line but nothing on this board.
My mistake. If you have couple of minutes, try this. Install as is for on board audio and then patch for GTX 570 as above. Thanks.

Sure, will try out and post back, thanks :thumbup:
 
Joined
Jul 4, 2011
Messages
55
Motherboard
ASRock z68 Fatal1ty Professional Gen3
CPU
i5 2500k
Graphics
EVGA GTX 570 HD
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
toleda said:
Walgus said:
Just tried it and no luck unfortunately. Tried doing a few cold boots and unplugging the power cord but nothing, only HDMI audio worked well, tried internal speaker and any other output line but nothing on this board.
My mistake. If you have couple of minutes, try this. Install as is for on board audio and then patch for GTX 570 as above. Thanks.

Impressive! Onboard ALC892 + GTX570 HDMI binpath working on this flawlessly, i can switch between internal speakers and HDMI audio with no problems!

Thanks so much for your time, much appreciated :thumbup:
 
Joined
Jul 4, 2011
Messages
55
Motherboard
ASRock z68 Fatal1ty Professional Gen3
CPU
i5 2500k
Graphics
EVGA GTX 570 HD
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
Hi Toleda,

I'm getting this error spamming my console with the latest ALC892 AppleHDA.kext as reported on here.

Code:
PM kernel: Sound assertion "kTypePinComplex != fType" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDAWidget.cpp" at line 1901 goto Exit



Maybe an specific layout892.xml and platforms.xml is needed for this board?

Thanks.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Walgus said:
Maybe an specific layout892.xml and platforms.xml is needed for this board?
Thanks.
The sound assertions are caused the patch of the 892 on the IDT codec. AppleHDA compares what it needs to what is available on the codec. There is a way to turn off that error but I don't have the time to try it. There is another patching method I will try in the next week or so which may resolve the problem.
 
Joined
Dec 28, 2011
Messages
4
Mac
Classic Mac
Mobile Phone
My machine config is i3-2100/GA-PH67A-D3-B3/Geforce 210, use HDMI connect to Benq EW2430v~

I can see the 1080p/1080i but can't see HDMI Audio ouput on my sound Pref,
And I did the DSDT fix and got the "HDAU@0,1" in my IO ....no sound /no HDMI output item
1.png
Try the step 2a(G 240) to fix Hex "AppleHDACon....." ,but startup crash.

Maybe I did something wrong, can any body help me?
 

Attachments

  • 1.png
    1.png
    115.2 KB · Views: 195

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
jacksonc0939 said:
My machine config is i3-2100/GA-PH67A-D3-B3/Geforce 210, use HDMI connect to Benq EW2430v~

Try the step 2a(G 240) to fix Hex "AppleHDACon....." ,but startup crash.

Maybe I did something wrong, can any body help me?
Is the IOReg screenshot before you patched AppleHDAController binary? Did you patch AppeHDA binary yet?
 
Joined
Dec 28, 2011
Messages
4
Mac
Classic Mac
Mobile Phone
5. Open DSDT-HDMI_Audio_Edits_v3 in DSDTSE.
6. Copy the code labeled "Nvidia_GE=Y-DSDT_HDMI_Audio_Edit - Complete" from DSDT-HDMI_Audio_Edits_v3.
7. Search "PEGP" (no quotes) in your dsdt.
8. Paste the copied code over the existing Device (PEGP), Device (GFX0) and Device (HDAU).
9. Compile.
10. Install.
11. Reboot with HDMI device connected.
12. Run IOReg, Search "HDAU".
13. Note device-id, this your HDMI Audio Device_id; save for later.
there were I already done~ 3Q for your reply, yes, this screenshot was before I patch the AppleHDAController.kext binary.

Example: HDMI Audio Device_id: "eb 0b".
Special Case - GT 240:
In Lion (AppleHDA_v2.1.x), GT240 (device_id; de 10 e4 0b) was not updated.
HexEdit/Find: "de 10 e4 0b", HexEdit/Replace: "de 10 e3 0b" 2 Times.
HexEdit/Find: "de 10 ea 0b", HexEdit/Replace: "de 10 eb 0b"
I did patch it use the part3b.Nvdia's "G240" way, but crash at startup : windows service when I reboot. :sick:

3Q for your help tell me how to patched the AppleHDAController.kext? and sorry for my poor English. :oops:
 
Joined
Jan 21, 2011
Messages
195
Motherboard
10.7.4 / Windows
CPU
Intel i7 2600K
Graphics
AMD 6870
Mac
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Didn't know which part to say thank you in, so I guess I'll just say it here.

Got ATI 6870 HDMI audio working fully on 10.7.2, instructions were clear and easy to understand.

So, again, thank you :)
 
Status
Not open for further replies.
Top