Contribute
Register

Lenovo Y50-70 Bluetooth Doesn't Recognize Media Devices. HELP!!!

Status
Not open for further replies.
Joined
Jun 30, 2018
Messages
10
Motherboard
Lenovo Y50-70(clover)
CPU
Intel i7-4720HQ
Graphics
GTX 860m/Intel HD 4600
Hello there, I've been a Hackintosh user since february 2018 over the period of time i've encountered bugs like graphics acceleration,wifi,touchpad etc and fixed them also. But this bug seem to have a rigid foundation and cant be fixed on the go i guess it needs some attention to detail. The problem is with the bluetooth it can't recognize any device and is on ever since i installed "Mojave" (In High Sierra it was working). I've tried every possible solution out there on the blogs and posts of different hackintosh support websites but cant resolve it. It would be great if anybody here help me to rectify this issue. My WiFi card is Atheros 956x wifi seem to work just fine though. I'm attaching the Screenshot so that you would have a better idea about what i'm talking about.
 

Attachments

  • Screenshot 2018-11-04 at 6.34.06 PM.png
    Screenshot 2018-11-04 at 6.34.06 PM.png
    57.8 KB · Views: 141

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello there, I've been a Hackintosh user since february 2018 over the period of time i've encountered bugs like graphics acceleration,wifi,touchpad etc and fixed them also. But this bug seem to have a rigid foundation and cant be fixed on the go i guess it needs some attention to detail. The problem is with the bluetooth it can't recognize any device and is on ever since i installed "Mojave" (In High Sierra it was working). I've tried every possible solution out there on the blogs and posts of different hackintosh support websites but cant resolve it. It would be great if anybody here help me to rectify this issue. My WiFi card is Atheros 956x wifi seem to work just fine though. I'm attaching the Screenshot so that you would have a better idea about what i'm talking about.
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jun 30, 2018
Messages
10
Motherboard
Lenovo Y50-70(clover)
CPU
Intel i7-4720HQ
Graphics
GTX 860m/Intel HD 4600
sorry my bad.. Hereby i'm attaching the problem reporting files.
Apart from this, After your recent patch for my laptop battery indicator also started to behave abnormally but it works perfectly without dsdt in place but in that case wifi doesnt work. I'm so messed up with all these and have very less idea about how to deal with these plese help me out. Thanks!!
 

Attachments

  • debug_1019.zip
    42.1 MB · Views: 93

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
sorry my bad.. Hereby i'm attaching the problem reporting files.
Apart from this, After your recent patch for my laptop battery indicator also started to behave abnormally but it works perfectly without dsdt in place but in that case wifi doesnt work. I'm so messed up with all these and have very less idea about how to deal with these plese help me out. Thanks!!

Read post #1 for recommended WiFi/BT hardware.
Your ACPI/patched content is wrong. Read/follow all post-install instructions in post #1.
 
Joined
Jun 30, 2018
Messages
10
Motherboard
Lenovo Y50-70(clover)
CPU
Intel i7-4720HQ
Graphics
GTX 860m/Intel HD 4600
Hey, I actually got the fix (turn around works phenomonally well) for my AR956x module i used following procedures in sequence and reset my bluetooth module that's it.
1. Install the kext in the manner demonstrated in this video Kext for wifi ar9565 for hackintosh macOS Sierra 10.12 (16A323)
2. Then do the same demonstrated in this video Kext ar9565 ar9485 ar9462 ar9463 for hackintosh MacOS High Sierra 10.13.x.
3. Reboot
4. Press shift + alt and hold it and click on Reset buetooth module. (By now you should be able to see the devices if not follow the next feew steps.)
5. Dont release it yet wait for the password prompt enter your password and hit enter.
6. Open the bluetooth PreferencePance and you should able to see the small lock next to theturn bluetooth off button.(Now you can release those keys).
7. click on it enter your credential again. Now search for your bluetooth device.
8. Done. Reboot and Enjoy.

See the attachments for the kexts.
 

Attachments

  • Screenshot 2018-11-09 at 10.34.50 AM.png
    Screenshot 2018-11-09 at 10.34.50 AM.png
    60.6 KB · Views: 187
  • 9565.zip
    5.8 MB · Views: 63
  • WIFIAR.zip
    28.6 MB · Views: 60
Last edited:
Joined
Jun 30, 2018
Messages
10
Motherboard
Lenovo Y50-70(clover)
CPU
Intel i7-4720HQ
Graphics
GTX 860m/Intel HD 4600
Apparently, I fixed the battery indicator as well with older version of AppleACPIPlatform.kext and AppleSmartBatteryManager.kext. Looking forward for dsdtless drivers in the future updates currently the notify time duration is 20 seconds. Is there a way to reduce that ? if it is let me know.
Thank you for the support!!!
 

Attachments

  • After.png
    After.png
    98.3 KB · Views: 141
  • before.png
    before.png
    103 KB · Views: 117

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Apparently, I fixed the battery indicator as well with older version of AppleACPIPlatform.kext and AppleSmartBatteryManager.kext. Looking forward for dsdtless drivers in the future updates currently the notify time duration is 20 seconds. Is there a way to reduce that ? if it is let me know.
Thank you for the support!!!

Bad idea to use old AppleACPIPlatform.kext. It breaks CPU PM.
 
Joined
Jun 30, 2018
Messages
10
Motherboard
Lenovo Y50-70(clover)
CPU
Intel i7-4720HQ
Graphics
GTX 860m/Intel HD 4600
Bad idea to use old AppleACPIPlatform.kext. It breaks CPU PM.
Yeah, patching dsdt for the new one is a long process i hope there will be dsdtless kexts for it. so far it doesn't seem to be malfunctioning.
 
Joined
Jun 30, 2018
Messages
10
Motherboard
Lenovo Y50-70(clover)
CPU
Intel i7-4720HQ
Graphics
GTX 860m/Intel HD 4600
I did followed that guide and got my brightness working but out of the following.

Expect to work:
- UEFI booting via Clover
- built-in keyboard (with brightness keys)
- built-in trackpad (basic gestures)
- HDMI video/audio with hotplug (please verify, the patches came from the u430 repo and may need tweaking)
- AirPlay mirroring to AppleTV
- native WiFi via BCM94352Z
- Bluetooth (with handoff) using BCM94352Z
- native USB3 with AppleUSBXHCI (USB2 works also)
- native audio with AppleHDA (using injector for easy updates), including headphone
- built-in mic
- built-in camera
- native power management
- battery status
- backlight controls with smooth transitions, save/restore across restart
- accelerated graphics for HD4600 including OpenCL
- wired Ethernet
- Mac App Store working
- retina scaling (in the case of UHD screen)

I faced many issues across like graphics glitch at 1080p resolution for native display(while hovering over ui of apps), battery status, Bluetooth (requires manual upload of BTFirmware using different os). I need to fix all of these..
 
Status
Not open for further replies.
Top