Contribute
Register

Lenovo W530: [SUCCESS] Yosemite Clover Installation

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi. Now learning more :)

I just testet to get PM to work. I used DPCI Manager to check what's in your tutorial.
P-States is always showing : P State 12

As i can see the battery goes down very fast, so i think there is no PowerManagement on my W530.

But in the Clover Partition there is a Patched AppleIntelCPU....kext

Can anyone (Rehabmen :mrgreen:) point me to the right direction, on getting this to work?

Thank you.
With Clover there is no need to install patched AppleIntelCPUPowerManagement. And EFI/Clover/kexts would be the wrong place to put it anyway (kexts that are already in /S/L/E cannot be injected via Clover).

Read here: http://www.tonymacx86.com/yosemite-laptop-support/146870-guide-native-power-management-laptops.html
 
Joined
Feb 8, 2015
Messages
10
Motherboard
Lenovo W530
CPU
i7-3630QM
Graphics
HD4000/NVK1000M
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Hi, pf course there is no need to install this kext. sometimes i write thinks i dont mean. I used clover configurator to enable p and c state. but in dpci manager it changes nothing, its only p state 12. also i have used me my prepatched dsdt.aml.

whats wrong? :)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi, pf course there is no need to install this kext. sometimes i write thinks i dont mean. I used clover configurator to enable p and c state. but in dpci manager it changes nothing, its only p state 12. also i have used me my prepatched dsdt.aml.

whats wrong? :)
Read at link provided in post #21.
 
Joined
Jun 13, 2012
Messages
3
Mac
Classic Mac
Mobile Phone
Android, iOS
Hi, I also have a W530, I have managed to install yosemite using clover but currently booting it from the install USB, but I am unsure of how to use the file you provided, do I install clover and then just copy the content of the compressed file to the root of my hard drive or do I not bother installing clover and just copy to the root of the hard drive, any chance you could provide some help with exactly what you did in terms of installing software/applying patches to get everything working (other than wifi)? Thanks in advance.
 
Joined
Feb 8, 2015
Messages
10
Motherboard
Lenovo W530
CPU
i7-3630QM
Graphics
HD4000/NVK1000M
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
No, you have to copy the EFI Folder on your USB if you boot from there, just overwrite the old EFI Folder. Thats what i do, but there is much more to do as you can see in my last Posts.

I have running now everthing expeckt Sleep.

@Rehebman (Pm is working now :)) SSDT creation is magic ;-)

But i have a question about sleep:

i already tryed everthing from this Post:

http://www.tonymacx86.com/mavericks-laptop-support/133291-dsdt-patch-sleep-brightness-speedstep-4.html

but it seems to be not work coreckt.

If i go to sleep the Display go black and HDD is working about 5-10 Sec. Then the Powerled is slowly flashing. But is seems not to sleep. Because if i press the Mouse or Keyboard the login screen shows after just 1sec.

I added all the patches from the post. But i ran into an error to boot. couldnt figure out what it is ;o(

any ideas, please no mor links to tutorials ;-)

Thank you Rehebman
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
No, you have to copy the EFI Folder on your USB if you boot from there, just overwrite the old EFI Folder. Thats what i do, but there is much more to do as you can see in my last Posts.

I have running now everthing expeckt Sleep.

@Rehebman (Pm is working now :)) SSDT creation is magic ;-)

But i have a question about sleep:

i already tryed everthing from this Post:

http://www.tonymacx86.com/mavericks-laptop-support/133291-dsdt-patch-sleep-brightness-speedstep-4.html

but it seems to be not work coreckt.

If i go to sleep the Display go black and HDD is working about 5-10 Sec. Then the Powerled is slowly flashing. But is seems not to sleep. Because if i press the Mouse or Keyboard the login screen shows after just 1sec.

I added all the patches from the post. But i ran into an error to boot. couldnt figure out what it is ;o(

any ideas, please no mor links to tutorials ;-)

Thank you Rehebman
DSDT/SSDT patching: http://www.tonymacx86.com/yosemite-laptop-support/152573-guide-patching-laptop-dsdt-ssdts.html

From your description sleep is working. Wake up from sleep is very fast.
 
Joined
May 15, 2017
Messages
1
I would just like to share with the community that I managed to get W530 running Yosemite 10.10 using Clover. I am attaching my EFI folder for anyone that would like to try to install it.

You must boot with the following flags:

-v kext-dev-mode=1

BIOS:
Enable only the Integrated Graphics (HD4000)
Disable CMS Support

What Works:

-Brightness: with Rehabman's kext /DSDT patching
-Battery: with Rehabman's kext / DSDT patching
-Bluetooth (had to swap the Bluetooth Module with one from a X220)
-Sound

What doesn't work:
-Wifi (W530 has a whitelist BIOS) and haven't found a compatible card. Anyone know of a compatible one? :confused:


Still working on:
-SSDT creation and power management.
-I will try to load the latest Nvidia Drivers for Yosemite since mini DisplayPort is most likely wired to the Nvidia card and thus must be enabled if you want video out.


Please let me know if anyone has any questions.
QUESTION (June 2017): Is there any way to enable discrete graphics at this point? I know it was the issue in the past, so I am wondering whether any progress has been made. Please kindly let me know.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Jun 19, 2018
Messages
92
Motherboard
Lenovo thinkpad w530
CPU
Mobile QuadCore Intel Core i7 3920XM 3100 MHz Ivy Bridge-MB
Graphics
NVIDIA Quadro K2000M / Intel HD Graphics 4000 - 2 GB DDR3 SDRAM
Mac
MacBook Pro
Mobile Phone
iOS
I would just like to share with the community that I managed to get W530 running Yosemite 10.10 using Clover. I am attaching my EFI folder for anyone that would like to try to install it.

You must boot with the following flags:

-v kext-dev-mode=1

BIOS:
Enable only the Integrated Graphics (HD4000)
Disable CMS Support

What Works:

-Brightness: with Rehabman's kext /DSDT patching
-Battery: with Rehabman's kext / DSDT patching
-Bluetooth (had to swap the Bluetooth Module with one from a X220)
-Sound

What doesn't work:
-Wifi (W530 has a whitelist BIOS) and haven't found a compatible card. Anyone know of a compatible one? :confused:


Still working on:
-SSDT creation and power management.
-I will try to load the latest Nvidia Drivers for Yosemite since mini DisplayPort is most likely wired to the Nvidia card and thus must be enabled if you want video out.


Please let me know if anyone has any questions.
Hi @xcaret I’m driving crazy with the sound on a w530 and high sierra. How did you do?? Thanks!
 
Top