Contribute
Register

Lenovo ThinkPad P50 nVidia Quadro M1000M

Joined
Jan 11, 2019
Messages
6
Motherboard
Lenovo ThinkPad P50-Clover
CPU
i7-6700HQ
Graphics
Quadro M1000M
I'm running HighSierra on a 4k ThinkPad P50 and everything works great with the built in Intel GFX.

I've enabled the "Discrete Graphics" in BIOS and I'm now trying to get the Quadro M1000M to work.

Using Inject Nvidia in Clover, OS X detects my card but I don't have any hardware acceleration and it limits me to 1024x768

Attached are the generated logs. What am I doing wrong?
 

Attachments

Joined
Feb 28, 2018
Messages
49
Motherboard
Lenovo Thinkpad L1HF63B00HA
CPU
i7-6700HQ
Graphics
Quadro M1000M, 1920x1080
I'm running HighSierra on a 4k ThinkPad P50 and everything works great with the built in Intel GFX.

I've enabled the "Discrete Graphics" in BIOS and I'm now trying to get the Quadro M1000M to work.

Using Inject Nvidia in Clover, OS X detects my card but I don't have any hardware acceleration and it limits me to 1024x768

Attached are the generated logs. What am I doing wrong?
We seem to be having similar issues (thought mine does not display the actual correct GPU yet).

I'm assuming your config.plist (not the clean or Intel one) is what you're using. If so, you might want to check NvidiaWeb.
 
Joined
Jan 11, 2019
Messages
6
Motherboard
Lenovo ThinkPad P50-Clover
CPU
i7-6700HQ
Graphics
Quadro M1000M
I notice in the bootlog.txt file this:
123:596 0:227 ERROR: Unable to locate nVidia Video BIOS
123:596 0:000 there are no ROM loaded and no VBIOS read from hardware
I've google this but I can't find any real answer to what this error means.

Ideas?
 
Joined
Feb 28, 2018
Messages
49
Motherboard
Lenovo Thinkpad L1HF63B00HA
CPU
i7-6700HQ
Graphics
Quadro M1000M, 1920x1080
I notice in the bootlog.txt file this:


I've google this but I can't find any real answer to what this error means.

Ideas?
Looking into that now, but InjectNvidia should be false iirc. Try setting InjectSystemID to true as well.
 
Joined
Feb 28, 2018
Messages
49
Motherboard
Lenovo Thinkpad L1HF63B00HA
CPU
i7-6700HQ
Graphics
Quadro M1000M, 1920x1080
Also, you need to set Vbios to true.
 
Joined
Jan 11, 2019
Messages
6
Motherboard
Lenovo ThinkPad P50-Clover
CPU
i7-6700HQ
Graphics
Quadro M1000M
I've reinstalled High Sierra 10.13.6, set InjectNvidia to false and installed nVidia Web Drivers (tried multiple versions using webdriver.sh, same result). NvidiaWeb and InjectSystemID are checked.

The system just hangs while trying to boot:
395511


I can boot if i set nv_disable=1 in Clover, and i've gathered the attached logs.
 

Attachments

Joined
Feb 28, 2018
Messages
49
Motherboard
Lenovo Thinkpad L1HF63B00HA
CPU
i7-6700HQ
Graphics
Quadro M1000M, 1920x1080
These are essentially the same results I am getting as well. Even stalling out at the same location.
 
Joined
Oct 10, 2018
Messages
16
Motherboard
Supermicro X11DPH-i
CPU
ES-6149
Graphics
GTX 760
Mac
MacBook Pro
Check my post
 
Top