Contribute
Register

Lenovo T540p UniBeast Install Crash

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
As I have already described I tried this. Result: Whether with the FakePCIID kexkts or without - the laptop will only boot if I set up the Graphics section of config.plist to inject only the NVidia card.
Code:
<key>Ati</key>
<false/>
<key>Intel</key>
<false/>
<key>NVidia</key>
<true/>

If I try like in the fix-intel-hd4200-hd4400-hd4600-mobile-yosemite thread
Code:
<key>Ati</key>
<false/>
<key>Intel</key>
<true/>
<key>NVidia</key>
<false/>
It won't boot anymore. Verbose boot shows "DSMOS arrived" as last message and then the laptop reboots. It doesn't matter whether the ig-platform-id is 0xa260006, changed or set to 0x0.

Provide output from 'lspci -nn' in Linux Terminal.

Post your EFI/CLOVER folder that you're using to boot.

Also...

Please provide complete details in your profile.

System: manufacturer/model
CPU: detailed CPU model + motherboard chipset
Graphics: all graphics devices + laptop internal screen resolution

For example, typical Ivy laptop:
System: ProBook 4540s
CPU: i5-3320m/HM76
Graphics: HD4000, 1366x768

Use CPU-Z on Windows to find CPU (Core iX-xxx) and motherboard chipset (HMxx). For a laptop, these details are important and affect critical installation procedures.
 
Joined
Oct 23, 2013
Messages
15
Motherboard
Lenovo T540p
CPU
i7-4700MQ, 20BFS27X00
Graphics
Intel HD 4600, Nvidia GT 730M, 1920x1080
Mac
Classic Mac
Mobile Phone

Attachments

  • lspci.txt
    2.2 KB · Views: 96
  • EFI.zip
    3.5 MB · Views: 85
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Oct 23, 2013
Messages
15
Motherboard
Lenovo T540p
CPU
i7-4700MQ, 20BFS27X00
Graphics
Intel HD 4600, Nvidia GT 730M, 1920x1080
Mac
Classic Mac
Mobile Phone
I just updated the EFI.zip. Now it's the version which actually allows me to boot. (but with only 7 MB VRAM and flickering Graphics)
Photo following...

edit: photo done
 

Attachments

  • startup.jpg
    startup.jpg
    1 MB · Views: 131
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I just updated the EFI.zip. Now it's the version which actually allows me to boot. (but with only 7 MB VRAM and flickering Graphics)
Photo following...

You probably need to inject EDID...
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Just tried to inject it in config.plist -
<key>InjectEDID</key>
<true/>

-- doesn't do anything, symptom excatly the same as before. :(

Suggestions:
- give it plenty of time. it is not quick.
- try different ig-platform-id values
- remove FakeSMC.kext/Contents/PlugIns/GPUSensors.kext
- try setting a custom EDID (config.plist/Graphics/CustomEDID + InjectEDID)
 
Status
Not open for further replies.
Top