Contribute
Register

Lenovo Flex 3 1580 - Cannot Get Accelerated Graphics with HD 520

Joined
Dec 28, 2018
Messages
7
Motherboard
Lenovo Flex 3 1580
CPU
i5-6200U
Graphics
HD 520
Mac
MacBook
I successfully installed macOS Mojave (10.14.2) on a Lenovo Flex 3. Most things are working fine, except the graphics. It looks like there is no acceleration at all. It runs pretty slowly, there are some graphical glitches, and none of the effects (blur) work.

Attached is the Clover folder with the configs and kexts. I say configs because there is two of them in there. One makes the computer boot, the other one (supposedly) enables graphics acceleration. It's the config from RehabMan's GitHub with some edits done by me, hoping it does anything (the stock one didn't work either).

Any help would be appreciated.
 

Attachments

Joined
Dec 28, 2018
Messages
7
Motherboard
Lenovo Flex 3 1580
CPU
i5-6200U
Graphics
HD 520
Mac
MacBook
I should add that when I say it doesn't boot, I meant it gets stuck at "End RandomSeed" with no other errors. I left it there for about 30 minutes and it doesn't progress beyond that point.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
10,414
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
I should add that when I say it doesn't boot, I meant it gets stuck at "End RandomSeed" with no other errors. I left it there for about 30 minutes and it doesn't progress beyond that point.
make sure to rename config,.plist as config.plist

you have too many fixes:
Code:
<key>Fixes</key>
            <dict>
                <key>AddDTGP</key>
                <true/>
                <key>AddMCHC</key>
                <true/>
                <key>DeleteUnused</key>
                <true/>
                <key>FixDarwin</key>
                <true/>
                <key>FixDarwin7</key>
                <true/>
                <key>FixDisplay</key>
                <true/>
                <key>FixHDA</key>
                <true/>
                <key>FixHPET</key>
                <true/>
                <key>FixIPIC</key>
                <true/>
                <key>FixRegions</key>
                <true/>
                <key>FixS3D</key>
                <true/>
                <key>FixShutdown</key>
                <true/>
                <key>FixTMR</key>
                <true/>
                <key>FixWAK</key>
                <true/>
            </dict>
InjectKexts should be set to Detect

get fresh config.plist from the laptop guide:

also search for End RandomSeed there are many posts relating to it
 
Joined
Dec 28, 2018
Messages
7
Motherboard
Lenovo Flex 3 1580
CPU
i5-6200U
Graphics
HD 520
Mac
MacBook
you have too many fixes:
I am aware of that, but something in the bootable plist is making it work, and I'm not sure what it is. It could also be the reason for missing acceleration, but again, I'm not sure what is responsible for it booting.
also search for End RandomSeed there are many posts relating to it
I have tried this already, along with booting with a fresh 520 plist, but they don't work. To most people the issue was they were missing the AptioMemoryFix driver, which I have. I don't know why it gets stuck at End RandomSeed with the cleaner configs, and why it doesn't with the other one.

I also took a picture of the verbose output, if it helps.
393557
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
10,414
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
I am aware of that, but something in the bootable plist is making it work, and I'm not sure what it is. It could also be the reason for missing acceleration, but again, I'm not sure what is responsible for it booting.

I have tried this already, along with booting with a fresh 520 plist, but they don't work. To most people the issue was they were missing the AptioMemoryFix driver, which I have. I don't know why it gets stuck at End RandomSeed with the cleaner configs, and why it doesn't with the other one.

I also took a picture of the verbose output, if it helps.View attachment 393557
try the other Osx files 1 at a time as mentioned in the laptop guide
 
Joined
Dec 28, 2018
Messages
7
Motherboard
Lenovo Flex 3 1580
CPU
i5-6200U
Graphics
HD 520
Mac
MacBook
Okay, I tried both OsxAptioFixDrv and OsxAptioFix3Drv, both of which didn't do anything. I couldn't find the 2nd variant though.

Is that whole "End RandomSeed" specifically a memory issue or is there another meaning to it?
 
Top