Layman's guide to access Mac App Store with NullEthernet.kext

Discussion in 'Network' started by pcmarques, Mar 8, 2014.

  1. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    134,320
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Dec 1, 2016 at 12:47 AM #151
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    134,320
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Clover bootlog (extracted from ioreg) shows DSDT.aml not loading.
    Conclusion: You're not booting from the EFI/Clover you provide here.
    Without patched DSDT.aml with RMNE object in it, no catalyst to load NullEthernet.kext.

    Investigate why you're not booting from the Clover folder you think you are.
     
  2. bennyp8585

    bennyp8585

    Joined:
    Jun 6, 2015
    Messages:
    7
    Dec 1, 2016 at 3:16 AM #152
    bennyp8585

    bennyp8585

    Joined:
    Jun 6, 2015
    Messages:
    7
    IS it possible I need to change a setting in clover configurator and save the config.plist?

    EDIT:
    I figured it out.
    I was posting the /EFI/CLOVER from the COMPUTER/ELCAPITAN
    I realised I should have mounted EFI partition and add the SSDT.aml to /EFI/EFI/CLOVER/ACPI/patched
    Once I did that I could add the fake ethernet and now app store is working.
    Thanks for pointing me in the right direction
     
    Last edited: Dec 1, 2016
  3. theruck

    theruck

    Joined:
    Jan 23, 2011
    Messages:
    50
    Mobo:
    intel DZ68BC
    CPU:
    Core i5 2500K
    Graphics:
    Gigabyte GTX 560 Ti
    Dec 19, 2016 at 3:05 PM #153
    theruck

    theruck

    Joined:
    Jan 23, 2011
    Messages:
    50
    Mobo:
    intel DZ68BC
    CPU:
    Core i5 2500K
    Graphics:
    Gigabyte GTX 560 Ti
    Hi,
    i am desperately trying to enable appstore on an asus x305f which does not have a native wifi adapter nor an ethernet adapter.
    i installed the 2 kexts, built 3 days ago but can not see the nullethernet device as an option to add when i try to add a device in network properties.
    attached files contain the output of ioreg and clover and output of the terminal commands requested in previous posts
     

    Attached Files:

  4. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    134,320
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Dec 19, 2016 at 3:13 PM #154
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    134,320
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Attach output of (in Terminal):
    Code (Text):

    sudo touch /System/Library/Extensions && sudo kextcache -u /
     
     
  5. theruck

    theruck

    Joined:
    Jan 23, 2011
    Messages:
    50
    Mobo:
    intel DZ68BC
    CPU:
    Core i5 2500K
    Graphics:
    Gigabyte GTX 560 Ti
    Dec 20, 2016 at 7:56 AM #155
    theruck

    theruck

    Joined:
    Jan 23, 2011
    Messages:
    50
    Mobo:
    intel DZ68BC
    CPU:
    Core i5 2500K
    Graphics:
    Gigabyte GTX 560 Ti
    Code (Text):

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext NullEthernetForce.kext
    kext-dev-mode allowing invalid signature -67054 0xFFFFFFFFFFFEFA12 for kext AppleKextExcludeList.kext
    KernelCache ID: 4CDE39E84A83DDB74A5E666BF61F9F3D
    symlink("/System/Library/PrelinkedKernels/prelinkedkernel", "/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache") failed 17 (File exists) <createPrelinkedKernel 2795>
     
    thank you for your help
     
  6. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    134,320
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Dec 20, 2016 at 1:48 PM #156
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    134,320
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    You forgot to install NullEthernet.kext.
     
  7. theruck

    theruck

    Joined:
    Jan 23, 2011
    Messages:
    50
    Mobo:
    intel DZ68BC
    CPU:
    Core i5 2500K
    Graphics:
    Gigabyte GTX 560 Ti
    Dec 21, 2016 at 12:13 PM #157
    theruck

    theruck

    Joined:
    Jan 23, 2011
    Messages:
    50
    Mobo:
    intel DZ68BC
    CPU:
    Core i5 2500K
    Graphics:
    Gigabyte GTX 560 Ti
    as usually you were right. thank you very much. anyway i am still not able to connect to appstore/icloud even the ethernet card is detected as en0. i will try some more excercise with SMBIOS
     
  8. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    134,320
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Dec 21, 2016 at 3:03 PM #158
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    134,320
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    NullEthernetForce.kext does not work and has been removed.
     
  9. theruck

    theruck

    Joined:
    Jan 23, 2011
    Messages:
    50
    Mobo:
    intel DZ68BC
    CPU:
    Core i5 2500K
    Graphics:
    Gigabyte GTX 560 Ti
    Dec 22, 2016 at 7:12 AM #159
    theruck

    theruck

    Joined:
    Jan 23, 2011
    Messages:
    50
    Mobo:
    intel DZ68BC
    CPU:
    Core i5 2500K
    Graphics:
    Gigabyte GTX 560 Ti
    yes i noticed your latest update yesterday and now i use the DSDT patched mode. i have the ethernet as en0 but still the icloud says "you can not sign in right now, please try again later"
    i do not understand how do i change the mac address though so the default is used so maybe apple is denying that

    question: should efi studio list the nullethernet adapter list as a real device or not?
     
    Last edited: Dec 22, 2016
  10. theruck

    theruck

    Joined:
    Jan 23, 2011
    Messages:
    50
    Mobo:
    intel DZ68BC
    CPU:
    Core i5 2500K
    Graphics:
    Gigabyte GTX 560 Ti
    Dec 22, 2016 at 12:15 PM #160
    theruck

    theruck

    Joined:
    Jan 23, 2011
    Messages:
    50
    Mobo:
    intel DZ68BC
    CPU:
    Core i5 2500K
    Graphics:
    Gigabyte GTX 560 Ti
    attaching ioreg export
     

    Attached Files:

Share This Page