Layman's guide to access Mac App Store with NullEthernet.kext

Discussion in 'Network' started by pcmarques, Mar 8, 2014.

  1. gorillaslongboard

    gorillaslongboard

    Joined:
    Oct 13, 2016
    Messages:
    10
    Mobo:
    macbook pro 13"retina
    Oct 13, 2016 at 10:33 PM #141
    gorillaslongboard

    gorillaslongboard

    Joined:
    Oct 13, 2016
    Messages:
    10
    Mobo:
    macbook pro 13"retina
    ok, I used DSDT
    what would it be EFI/Clover/ACPI?
     
  2. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    149,271
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Oct 14, 2016 at 2:38 AM #142
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    149,271
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Clover loads all patched and add-on ACPI content from ACPI/patched.
     
  3. gorillaslongboard

    gorillaslongboard

    Joined:
    Oct 13, 2016
    Messages:
    10
    Mobo:
    macbook pro 13"retina
    Oct 14, 2016 at 3:06 AM #143
    gorillaslongboard

    gorillaslongboard

    Joined:
    Oct 13, 2016
    Messages:
    10
    Mobo:
    macbook pro 13"retina
    understand ..
    I find it hard for me
    I will buy a board new in ebay, more easy
    thank you for patience
     
  4. RobD

    RobD

    Joined:
    Apr 14, 2010
    Messages:
    8
    Mobo:
    Desktop
    CPU:
    2.83 GHz Quad-Core Q9505
    Graphics:
    PNY 8400 GS
    Oct 31, 2016 at 10:13 AM #144
    RobD

    RobD

    Joined:
    Apr 14, 2010
    Messages:
    8
    Mobo:
    Desktop
    CPU:
    2.83 GHz Quad-Core Q9505
    Graphics:
    PNY 8400 GS
    Thanks for this, managed to get App Store sign in back after updating/fresh install of Sierra. Never posed a problem before, on EL Capitan and previous, App Store log in was always possible, for some reason Sierra made it more difficult.

    At step "6 – Copy the file ssdt–rnme.aml included in to the folder "/Extra/". Rename it to ssdt.aml." all I did was copy the provided "ssdt–rnme.aml" to EFI/Clover/ACPI/patched (as you suggested later in the thread), rename it ssdt.aml, follow the rest and it was all good.

    Could be an idea to amend the original post to include this later info?

    Thanks again.
     
  5. JohnnyBoy27

    JohnnyBoy27

    Joined:
    Nov 24, 2016
    Messages:
    2
    Nov 26, 2016 at 9:57 AM #145
    JohnnyBoy27

    JohnnyBoy27

    Joined:
    Nov 24, 2016
    Messages:
    2
    Hello all,
    I recovered an old macbook air but apparently wifi card is broken and not detected.
    I followed your guide but in order to gain access to the app store but cannot seem to make it work.
    I have installed the .kext using the kext wizard, and tried patching the ssdt using maciassl. I repeated this process several times but however the null ethernet never appears in the network settings panel. Also, where should I find the /Extra folder for the ssdt method?

    Thank you in advance,
    JC
     
  6. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    149,271
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Nov 26, 2016 at 3:12 PM #146
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    149,271
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    You would need to use a hackintosh bootloader on your Mac in order to patch ACPI...
     
  7. JohnnyBoy27

    JohnnyBoy27

    Joined:
    Nov 24, 2016
    Messages:
    2
    Nov 27, 2016 at 11:47 AM #147
    JohnnyBoy27

    JohnnyBoy27

    Joined:
    Nov 24, 2016
    Messages:
    2
    Thank you very much RehabMan.
    I installed clover and was able to access the AppStore and update my OS X to Sierra.
    However, after the update the fake ethernet is no longer appearing. I tried repeating the process but clover failed to install.
    Do you have any advice or guide into solving the problem?
    Thank you very much again for your help and great work with the nullethernet.
    Chrs,

    JC
     
  8. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    149,271
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Nov 27, 2016 at 3:23 PM #148
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    149,271
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Would need standard "Problem Reporting" files...

    Attach ioreg as ZIP: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

    Provide output (in Terminal):
    Code (Text):

    kextstat|grep -y acpiplat
    kextstat|grep -y appleintelcpu
    kextstat|grep -y applelpc
    kextstat|grep -y applehda
     
    Attach EFI/Clover folder as ZIP (press F4 at main Clover screen before collecting). Please eliminate 'themes' directory. Provide only EFI/Clover, not the entire EFI folder.

    Attach output of (in Terminal):
    Code (Text):

    sudo touch /System/Library/Extensions && sudo kextcache -u /
     
    Compress all files as ZIP. Do not use external links. Attach all files using site attachments only.
     
  9. bennyp8585

    bennyp8585

    Joined:
    Jun 6, 2015
    Messages:
    7
    Nov 30, 2016 at 11:15 AM #149
    bennyp8585

    bennyp8585

    Joined:
    Jun 6, 2015
    Messages:
    7
    Hi I've followed the guide to installing NullEthernet but still do not get the option to add the fake ethernet.
    I did have it working on Yosemite but have since upgraded to El Capitan and cannot seem to get it working.
    I have attached the output from terminal commands and have put the clover folder in there also.
    Please let me know if you need anymore info.
    Thanks for the help
     

    Attached Files:

  10. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    149,271
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Dec 1, 2016 at 12:47 AM #150
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    149,271
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Clover bootlog (extracted from ioreg) shows DSDT.aml not loading.
    Conclusion: You're not booting from the EFI/Clover you provide here.
    Without patched DSDT.aml with RMNE object in it, no catalyst to load NullEthernet.kext.

    Investigate why you're not booting from the Clover folder you think you are.
     

Share This Page