Contribute
Register

Latest Unibeast Mavericks and Lenovo ThinkPad T430

Joined
Nov 19, 2012
Messages
10
Motherboard
Lenovo T430 2347A39
CPU
Intel® Core™ i5-3320M
Graphics
intel HD 4000 and NVS5400M 1600x900
Mac
Classic Mac
Mobile Phone
Android
My scenario:
MBR USB Unibeast Mavericks from App store.

Results until now:
Blank screen or reboot even before install screen.

Setup:

Bios updated
Display integrated or discrete
ACHI
VT-D disabled
Boot Legacy only of both
USB UEFI support (if not, can't boot)

Have tried:

Flags -x -v
GraphicsEnabled=no or Yes
PCIRootUID=1 or 0
npci=0x3000


My computer:

Lenovo ThinkPad T430 - type 2347-A39
i5-3320M
Chipset QM77 Express
NVIDIA NVS 5400M
Intel HD 4000
HD#1 SSD
HD#2 SATA
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,101
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
My scenario:
MBR USB Unibeast Mavericks from App store.

Results until now:
Blank screen or reboot even before install screen.

Setup:

Bios updated
Display integrated or discrete
ACHI
VT-D disabled
Boot Legacy only of both
USB UEFI support (if not, can't boot)

Have tried:

Flags -x -v
GraphicsEnabled=no or Yes
PCIRootUID=1 or 0
npci=0x3000


My computer:

Lenovo ThinkPad T430 - type 2347-A39
i5-3320M
Chipset QM77 Express
NVIDIA NVS 5400M
Intel HD 4000
HD#1 SSD
HD#2 SATA
It is not GraphicsEnabled, it is GraphicsEnabler.

Use these flags:
IGPEnabler=N GraphicsEnabler=N -x -v -f UseKernelCache=N dart=0

If it does not work, you will need to remove the nvidia kexts, NV*, GeForce* (or disable nvidia in BIOS).
 
Joined
Nov 19, 2012
Messages
10
Motherboard
Lenovo T430 2347A39
CPU
Intel® Core™ i5-3320M
Graphics
intel HD 4000 and NVS5400M 1600x900
Mac
Classic Mac
Mobile Phone
Android
I've tried these flags IGPEnabler=N GraphicsEnabler=N -x -v -f UseKernelCache=N dart=0
and have set to integrated video and is rebooting after:

...Webdav_fs
Pausing 5 seconds
Errors encountered while starting...
and reboot
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,101
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I've tried these flags IGPEnabler=N GraphicsEnabler=N -x -v -f UseKernelCache=N dart=0
and have set to integrated video and is rebooting after:

...Webdav_fs
Pausing 5 seconds
Errors encountered while starting...
and reboot
It is likely Local ACPI panic causing instant reboot. Have you installed the KernelPatcher module from Chameleon? Note: I think the latest version may be broken. Try it, but if you have the same result go back to a previous version.

Official location of Chameleon builds: http://www.insanelymac.com/forum/topic/231075-chameleon-22svn-official-pkg-installer-binaries/
 
Joined
Nov 19, 2012
Messages
10
Motherboard
Lenovo T430 2347A39
CPU
Intel® Core™ i5-3320M
Graphics
intel HD 4000 and NVS5400M 1600x900
Mac
Classic Mac
Mobile Phone
Android
No, I did only Unibeast with Laptop support.
In the firsts attempts I got just blank screen but it was at the end. Just from the latests attempts I got reboots after the 5 seconds pause.
I don't know how work with Chameleon.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,101
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
No, I did only Unibeast with Laptop support.
In the firsts attempts I got just blank screen but it was at the end. Just from the latests attempts I got reboots after the 5 seconds pause.
I don't know how work with Chameleon.
You don't necessarily need to install Chameleon itself, but you need the KernelPatcher module. Or you can patch the kernel yourself for lapic panic.

Chimera is simply a branch of Chameleon, so if you know how to work with Chimera, you know how to work with Chameleon. There are slight differences (definition of a branch), of course...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,101
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Nov 19, 2012
Messages
10
Motherboard
Lenovo T430 2347A39
CPU
Intel® Core™ i5-3320M
Graphics
intel HD 4000 and NVS5400M 1600x900
Mac
Classic Mac
Mobile Phone
Android
I had an unformatted partition in my SATA Samsung HD. I just formatted it and got the blank screen again, at least reboots no more...

After that, I used -v GraphicsEnabler=N IGPEnabler=N and slowly the install screen appeared. First the mouse arrow and then the background, very slowly.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,101
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I had an unformatted partition in my SATA Samsung HD. I just formatted it and got the blank screen again, at least reboots no more...

After that, I used -v GraphicsEnabler=N IGPEnabler=N and slowly the install screen appeared. First the mouse arrow and then the background, very slowly.
That's good. And yes the OS X installer is very slow to come up.
 
Top