Contribute
Register

Laptop reboots consistently on wake from sleep, no kernel panic. Here's what I've tried; what did I miss?

Joined
Mar 26, 2013
Messages
149
Motherboard
Lenovo G510 (Clover)
CPU
i7-4700MQ
Graphics
HD 4600, 1366 x 768
Mobile Phone
  1. iOS
What I've tried so far:

  • Ensuring I have only essential USB 2/3 ports enabled (done using USBMap, I installed the resulting USBMap.kext and USBX SSDT). Issue doesn't seem to be caused by an external port (I removed all devices and the issue still happens, though it could be caused by an internal one.)
  • Removing AppleALC.kext — I tried this since others with my reboot-on-wake issue have been getting a panic indicating this kext, but it doesn't seem to be the root cause in my case.
  • Adding debug=0x100 keepsyms=1 in order to make sure I'm not missing any panics/more likely to catch them.
  • Making sure proximitywake, hibernatemode, powernap, networkoversleep are all off; hibernatefile replaced with a directory
  • Sleeping then waking the machine, and checking the last logs via log show --start ... -- end ... — no obvious red-flag activity there, just a sudden abrupt end to the log
  • Checking sudo pmset -g log | grep -i failure — nothing returned.
  • Deleting the PowerManagment files from /library/preferences
What should I try next/double-check? What did I miss?

System details; running Catalina 10.15.4:
 
Joined
Jan 29, 2019
Messages
9
Motherboard
Toshiba
CPU
Intel I7 5500u
Graphics
Intel HD 5500
I also tried everything you did and nothing worked. My clover is installed in an MBR partition that's not a common thing I did it cause I had graphics glitches when mac loaded. I don't know if that could be the problem
 
Joined
Mar 26, 2013
Messages
149
Motherboard
Lenovo G510 (Clover)
CPU
i7-4700MQ
Graphics
HD 4600, 1366 x 768
Mobile Phone
  1. iOS
Any one have any clue where I should be looking next? In case it helps, here's my power settings:

Code:
pmset -g

System-wide power settings:

Currently in use:

 standby              0

 womp                 0

 hibernatefile        /var/vm/sleepimage

 proximitywake        0

 powernap             0

 gpuswitch            2

 networkoversleep     0

 disksleep            10

 standbydelayhigh     86400

 sleep                0 (sleep prevented by AddressBookSourceSync, UserEventAgent, UserEventAgent)

 autopoweroffdelay    28800

 hibernatemode        0

 autopoweroff         0

 ttyskeepawake        1

 displaysleep         10

 tcpkeepalive         1

 highstandbythreshold 50

 standbydelaylow      10800

I also attached my Clover EFI and ioreg.
 

Attachments

  • MacBook Pro.ioreg
    5.2 MB · Views: 15
  • EFI.zip
    2.9 MB · Views: 8
Joined
Jan 29, 2019
Messages
9
Motherboard
Toshiba
CPU
Intel I7 5500u
Graphics
Intel HD 5500
In this webs reports the problem as very frecuent in this update. Seems an Apple problem not a hackintosh one
 
Joined
Mar 26, 2013
Messages
149
Motherboard
Lenovo G510 (Clover)
CPU
i7-4700MQ
Graphics
HD 4600, 1366 x 768
Mobile Phone
  1. iOS
In this webs reports the problem as very frecuent in this update. Seems an Apple problem not a hackintosh one

Thanks for sharing that article. I'm hoping a future macOS update fixes it.
 
Joined
Mar 7, 2013
Messages
70
Motherboard
Lenovo G710
CPU
i7-4702mq/HM86
Graphics
HD4600 /820M
Mobile Phone
  1. iOS
Just disable sleep mode for now.
Code:
# Save original values, when you need them to re-enable sleep
pmset -g

# To disable sleep
sudo pmset -a sleep 0; sudo pmset -a hibernatemode 0; sudo pmset -a disablesleep 1;

# And to go back to normal
sudo pmset -a sleep 1; sudo pmset -a hibernatemode [original hibernatemode value]; sudo pmset -a disablesleep 0;
When Apple or TonyMac Community find a fix use the third command.
 
Joined
Nov 7, 2016
Messages
14
Motherboard
Asus UX310UQK
CPU
Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
Graphics
Intel HD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello svilen,
Did you manage to repair this bugs? I have the same problem :(

I have disabled sleep as you indicate:
Bash:
sudo pmset -a sleep 0
sudo pmset -a hibernatemode 0
sudo pmset -a disablesleep 1


I have a question: When you closed the laptop lid and used an external monitor with a keyboard and mouse, the internal screen of the laptop continues to work. Do you have the same problem? (what would be expected would be that the internal screen stopped working and only the external one worked)

I have Catalina 10.15.4 Running on an Asus ZenBook

Cheers!
 
Joined
Mar 7, 2013
Messages
70
Motherboard
Lenovo G710
CPU
i7-4702mq/HM86
Graphics
HD4600 /820M
Mobile Phone
  1. iOS
After the last update 10.15.5 sleep is working again!
 
Joined
Jan 29, 2019
Messages
9
Motherboard
Toshiba
CPU
Intel I7 5500u
Graphics
Intel HD 5500
I updated yesterday but still having sleep issues
 
Top