Contribute
Register

Laptop Internal 4K Display Not Working

Joined
Oct 27, 2017
Messages
13
Motherboard
Hp spectre 2020
CPU
i7-1065G7
Graphics
Intel iris plus
Mobile Phone
  1. Android
Hi @576445533 , Have you finally find any solution for fixing the internal display ? 
I have the same laptop and i don’t find any topics about the hp spectre 2020 :/
 
Joined
Apr 16, 2020
Messages
14
Motherboard
hp spectre x360
CPU
i7-1065G7
Graphics
intel iris plus
Mac
  1. MacBook
Mobile Phone
  1. iOS
Your posts is a little old but if you care you can Remove the processor type number in your platform information and that should correct the processor shown.
Got it! Thanks!
 
Joined
Apr 16, 2020
Messages
14
Motherboard
hp spectre x360
CPU
i7-1065G7
Graphics
intel iris plus
Mac
  1. MacBook
Mobile Phone
  1. iOS
Hi @576445533 , Have you finally find any solution for fixing the internal display ? 
I have the same laptop and i don’t find any topics about the hp spectre 2020 :/
No! I'm waiting for update too.
 
Joined
Sep 27, 2016
Messages
182
Motherboard
Gigabyte Aorus z390 Elite
CPU
i7-9700K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
No! I'm waiting for update too.
Have a look at this thread.

I finally got my 4k display work using this method. It does limit my screen the 48-49hz, but the screen works at full 4k resolution. This EDID patcher was the only way I was able to upgrade to Big Sur. Ive also attached patcher. You do have to do some of the work in linux.
 

Attachments

  • patcher.py.txt
    2.5 KB · Views: 96
Joined
Apr 16, 2020
Messages
14
Motherboard
hp spectre x360
CPU
i7-1065G7
Graphics
intel iris plus
Mac
  1. MacBook
Mobile Phone
  1. iOS
Have a look at this thread.

I finally got my 4k display work using this method. It does limit my screen the 48-49hz, but the screen works at full 4k resolution. This EDID patcher was the only way I was able to upgrade to Big Sur. Ive also attached patcher. You do have to do some of the work in linux.
I have tried it. And I ran into this problem since Catalina.
After paste patched EDID in PciRoot(0x0)/Pci(0x2,0x0)>AAPL00,override-no-connect the internal screen still show nothing.
I plugin external monitor and check hackintool>patch>connectors then I check its EDID and got the old EDID that is not changed!
Oh and I think the 48Hz patch work on my external monitor, it make my animation really weird.
 
Joined
Oct 27, 2017
Messages
13
Motherboard
Hp spectre 2020
CPU
i7-1065G7
Graphics
Intel iris plus
Mobile Phone
  1. Android
Same here. I have done a lot of tests with edid patcher in config.plist or with overrides file in /System/Library/.../Overrides like suggested in this post.


But no success. I have even test in Catalina and the behavior was exactly the same as on bigsur.


I can see the display in Io registry explorer, I can override the edid but the screen is always black and not detected in settings.


If have override the edid of the internal screen with a bad edid(like the one of my external screen), all screens are disabled(that make sense and prove that the edid override works but is not the problem).


I have the impression that this is an issue related specifically on hp spectre 2020.


All the topics I have found about this issue what either bigsur problem(no ice lake proc and 4k screen, but working on Catalina) or another issue that was resolved with an edid patching(like on Dell XPS 13 9300 that have ice lake).


Anyone have any clue on this problem ?
 
Last edited:
Joined
Apr 16, 2020
Messages
14
Motherboard
hp spectre x360
CPU
i7-1065G7
Graphics
intel iris plus
Mac
  1. MacBook
Mobile Phone
  1. iOS
Same here. I have done a lot of tests with edid patcher in config.plist or with overrides file in /System/Library/.../Overrides like suggested in this post.


But no success. I have even test in Catalina and the behavior was exactly the same as on bigsur.


I can see the display in Io registry explorer, I can override the edid but the screen is always black and not detected in settings.


If have override the edid of the internal screen with a bad edid(like the one of my external screen), all screens are disabled(that make sense and prove that the edid override works but is not the problem).


I have the impression that this is an issue related specifically on hp spectre 2020.


All the topics I have found about this issue what either bigsur problem(no ice lake proc and 4k screen, but working on Catalina) or another issue that was resolved with an edid patching(like on Dell XPS 13 9300 that have ice lake).


Anyone have any clue on this problem ?
I'm trying to update to the latest opencore and whateverygreen, but still can't resolve this problem.

I google and saw:

this two EFI seems the 4K display will work.
But I still can't get the internal display to work.
I google the problem a lot and it seems the 8th gen and 10th gen processor have this problem and can't be resolve.
Or someone have tried maybe get some linux code and patch this problem?
 
Joined
Dec 20, 2018
Messages
704
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
I'm trying to update to the latest opencore and whateverygreen, but still can't resolve this problem.

I google and saw:

this two EFI seems the 4K display will work.
But I still can't get the internal display to work.
I google the problem a lot and it seems the 8th gen and 10th gen processor have this problem and can't be resolve.
Or someone have tried maybe get some linux code and patch this problem?
what does your EFI look like? particularly device properties? I have 4k 60hz working and many other users do as well in Big Sur. post your EFI
 
Joined
Apr 16, 2020
Messages
14
Motherboard
hp spectre x360
CPU
i7-1065G7
Graphics
intel iris plus
Mac
  1. MacBook
Mobile Phone
  1. iOS
what does your EFI look like? particularly device properties? I have 4k 60hz working and many other users do as well in Big Sur. post your EFI
Here you go!
 

Attachments

  • EFI.zip
    32.3 MB · Views: 51
Joined
Dec 20, 2018
Messages
704
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Here you go!
although I'm not familiar with your architecture, you need to remove the AAPL00 override entry from your config.plist Device properties. did you have the screen working with 48hz refresh rate? or not working at all? what were you're settings In Catalina ?
 
Top