Contribute
Register

knowledge-agent using High CPU

Status
Not open for further replies.
Joined
Nov 3, 2013
Messages
107
Motherboard
Dell Inspiron 7567
CPU
Intel i7 7700HQ
Graphics
Intel 630 + NVIDIA 1050TI
Hello everyone, I couldn't find any research on this. I upgraded from Mojave to Catalina Public Beta 4 and noticed from Intel Power Gadget that my CPU frequency wouldn't go below 1.50GHz and Power PKG was stuck above 3.00. I went into Activity Monitor and saw that knowledge-agent was the culprit. Once I force quit that process, my CPU dropped to 1.00GHz when idle and 0.50 Power PKG. I have the Dell Inspiron 7567 with a Intel i7-7700HQ. I've tried both Clover and OC with the MacBookPro14,1 SMBIOS, and this only happens with Catalina. This is with using updated kexts like Lilu, WhateverGreen, AppleALC and CPUFriend for Catalina.

Since I am using OC, not sure how to post debug files properly, but let me know if there is anything else you will need or solutions for this?
 

Attachments

  • Knowledge-agent.jpg
    Knowledge-agent.jpg
    204.7 KB · Views: 358
Joined
Nov 3, 2013
Messages
107
Motherboard
Dell Inspiron 7567
CPU
Intel i7 7700HQ
Graphics
Intel 630 + NVIDIA 1050TI
Hey, I've compressed my EFI folder container both my OC and Clover config files with serial number removed from my SMBIOS. Please let me know if you need anything else?
 

Attachments

  • Archive.zip
    10.6 MB · Views: 47
Joined
Nov 3, 2013
Messages
107
Motherboard
Dell Inspiron 7567
CPU
Intel i7 7700HQ
Graphics
Intel 630 + NVIDIA 1050TI
Hey wanted to let you know, the latest Catalina Public Beta appeared to fix this issue as knowledge-agent no longer is taken up high CPU and Intel Power Gadget is now showing low Power usage.
 
Status
Not open for further replies.
Top