Contribute
Register

Kind of Successful GA-Z97X-UD5H - i74790k - GTX 980

Status
Not open for further replies.
Joined
Aug 18, 2015
Messages
7
Mac
Classic Mac
Mobile Phone
Hello,

so this is my first Hackintosh ever, and i ran into so many problems that i was right about to say: "F*** it i just install Windows 10 and everything is fine."
But after one night of sleep i retried and found the right guides and answers to my problems.
So I got this following Build to work:
Gigabyte Z97X UD5H
Intel Core i7 4790k
32 GB HyperX DDR3 RAM
2x 250 GB Samsung Evo 850 SSD
1x 2TB Seagate Desktop HDD
600Watt Be Quiet PSU
and a lot of stuff for the water cooling.
CASE: Thermaltake Core P5 :thumbup:

Foto 13.11.15, 13 46 56.jpg

These are the Threads that helped me a LOT:
http://www.tonymacx86.com/user-buil...tx-980-512gb-m-2-10gbe-dual-4k-10-11-1-a.html

http://www.tonymacx86.com/el-capita...l-capitan-install-problems.html#CategoryModel

And ofc the classic Clover-El Capitan Guide on the Main Page.

USB 3.0 Works
Audio Works
Network (Atheros Killer) works
GTX 980 works
Got the Sensors running with some Kexts and HW Monitor
even iMessage seems to work out of the box

NOW here are my questions i have.
I Always kept running in the same error. Booting stopped at "Missing Bluetooth Controller Transport"
When i booted from the USB-Stick it worked, so i backuped the working EFI from my USB to my Desktop and copied it to my Clover EFI on the Hard Drive. Now i had a System that was bootable again.
From this point i went step by step, to see at what point everything Breaks. Audio Update worked, Nvidia Web Drivers worked, everything was good - until i tried to configure my SMBIOS and say, change it to MacPro 3,1.
I tried iMac with my same CPU, i tried the MacPro 3,1 everything got me running in the same failure (Bluetooth missing).
Now my config has no SMBIOS, its all empty.
Can or will this be a problem at any point?

Also id like to know, will i be able to install updates for say iTunes and RAW from the App Store without breaking my System? What can i do to turn back to my working system if something crashes?

I Have a second SSD already formated for Windows. Can i just install windows on it and than see and select it at the clover bootloader or is there something more i have to know?

Greets and Thanks in advance,
Niki

PS: I hope you like my build ;)
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
22,183
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Like the looks of your build. :thumbup: You could call it the OJ Mac custom loop CustoMac cooled with orange juice. ;) The missing bluetooth KP is never about bluetooth. Has to do with initializing your graphics.
Go into the bios and check to make sure that VT-d (in bios features) is disabled. You'll probably have
the best results with the iMac 14,2 SMBIOS for your hardware. Also once you've got it all working then
post a User Build with more pics.
 
Joined
Aug 18, 2015
Messages
7
Mac
Classic Mac
Mobile Phone
Like the looks of your build. :thumbup: You could call it the OJ Mac custom loop CustoMac cooled with orange juice. ;) The missing bluetooth KP is never about bluetooth. Has to do with initializing your graphics.
Go into the bios and check to make sure that VT-d (in bios features) is disabled. You'll probably have
the best results with the iMac 14,2 SMBIOS for your hardware. Also once you've got it all working then
post a User Build with more pics.

Thank, like the name haha :p

VT-d is enabled, i know it, because everytime i changed my XMP Profile to Profile 1 i got a BIOS error.
SO i had to load Best Defaults and it changed everything back, but thanks for the tip, i only change the Vt-d, save my current running EFI and try to update my SMBIOS. If it does not work i can still go back to my working config.

Also i think my iMessage is not working properly... but i havent tried to fix anything yet, so i will see how that turns out :)

EDIT:
Maybe i call the Build:
O.J. Simpson :p
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
22,183
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
VT-d is enabled, i know it, because everytime i changed my XMP Profile to Profile 1 i got a BIOS error.

VT-d should be DIS-abled not enabled. Your BIOS features should look somewhat like this.

151103135018.jpg
 
Joined
Aug 18, 2015
Messages
7
Mac
Classic Mac
Mobile Phone
VT-d should be DIS-abled not enabled. Your BIOS features should look somewhat like this.

View attachment 162318

You Are my Hero, that did the trick.

Like I said. I changed it, but also changed my RAM Profile and this made my BIOS Fail, i had to load Best Defaults and never changed the Vt-d back.

working now :) Thanks a lot!

NOW:
can i use TimeMachine Backup or is there something better?
AND:
I want to Dual Boot my System for some Games i would like to have Win 8 or Win 10 running on a seperate SSD.
Can i just install Windows on my 2nd SSD and Clover will find it or will there be more i have to look at?

greets and THX
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
22,183
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
can i use TimeMachine Backup or is there something better?
Yes, you can use that for daily backups but you'll want to make a Carbon Copy Cloner image after you've got all your software installed and everything working.


I want to Dual Boot my System for some Games i would like to have Win 8 or Win 10 running on a seperate SSD.

Can i just install Windows on my 2nd SSD and Clover will find it or will there be more i have to look at?

Disconnect your OS X El Cap drive when you do the Windows install. Make sure to install 8/10 UEFI.
Then after the Windows install reconnect the El Cap Drive and set it to first in the BIOS boot order.
You should then have the option to choose either El Cap or Windows at the Clover splash screen.
 
Status
Not open for further replies.
Top