Contribute
Register

<key>Graphics Mode</key> Not working?!

Joined
Feb 23, 2011
Messages
49
Motherboard
Mountain Lion
CPU
3.06
Graphics
AMD HD 5670
Mac
Classic Mac
Mobile Phone
Hi,
On boot, the apple logo is showing in low resolution "1024x768", instead of full resolution..

I tried the old "<key>Graphics Mode</key>" trick on org.chameleon.Boot.plist, but nothing changed..

So, here is my org.chameleon.Boot.plist content:

Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>GraphicsEnabler</key>
	<string>Yes</string>
	<key>Graphics Mode</key>
	<string>1360x768x32@60</string>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Kernel Flags</key>
	<string>npci=0x3000 darkwake=0</string>
	<key>Legacy Logo</key>
	<string>Yes</string>
	<key>Timeout</key>
	<string>2</string>
	<key>UseKernelCache</key>
	<string>Yes</string>
</dict>
</plist>
and here is my smbios.plist content "if needed":

Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>SMfamily</key>
	<string>Mac Pro</string>
	<key>SMproductname</key>
	<string>MacPro3,1</string>
	<key>SMboardproduct</key>
	<string>Mac-F42C88C8</string>
	<key>SMserial</key>
	<string>G88451235J4</string>
	<key>SMbiosversion</key>
	<string>MultiBeast.tonymacx86.com</string>
</dict>
</plist>
So, what do i need to change?
Any extra changes that may improve the performance would be great as well :thumbup:

thnx
 
Joined
Mar 4, 2010
Messages
4,719
Motherboard
ASUS ROG Strix Z270E-Gaming
CPU
i5-7600K
Graphics
Vega 64
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
Android, iOS
ZaYoOoD said:
Hi,
On boot, the apple logo is showing in low resolution "1024x768", instead of full resolution..

I tried the old "<key>Graphics Mode</key>" trick on org.chameleon.Boot.plist, but nothing changed..

So, here is my org.chameleon.Boot.plist content:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>1360x768x32@60</string>
Has your GFX card the ability to generate that Resolution in FB Mode (FB=Vesa FrameBuffer)? To test which Modes your GFX Card supports, on the Chimera Bootscreen just hit any key, scroll down and select Video Info. To leave the Video Info Window just hit Escape and you can boot normally. For further Information pleas have a look there -> viewtopic.php?f=76&t=9448
 
Joined
Feb 23, 2011
Messages
49
Motherboard
Mountain Lion
CPU
3.06
Graphics
AMD HD 5670
Mac
Classic Mac
Mobile Phone
Aha,
I looked it up, ans as you mentioned, it is not supported..
But i noticed that all the resolutions available are 4:3, none of them is 16:9..
Like even 1080x720 or 1920x1080 is supported..

Anyway to fix that? or is it hardware stuff?

thank you,,
 
Top