Contribute
Register

Kernel panic after patching DSDT.aml

Status
Not open for further replies.
Joined
May 4, 2017
Messages
130
Motherboard
Lenovo Flex 2 15inch
CPU
i7-4510U
Graphics
HD 4400 + GT 840M, 1920x1080
Mobile Phone
  1. iOS
It's a new fresh install 10.13.2

DSDT.dsl file properly disassembled using refs.txt. Then compiled without any error.
In order to make your checking/troubleshooting more easier, I just applied one patch, IRQ Fix, on DSDT.dsl and then saved it as .aml file.
Kernel panic occurs as soon as I place patched DSDT.aml file to path Clover/ACPI/patched.

Any quick help would be really appreciated.



Report generated via black.dragon74 tool[1]
........................
[1] : There's a visual evidence that indicates the auto generator tool hit "Save as..." in File menu of IORegistryExlporer whereas the reference of that topic (http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html) clearly recommends "Save as a copy..." instead of.
 

Attachments

  • 8383.zip
    2 MB · Views: 69
  • DSDT (IRQ).aml
    67.4 KB · Views: 156
  • DSDT (all essential patches).aml
    69.9 KB · Views: 129
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
It's a new fresh install 10.13.2

DSDT.dsl file properly disassembled using refs.txt. Then compiled without any error.
In order to make your checking/troubleshooting more easier, I just applied one patch, IRQ Fix, on DSDT.dsl and then saved it as .aml file.
Kernel panic occurs as soon as I place patched DSDT.aml file to path Clover/ACPI/patched.

Any quick help would be really appreciated.



Report generated via black.dragon74 tool[1]
........................
[1] : There's a visual evidence that indicates the auto generator tool hit "Save as..." in File menu of IORegistryExlporer whereas the reference of that topic (http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html) clearly recommends "Save as a copy..." instead of.

No photo of verbose boot provided.
No EFI/Clover with misc/preboot.log from problem scenario.

Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Status
Not open for further replies.
Top