Contribute
Register

Kaby lake HD 630 problem

Status
Not open for further replies.
Joined
Jun 3, 2017
Messages
6
Motherboard
Gygabyte GA-Z270X-UD5
CPU
Intel Core i5-7500
Graphics
Intel® HD Graphics 630
Mobile Phone
  1. Android
I'm on Kaby Lake (Intel NUC) with a Intel Iris Plus Graphics 650 (Intel i7) and running OSX 10.12.6 Beta (That has Kaby Lake support) where /S/L/E includes *KBL* drivers.

System profile shows 650 graphics but not any software that displays what driver I'm using, i.e. Open GL Extension Viewer or GeekBench

Added the new IntelGraphicsFixup.kext and have tried it with the -igfxbeta, close, but no cigar...

Anyone tried the above on 10.12.6 and with a 650, not 630?


I've dared to update to 10.12.6 and my 4k display doesn't work...
in case I remove fake IntelGFX it hangs at later stage. with display port nothing changed (i.e. monitor just turns off, with HDMI I have new message on the monitor: Input timing is not supported, choose 3840x2160, 30 HZ or very similar)

The bad thing that the old configuration loads only in non 4K mode... so I really don't know how to rollback well.
New IntelGraphicsFixup didn't help.
 
Joined
Jun 3, 2017
Messages
6
Motherboard
Gygabyte GA-Z270X-UD5
CPU
Intel Core i5-7500
Graphics
Intel® HD Graphics 630
Mobile Phone
  1. Android
Update: I was able to launch everything via Display Port (formerly I was able to use only HDMI) at 60Hz in 4K mode with the following settings:

SMBIOS: iMac18,1 (!!! It's important and this what I missed... it doesn't work for me with iMac18,2 or 3). I used updated Clover Configurator
new IntelGraphicsFixup (I don't know if it is important but I have it, just it by itself doesn't help)
ig-platform-id: 59120000
No any other UI-related patches. on ACPI table I have IntelGFX checkbox set
My config.plist is attached if it is useful for somebody.

P.S. system works observable faster in comparison to fake SkyLake CPU id and IntelGFX ids, so now I'm glad that I've updated.
 

Attachments

  • config.plist
    11.9 KB · Views: 290

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,716
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
SMBIOS: iMac18,1 (!!! It's important and this what I missed... it doesn't work for me with iMac18,2 or 3).

When looking at Wikipedia, they don't show an iMac18,1 on their iMac page. Did Apple ever release an 18,1? Is it safe to use with iCloud/iMessage/etc?

Source: iMac (Intel-based) - Wikipedia
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I've dared to update to 10.12.6 and my 4k display doesn't work...
in case I remove fake IntelGFX it hangs at later stage. with display port nothing changed (i.e. monitor just turns off, with HDMI I have new message on the monitor: Input timing is not supported, choose 3840x2160, 30 HZ or very similar)

The bad thing that the old configuration loads only in non 4K mode... so I really don't know how to rollback well.
New IntelGraphicsFixup didn't help.
Update: I was able to launch everything via Display Port (formerly I was able to use only HDMI) at 60Hz in 4K mode with the following settings:

SMBIOS: iMac18,1 (!!! It's important and this what I missed... it doesn't work for me with iMac18,2 or 3). I used updated Clover Configurator
new IntelGraphicsFixup (I don't know if it is important but I have it, just it by itself doesn't help)
ig-platform-id: 59120000
No any other UI-related patches. on ACPI table I have IntelGFX checkbox set
My config.plist is attached if it is useful for somebody.

P.S. system works observable faster in comparison to fake SkyLake CPU id and IntelGFX ids, so now I'm glad that I've updated.

New KBL specific framebuffer patches required for 4k support over HDMI (and HDMI audio).
I will update my guide later (now that 10.12.6 has native KBL).
 
Joined
Jun 28, 2011
Messages
35
Motherboard
I didn't read
CPU
the RULES
Graphics
so ignore me
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
SMBIOS: iMac18,1 (!!! It's important and this what I missed... it doesn't work for me with iMac18,2 or 3).

Yes now I'm also running 650, thanks for that !!!! I've used 18,3 (As I have an i7 Kaby Laky) but changing to 18,1 worked for me :)))

However most/some games does not work well, starting with black screen, extremely slow etc. Did work in "emulated" HD 540. Not sure if they use metal.

Running GeekBench in OpenCL I'm failing at the SFFT test
Running Metal I'm failing at both SFFT and Face Detection (That runs for 5 minutes before times out)

Heaven/Valley runs fine.

Anyone else experiencing the same? (i.e. not having a 2th graphics card)
 
Joined
Feb 3, 2011
Messages
1,364
Motherboard
Gigabyte Z390 AORUS Ultra
CPU
i9-9900K
Graphics
RX 590
i have my hd 630 working via clover r4220 and boot arg -disablegfxfirmware with platform id 0x59120000 in high sierra
 

Attachments

  • Screen Shot 2017-09-24 at 9.23.27 AM.png
    Screen Shot 2017-09-24 at 9.23.27 AM.png
    114.9 KB · Views: 371
Joined
Dec 22, 2012
Messages
7
Motherboard
OSX 10.8
CPU
i7
Graphics
512
Mac
Classic Mac
Mobile Phone
Hello,
I am running High Sierra with Pentium G4600 (Intel HD 630) on MSI B250I.
I have tried the FakeID 0x59128086 and ig-platform id 0X59120000 but I was getting the gIOScreenLockState 3.
I have tried everything listed above as well.

I changed to a FakeID of 0x19168086 and ig-platform of 0x19160000 and is booting using this kext:
FakePCIID_Intel_HD_Graphics.kext, IntelGraphicsFixup.kext, Lilu.kext, NullCPUPowerManagement.kext, NvidiaGraphicsFixup.kext, Shiki.kext

and a FakeCPUID 0x0306A0 for the Pentium processor.
OpenGL seams working but my dock bar is not transparent yet.

Any help?

Thanks,
Andrea
 

Attachments

  • Screen Shot 2017-10-09 at 12.26.43.png
    Screen Shot 2017-10-09 at 12.26.43.png
    36.9 KB · Views: 230
  • Screen Shot 2017-10-09 at 14.13.00.png
    Screen Shot 2017-10-09 at 14.13.00.png
    55.3 KB · Views: 209
  • config.plist
    10.3 KB · Views: 214

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,449
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@andreamike, please update your profile (personal details) with your Motherboard or Make/Model, CPU and Graphics Card.
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.
 
Status
Not open for further replies.
Top