Contribute
Register

iTunes Protected Video Black Screen Solution (HDCP)

Status
Not open for further replies.
Joined
Jul 12, 2016
Messages
5
Motherboard
Gigabyte GA-Z170X-UD5-TH
CPU
Intel Core i7 6700K
Graphics
Gigabyte GeForce GTI 750ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
They should not be deleted by clover, they will be copied to another folder like S/L/E (system/library/extensions). At least I hope it's there but your system will not work properly when not.
Shiki.kext FAQ says it's possible that it wont work there, so everything should be fine with your installation because you use EFI/Clover/Kexts.

The last things i could imagine as the problem are the terminal commands you have to use, your version of shiki.kext and at least some cosmic interference.
I'm not a professional in customac, maybe someone other could help you better.

When you tell me how, I could call you or something like that, but we have to post our work later.



Sorry, i´ve been very busy last time,
solving my problem , i have to inject the kext for enabling Maxwell Graphics and Shiki via Clover by copying in Kext/10.11, now iTunes fully works and my Setup is complete,

Many Thanks for your Help
 
Joined
Jan 11, 2014
Messages
33
Mac
Classic Mac
Mobile Phone
  1. iOS
I just spent a day and half on this issue trying everything I could to get it working and I come to find out it has probably been working the whole time...

I have always been able to play HD trailers. Just thought that I couldn't play my purchased movies...

Well I can't play my purchased movies unless they are downloaded to my system. I was always trying to play them from the cloud "AirPlay" while they downloaded... Like you can from a regular Mac or Apple TV. This would never work.

So for testing purposes I just downloaded one of my purchased movies and once it was downloaded to my system it played perfectly.

Conclusion - Sierra 10.12 and iTunes 12.5.1 Work
So in my situation iTunes Trailers and Downloaded movies play. Purchased movies in the cloud will not play from the cloud only when they are downloaded...

Do this seem correct? Maybe should add to the OP?

Can confirm!! I was so annoyed not being able to play movies in iTunes anymore in 10.12 and iTunes 12.5.1, but I just fully downloaded a movie instead of streaming and now it works. Would be nice to just stream it, but I'm ok with downloading for now :) Thanks for shedding some light on this.
 
Joined
Jul 21, 2011
Messages
15
Motherboard
Z490 Vision D
CPU
Intel i9 10850k
Graphics
AMD 5700XT Saphire
Mac
  1. iMac
I can confirm that this worked for me yesterday. However with an update to Clover bootloader I can say this now no longer works. Clover is now updated to v3835 and this seems to have killed shiki.kext (I have tried a few version of this and none work) I can see previews for movies but no longer can I watch downloaded content.
I would double check clover config/settings and reset the DRM per OP instructions. I am on Clover 3835 and can play downloaded content just not streamed/cloud based content.

Looks like "Streaming/Cloud based Play" is an outstanding issue based on the github issue opened with the developer. vit9696 (Shiki developer) response seems to point to an issue with "FairPlay 2". See link https://github.com/vit9696/Shiki/issues/2?_pjax=#js-repo-pjax-container.
 
Joined
Aug 9, 2014
Messages
13
Motherboard
Gigabyte Vision D B550 (rev. 1)
CPU
Ryzen 9 5900X
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Kexts must be installed correctly not just copied into folders.
Place the kext that you wish to install on the desktop.
Download and run KextBeast and choose /Library/Extensions as the location to install to.
Yeah :D Sry, I got it now with KextBeast thanks

EDIT: Okay, I installed the kext right and I ran the commands in Terminal but it does not work anyone who can help? Should I drop it into CLOVER/kext/Others too? I´m on 10.12.1 with Shiki 1.9.0
 
Last edited:
Joined
May 26, 2010
Messages
684
Motherboard
Gigabyte GA-Z170X-UD3
CPU
i7-6700K OC @ 4.5GHz
Graphics
GTX 760
Mac
  1. MacBook
Mobile Phone
  1. iOS
I used this guide on my new build
  • GA-Z170X-UD3
  • i7-6700K
  • AMD Radeon 6870
using Shiki 1.9.0, putting it into CLOVER/kext/Others

After running the commands from post one relevant for my system, playback of iTunes Store purchased TV series etc. finally works.
 
Joined
Mar 9, 2012
Messages
2,605
Motherboard
Gigabyte Z590 AORUS MASTER
CPU
i7-11700k
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Yeah :D Sry, I got it now with KextBeast thanks

EDIT: Okay, I installed the kext right and I ran the commands in Terminal but it does not work anyone who can help? Should I drop it into CLOVER/kext/Others too? I´m on 10.12.1 with Shiki 1.9.0

Ok here is something you can try along with the terminal commands from post #1 that you ran already, no need to run them again - S/L/E and remove this kext AppleIntelHD3000GraphicsVADriver.bundle - make sure you delete the right one as described, leave it in the Recycle Bin for the moment just incase it doesn't work and you need to put it back. Reboot and try playing movies or trailers in iTunes, This tip worked for me after trying everything else. Good luck.
 
Joined
Aug 9, 2014
Messages
13
Motherboard
Gigabyte Vision D B550 (rev. 1)
CPU
Ryzen 9 5900X
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Didn´t worked for me but thanks for the try :)
 
Joined
Mar 9, 2012
Messages
2,605
Motherboard
Gigabyte Z590 AORUS MASTER
CPU
i7-11700k
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Didn´t worked for me but thanks for the try :)

It didn't work for me either when I used the recommended Terminal Input line for my ATI card (defaults write com.apple.AppleGVA forceATI -boolean yes) in sheer frustration I input this line instead - For Intel (defaults write com.apple.AppleGVA forceIntel -boolean yes) coupled with the removal of the fore mentioned kext, I finally got it to work perfectly. You need to experiment a bit (backup your setup incase things go south) I'm sure you'll find the solution.
One thing to note you have to go through the process of removing that kext again after any major Apple update/upgrade as it's always replaced in the process. A very small price to pay if you have an extensive movie library - Good luck.
 
Joined
Mar 22, 2012
Messages
267
Motherboard
GA-X99-Gaming 5P
CPU
i7-5820K OC @ 4.25 GHz
Graphics
Nvidia Titan Xp
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Confirmed - latest iTunes and 10.12.1 with Shiki.kext can only play downloaded videos and will not stream. I'm sure devs will figure this out eventually.
 
Joined
Apr 2, 2016
Messages
8
Motherboard
Gigabyte GA-Z97N-WIFI
CPU
i7-4790K
Graphics
RX 580
I'm still getting no joy. I'm running a GTX 950 / 10.12.1 / latest Shiki, latest iTunes. iMac 14,2 profile. The boot log confirms that Shiki is loading. No kexts other than Shiki and FakeSMC.

Looking around at the FAQ, I can also tell you that VDADecoderCreate fails and that no IMEI/IGPU device appears in ioreg, so I've clearly messed up or missed something in my setup. Suggestions?
 
Status
Not open for further replies.
Top