Contribute
Register

iTunes HD content not working on my ivy Hackintosh

Status
Not open for further replies.

jwk

Joined
Oct 8, 2011
Messages
236
Motherboard
Z68X-UD5-B3
CPU
i7-2700K
Graphics
PNY Quadro 4000
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
This could make some sense if the 'copy protection' issue is the PAP (Protected Audio Path) part of HDCP which prevents bit-streamed audio (bit-for-bit the same as the original material) to be sent to a non-HDCP display device; selecting 'Dolby Pro Logic' would mean audio is no longer bit-for-bit accurate and HDCP PAP would no longer would no longer be enforced. Maybe a bug in Apples implementation, but could be working correctly and not enough detail about individual complaintant's connection to external devices for an accurate assessment of whether HDCP is working properly or not.

jwk
 
Joined
May 16, 2010
Messages
276
Motherboard
Gigabyte Z370-HD3
CPU
i5-8600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Has anyone tried using Perian (1.2.3 in my case) to set their audio output to "Dolby Pro Logic". I had these issues on my 3,1 system. Then I realized that I had my Audio set to "Multi-channel output". Once I changed it to "Dolby Pro Logic" I was able to watch the HD 1080 movies without the HDCP error on both of my external monitors.

Had a look at this and mine was already set to Dolby Pro Logic. I tried changing it back and forth and it made no difference for me. I guess it is possible that there are some other audio or video settings that might play a role too. Still can't play any iTunes Store video content.
 
Joined
Oct 14, 2012
Messages
42
Motherboard
Z77 DS3H
CPU
i5 3570K @ 4.2GHz
Graphics
Sapphire HD 6870 with REDMOD
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Im having this issue with content that I have not downloaded from the iTunes store. Is there a fix for that?
 
Status
Not open for further replies.
Top