Contribute
Register

iTunes HD content not working on my ivy Hackintosh

Status
Not open for further replies.
Joined
Mar 24, 2011
Messages
1,045
Motherboard
ASUS Z10PE-D8 WS
CPU
2x E5-2683 v3
Graphics
W9100
Don't expect a fix anytime soon as this issue is going on 2+ years now with no real solutions to be found. Before iTunes 11.0.2 at least there was the 32bit app mode solution but hasn't worked since.
 
Joined
Jul 29, 2012
Messages
154
Motherboard
GA-Z77X-UD5H
CPU
i7 3770K 3.5 GHz
Graphics
NVIDIA GTX 760 4GB
Mac
Classic Mac
Mobile Phone
  1. iOS
It is possible my internet is too slow :p

Netflix/Hulu/Amazon use Silverlight so it may or may not be working
iTunes uses Quicktime and it definitely is not working.
Vudu to Go uses Adobe Air and it doesn't work either.

If I enable my HD4000 in addition to the GTX 760 I can get the video to start, but the picture is pink/green garbage.
 
Joined
Jul 22, 2011
Messages
24
Motherboard
Mac Pro 5,1
CPU
Core i7 920
Graphics
nVidia GTX 570
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
Mobile Phone
  1. iOS
It is possible my internet is too slow :p

Netflix/Hulu/Amazon use Silverlight so it may or may not be working
iTunes uses Quicktime and it definitely is not working.
Vudu to Go uses Adobe Air and it doesn't work either.

If I enable my HD4000 in addition to the GTX 760 I can get the video to start, but the picture is pink/green garbage.

I can't speak to what DRM is used in Vudu, but Netflix/silverlight work just fine with no issues. This particular problem is specific to iTunes when playing back protected content.
 
Joined
Jul 22, 2011
Messages
24
Motherboard
Mac Pro 5,1
CPU
Core i7 920
Graphics
nVidia GTX 570
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
Mobile Phone
  1. iOS
Joined
Nov 22, 2011
Messages
4
Motherboard
Dell Latitude e5520
CPU
i5 2,4 Ghz 2430m
Graphics
HD3000
Mac
Classic Mac
Mobile Phone
  1. iOS
Hi

I just bought a used Dell Latitude 5520 with sandy bridge. (2430m i5) and I have only garbage on HD playback and sometimes the message that I can not use this display to play back HD Itunes movies.

Please advise
lemans
 
Joined
Jun 30, 2011
Messages
1
Motherboard
Mac Pro 3,1
CPU
2.67 Ghz Xeon
Graphics
GeForce 9800 GT 1024MB
Mac
Classic Mac
Mobile Phone
Has anyone tried using Perian (1.2.3 in my case) to set their audio output to "Dolby Pro Logic". I had these issues on my 3,1 system. Then I realized that I had my Audio set to "Multi-channel output". Once I changed it to "Dolby Pro Logic" I was able to watch the HD 1080 movies without the HDCP error on both of my external monitors.

Just a thought to try.

- Philip
 
Status
Not open for further replies.
Top