Contribute
Register

iTunes Crashing: Mojave (macOS 10.14.5), iTunes v12.9.5

Joined
Jun 28, 2012
Messages
383
Motherboard
EVGA X99 Classified
CPU
i7-5960X
Graphics
RX 590
Mac
MacBook Pro
Mobile Phone
iOS
So according to the crash report, it's pretty clear that AppleGVA is the culprit if I scroll down to the actual crash:
Code:
Thread 16 Crashed:: Dispatch queue: com.apple.FigASMF.InstanceManagement
0   com.apple.AppleGVAFramework       0x00007fff62ac2be3 0x7fff62a9f000 + 146403
1   com.apple.AppleGVAFramework       0x00007fff62abb318 0x7fff62a9f000 + 115480
2   com.apple.AppleGVAFramework       0x00007fff62af0a18 0x7fff62a9f000 + 334360
3   com.apple.AppleGVAFramework       0x00007fff62abad88 0x7fff62a9f000 + 114056
4   com.apple.MediaToolbox            0x00007fff572b1aaf 0x7fff56e0d000 + 4868783
5   libdispatch.dylib                 0x00007fff7e82763d _dispatch_client_callout + 8
6   libdispatch.dylib                 0x00007fff7e833129 _dispatch_lane_barrier_sync_invoke_and_complete + 60
7   com.apple.MediaToolbox            0x00007fff572b0dc3 0x7fff56e0d000 + 4865475
8   com.apple.MediaToolbox            0x00007fff572b0d17 0x7fff56e0d000 + 4865303
9   com.apple.MediaToolbox            0x00007fff571ee100 0x7fff56e0d000 + 4067584
10  libdispatch.dylib                 0x00007fff7e82763d _dispatch_client_callout + 8
11  libdispatch.dylib                 0x00007fff7e82d8e0 _dispatch_lane_serial_drain + 602
12  libdispatch.dylib                 0x00007fff7e82e396 _dispatch_lane_invoke + 385
13  libdispatch.dylib                 0x00007fff7e8366ed _dispatch_workloop_worker_thread + 598
14  libsystem_pthread.dylib           0x00007fff7ea67611 _pthread_wqthread + 421
15  libsystem_pthread.dylib           0x00007fff7ea673fd start_wqthread + 13
Explanation of the shiki boot flags bitmask can be found here: https://github.com/acidanthera/WhateverGreen/blob/master/WhateverGreen/kern_shiki.hpp

shikigva=32 is the ReplaceBoardID flag, and needs to be followed by the shiki-id flag to specify the board id for AppleGVA. According to that link, AddExecutableWhitelist is required for iGPUs, which has a value of 8, so 8+32 would make the bitmask 40. So if you have an iGPU use shikigva=40 instead. I don't personally have an iGPU so I can't confirm whether or not that works.
 
Last edited:
Joined
Mar 13, 2016
Messages
36
Motherboard
Asus Prime X299-Deluxe II
CPU
i9-9980XE
Graphics
RX 590
Great! I will try when the code I'm running finishes in ... hopefully a day or so (it's a home-work computer so gotta let some stuff play out first).
 
Joined
Mar 13, 2016
Messages
36
Motherboard
Asus Prime X299-Deluxe II
CPU
i9-9980XE
Graphics
RX 590
Yay! The fix worked for me, thanks! Now I'm more comfortable about wiping Hackintosh-1 computer (whose motherboard has been dying for the last year).
 
Joined
Jun 26, 2018
Messages
231
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i7-8700K
Graphics
RX 5700 XT
Mac
Mac Pro
Mobile Phone
iOS
So according to the crash report, it's pretty clear that AppleGVA is the culprit if I scroll down to the actual crash:
Code:
Thread 16 Crashed:: Dispatch queue: com.apple.FigASMF.InstanceManagement
0   com.apple.AppleGVAFramework       0x00007fff62ac2be3 0x7fff62a9f000 + 146403
1   com.apple.AppleGVAFramework       0x00007fff62abb318 0x7fff62a9f000 + 115480
2   com.apple.AppleGVAFramework       0x00007fff62af0a18 0x7fff62a9f000 + 334360
3   com.apple.AppleGVAFramework       0x00007fff62abad88 0x7fff62a9f000 + 114056
4   com.apple.MediaToolbox            0x00007fff572b1aaf 0x7fff56e0d000 + 4868783
5   libdispatch.dylib                 0x00007fff7e82763d _dispatch_client_callout + 8
6   libdispatch.dylib                 0x00007fff7e833129 _dispatch_lane_barrier_sync_invoke_and_complete + 60
7   com.apple.MediaToolbox            0x00007fff572b0dc3 0x7fff56e0d000 + 4865475
8   com.apple.MediaToolbox            0x00007fff572b0d17 0x7fff56e0d000 + 4865303
9   com.apple.MediaToolbox            0x00007fff571ee100 0x7fff56e0d000 + 4067584
10  libdispatch.dylib                 0x00007fff7e82763d _dispatch_client_callout + 8
11  libdispatch.dylib                 0x00007fff7e82d8e0 _dispatch_lane_serial_drain + 602
12  libdispatch.dylib                 0x00007fff7e82e396 _dispatch_lane_invoke + 385
13  libdispatch.dylib                 0x00007fff7e8366ed _dispatch_workloop_worker_thread + 598
14  libsystem_pthread.dylib           0x00007fff7ea67611 _pthread_wqthread + 421
15  libsystem_pthread.dylib           0x00007fff7ea673fd start_wqthread + 13
Explanation of the shiki boot flags bitmask can be found here: https://github.com/acidanthera/WhateverGreen/blob/master/WhateverGreen/kern_shiki.hpp

shikigva=32 is the ReplaceBoardID flag, and needs to be followed by the shiki-id flag to specify the board id for AppleGVA. According to that link, AddExecutableWhitelist is required for iGPUs, which has a value of 8, so 8+32 would make the bitmask 40. So if you have an iGPU use shikigva=40 instead. I don't personally have an iGPU so I can't confirm whether or not that works.
@Manic Harmon1c, I just can't figure out how to apply/do this? Any chance you can give us a little write up meant for 1st graders. thanks.
 
Joined
Mar 13, 2016
Messages
36
Motherboard
Asus Prime X299-Deluxe II
CPU
i9-9980XE
Graphics
RX 590
@Manic Harmon1c, I just can't figure out how to apply/do this? Any chance you can give us a little write up meant for 1st graders. thanks.
1) Make sure you have WhateverGreen.kext, or put it in your KEXT folder on your EFI volume.
2) Using Clover Configurator, if you have a discrete GPU (AMD/NVIDIA), add this bootflag: shikigva=32. If you have an integrated GPU you're using, the flag is shikigva=40.
3) Also add this bootflag to make it think you're using a different motherboard than the Mac Pro that is the apparent issue: shiki-id=Mac-7BA5B2D9E42DDD94
4) Restart.

Try that. As a side-note, make sure you have the latest USB patches, they changed for 10.14.5 from 10.14.4.
 
Joined
Jun 26, 2018
Messages
231
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i7-8700K
Graphics
RX 5700 XT
Mac
Mac Pro
Mobile Phone
iOS
1) Make sure you have WhateverGreen.kext, or put it in your KEXT folder on your EFI volume.
2) Using Clover Configurator, if you have a discrete GPU (AMD/NVIDIA), add this bootflag: shikigva=32. If you have an integrated GPU you're using, the flag is shikigva=40.
3) Also add this bootflag to make it think you're using a different motherboard than the Mac Pro that is the apparent issue: shiki-id=Mac-7BA5B2D9E42DDD94
4) Restart.

Try that. As a side-note, make sure you have the latest USB patches, they changed for 10.14.5 from 10.14.4.
@astroguy..... thanks! works perfectly.
 
Joined
Nov 3, 2011
Messages
63
Motherboard
Gigabyte X79-UP4
CPU
i7-4930K
Graphics
2x RX 580
Mac
Mac Pro
Classic Mac
Color Classic
Mobile Phone
iOS
Worked for me... but FCPX kept crashing so had to change it back
 
Joined
Mar 13, 2016
Messages
36
Motherboard
Asus Prime X299-Deluxe II
CPU
i9-9980XE
Graphics
RX 590
Worked for me... but FCPX kept crashing so had to change it back
What were you doing in FCPX? I just opened it and it opens fine, but I haven't tried to do anything in it.
 
Joined
Mar 29, 2011
Messages
74
Motherboard
GA-Z170X-UD5-TH, Clover
CPU
i7-4770K
Graphics
GTX 760, HD 4600
Mac
iMac, MacBook, MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
same issue here with 10.14.5
6.1 MacPro Late 2013 definiton

astroguys solution didn´t worked for me, still crashing

tried also whatevergreen in L/E (lilu.kext is there). Boot flags set, no success :(

Code:
Process:               iTunes [690]
Path:                  /Applications/iTunes.app/Contents/MacOS/iTunes
Identifier:            com.apple.iTunes
Version:               12.9.5 (12.9.5)
Build Info:            iTunes-1200012009005005~7
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           iTunes [690]
User ID:               503

Date/Time:             2019-05-23 15:52:25.666 +0200
OS Version:            Mac OS X 10.14.5 (18F132)
Report Version:        12
Anonymous UUID:        175939DC-45CF-6B91-3920-AE2B016A9088
 
Last edited:
Top