iTunes 12.7 constantly crashing (random messages)

Discussion in 'High Sierra Desktop Support' started by familygw, Sep 28, 2017.

  1. MatchesMalonee

    MatchesMalonee

    Joined:
    May 9, 2017
    Messages:
    48
    Mobo:
    Sony Vaio SVF15325SNW motherboard
    CPU:
    Intel i3-4005U Haswell
    Graphics:
    Intel HD Graphics 4400
    Mobile Phone:
    Android
    Oct 8, 2017 at 12:06 PM #111
    MatchesMalonee

    MatchesMalonee

    Joined:
    May 9, 2017
    Messages:
    48
    Mobo:
    Sony Vaio SVF15325SNW motherboard
    CPU:
    Intel i3-4005U Haswell
    Graphics:
    Intel HD Graphics 4400
    Mobile Phone:
    Android
    @geekomancer Upgrading from Sierra to High Sierra? And did the iTunes problem start after upgrading to High Sierra?
     
  2. familygw

    familygw

    Joined:
    May 27, 2013
    Messages:
    73
    Mobo:
    GA-Z97X-GAMING 3
    CPU:
    Core i7 4790K @ 4Ghz
    Graphics:
    GeForce GTX 750Ti (2048Mb)
    Mac:
    MacBook
    Mobile Phone:
    Android, iOS, Windows Phone
    Oct 8, 2017 at 6:07 PM #112
    familygw

    familygw

    Joined:
    May 27, 2013
    Messages:
    73
    Mobo:
    GA-Z97X-GAMING 3
    CPU:
    Core i7 4790K @ 4Ghz
    Graphics:
    GeForce GTX 750Ti (2048Mb)
    Mac:
    MacBook
    Mobile Phone:
    Android, iOS, Windows Phone
    Hi, are you using the iMac.kext or something that enables the Intel Quick Sync feature?
    Have you executed VDADecoderChecker? Which results do you see?
     
  3. geekomancer

    geekomancer

    Joined:
    Jul 23, 2012
    Messages:
    79
    Mobo:
    Gigabyte GA-Z77X-UP5-TH
    CPU:
    Intel Core i7-3770K
    Graphics:
    NVidia GeForce GTX 750 Ti (EVGA)
    Mac:
    iMac
    Oct 8, 2017 at 9:03 PM #113
    geekomancer

    geekomancer

    Joined:
    Jul 23, 2012
    Messages:
    79
    Mobo:
    Gigabyte GA-Z77X-UP5-TH
    CPU:
    Intel Core i7-3770K
    Graphics:
    NVidia GeForce GTX 750 Ti (EVGA)
    Mac:
    iMac
    I'm on Sierra 10.12.6. I think the problem started after updating iTunes to 12.7.

    I am not using any special kexts, just the basics that are included MultiBeast. I am using the Nvidia drivers, so I turned off Inject Intel in Clover Configurator, which had no effect.

    I ran VDADecoderCheck, and it gave me error -12473:
     
  4. medianjoe

    medianjoe

    Joined:
    Nov 28, 2012
    Messages:
    22
    Mobo:
    ASUS P8Z77-V LK, OS X 10.10.0
    CPU:
    Intel i5 Quad 3570K
    Graphics:
    Intel HD 4000
    Oct 8, 2017 at 11:06 PM #114
    medianjoe

    medianjoe

    Joined:
    Nov 28, 2012
    Messages:
    22
    Mobo:
    ASUS P8Z77-V LK, OS X 10.10.0
    CPU:
    Intel i5 Quad 3570K
    Graphics:
    Intel HD 4000
    I had the same issue and AppleALC.kext was the cockpit on macOS 10.13.0 (17A405) & iTunes 12.7.0.66.

    The kexts in /EFI/CLOVER/kexts/10.13/ are
    Crash) FakeSMC.kext, Lilu.kext, IntelGraphicsFixup.kext, AppleALC.kext, RealtekRTL8111.kext, USBInjectAll.kext
    Few Crash) FakeSMC.kext, Lilu.kext, IntelGraphicsFixup.kext, RealtekRTL8111.kext, USBInjectAll.kext

    I'm ok since I'm using USB headset and doesn't really need the AppleALC.kext.

    Edit) No, it became much stable but it still crashes sometimes.
     
    Last edited: Oct 8, 2017
  5. tamgya

    tamgya

    Joined:
    Nov 14, 2015
    Messages:
    53
    Mobo:
    Intel C220 Series
    CPU:
    Xeon E3 1246v3
    Graphics:
    Intel HD P4600 + Nvidia GeForce GT 1030 2GB
    Mac:
    iMac
    Oct 8, 2017 at 11:24 PM #115
    tamgya

    tamgya

    Joined:
    Nov 14, 2015
    Messages:
    53
    Mobo:
    Intel C220 Series
    CPU:
    Xeon E3 1246v3
    Graphics:
    Intel HD P4600 + Nvidia GeForce GT 1030 2GB
    Mac:
    iMac
    You need Lilu+NvidiaGraphicsFixup to enable offline video decoding (with Intel HD Graphics).
     
    familygw likes this.
  6. tamgya

    tamgya

    Joined:
    Nov 14, 2015
    Messages:
    53
    Mobo:
    Intel C220 Series
    CPU:
    Xeon E3 1246v3
    Graphics:
    Intel HD P4600 + Nvidia GeForce GT 1030 2GB
    Mac:
    iMac
    Oct 8, 2017 at 11:25 PM #116
    tamgya

    tamgya

    Joined:
    Nov 14, 2015
    Messages:
    53
    Mobo:
    Intel C220 Series
    CPU:
    Xeon E3 1246v3
    Graphics:
    Intel HD P4600 + Nvidia GeForce GT 1030 2GB
    Mac:
    iMac
    For me, VoodooHDA seems to be the problem. I switched to AppleALC and now iTunes hasn't crashed yet.
     
  7. geekomancer

    geekomancer

    Joined:
    Jul 23, 2012
    Messages:
    79
    Mobo:
    Gigabyte GA-Z77X-UP5-TH
    CPU:
    Intel Core i7-3770K
    Graphics:
    NVidia GeForce GTX 750 Ti (EVGA)
    Mac:
    iMac
    Oct 9, 2017 at 12:07 AM #117
    geekomancer

    geekomancer

    Joined:
    Jul 23, 2012
    Messages:
    79
    Mobo:
    Gigabyte GA-Z77X-UP5-TH
    CPU:
    Intel Core i7-3770K
    Graphics:
    NVidia GeForce GTX 750 Ti (EVGA)
    Mac:
    iMac
    Update: After clearing my kernel caches, I tried re-installing iTunes 12.7 (previously, it failed to install) — and this time it worked! Seems to be running as expected.

    FYI, I was also having issues with MultiBeast. Has anyone else experienced issues with MultiBeast failing to install, while also getting the iTunes crashes?

    Here's what I did:
    • Deleted all the FakeSMC stuff, and used KextBeast to install the latest FakeSMC from here: https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek/downloads/
    • Re-installed everything with Multi-Beast, and copied the new FakeSMC into my /EFI/Clover/Kexts/Other/
    • Installed NvidiaGraphicsFixup + Lilu (thanks Tamgya).
    • Rebuilt my kernel cache:
      Code (Text):
      sudo touch /System/Library/Extensions && sudo kextcache -u /
    • Re-installed iTunes.
    In a couple days I'm going to test removing the NvidiaGraphicsFixup & Lilu, to see if it runs without them. (Seems like I should be able to do without....)

    I hope this helps someone!
     
    Last edited: Oct 9, 2017
  8. karacho

    karacho

    Joined:
    Mar 4, 2010
    Messages:
    4,729
    Mobo:
    GA-Z97M-D3H
    CPU:
    Core i5-4690K
    Graphics:
    AMD Radeon RX 560 Pulse 4GB
    Mac:
    MacBook Pro
    Classic Mac:
    Power Mac
    Mobile Phone:
    Android, iOS
    Oct 9, 2017 at 1:01 PM #118
    karacho

    karacho

    Joined:
    Mar 4, 2010
    Messages:
    4,729
    Mobo:
    GA-Z97M-D3H
    CPU:
    Core i5-4690K
    Graphics:
    AMD Radeon RX 560 Pulse 4GB
    Mac:
    MacBook Pro
    Classic Mac:
    Power Mac
    Mobile Phone:
    Android, iOS
    Perhaps this helps https://support.apple.com/en-us/HT203538
     
  9. digitalm3

    digitalm3

    Joined:
    Jul 15, 2012
    Messages:
    40
    Mobo:
    Gigabyte GA-Z77N-WIFI
    CPU:
    Intel i7-3770k
    Graphics:
    HD4000
    Mac:
    MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Oct 9, 2017 at 2:16 PM #119
    digitalm3

    digitalm3

    Joined:
    Jul 15, 2012
    Messages:
    40
    Mobo:
    Gigabyte GA-Z77N-WIFI
    CPU:
    Intel i7-3770k
    Graphics:
    HD4000
    Mac:
    MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    just an FYI, the 12.6.3 update Apple just released is still crashing for me.
     
  10. MatchesMalonee

    MatchesMalonee

    Joined:
    May 9, 2017
    Messages:
    48
    Mobo:
    Sony Vaio SVF15325SNW motherboard
    CPU:
    Intel i3-4005U Haswell
    Graphics:
    Intel HD Graphics 4400
    Mobile Phone:
    Android
    Oct 9, 2017 at 6:18 PM #120
    MatchesMalonee

    MatchesMalonee

    Joined:
    May 9, 2017
    Messages:
    48
    Mobo:
    Sony Vaio SVF15325SNW motherboard
    CPU:
    Intel i3-4005U Haswell
    Graphics:
    Intel HD Graphics 4400
    Mobile Phone:
    Android
    I think there's something wrong with how iTunes tries to connect to iTunes Store. The same javascript.dll that someone posted a few days ago. Hopefully this gets fixed. Gonna downgrade to Sierra 10.12.6 for now. I give up. Avenge me, brothers.
     
    Last edited: Oct 9, 2017

Share This Page