Contribute
Register

Issue with 5G after wifi toggle/sleep

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,808
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
@RehabMan,

Hi RM,

As you requested here ...

https://www.tonymacx86.com/threads/guide-airport-pcie-half-mini-v2.104850/page-205#post-1336912

i'm posting this issue as a new thread ...

Sony Vaio Laptop, I7 Sandy bridge, 8 Gig Ram, HD3000 (see sig)

I got an odd issue with my AW123Ch ... bluetooth works fine, 5GH wifi works fine connecting to my AC router at 867Bps ...

Software Versions:
CoreWLAN: 11.0 (1101.20)
CoreWLANKit: 11.0 (1101.20)
Menu Extra: 11.0 (1121.34.2)
System Information: 12.0 (1100.2)
IO80211 Family: 11.1 (1110.26)
Diagnostics: 5.1 (510.88)
AirPort Utility: 6.3.6 (636.5)
Interfaces:
en1:
Card Type: AirPort Extreme (0x14E4, 0x2123)
Firmware Version: Broadcom BCM43xx 1.0 (7.21.95.175.1a6)
MAC Address: 6c:71:d9:46:b5:5c
Locale: FCC
Country Code: US
Supported PHY Modes: 802.11 a/b/g/n/ac
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 144, 149, 153, 157, 161, 165
Wake On Wireless: Supported
AirDrop: Supported, Channel 149
Status: Connected
Current Network Information:
CMMP-5G:
PHY Mode: 802.11ac
BSSID: e0:3f:49:f1:6a:dc
Channel: 52
Country Code: US
Network Type: Infrastructure
Security: WPA2 Personal
Signal / Noise: -53 dBm / -89 dBm
Transmit Rate: 867 <-----------------------
MCS Index: 9

But after a disconnect and reconnect it will only connect at 300bps.

Software Versions:

CoreWLAN: 11.0 (1101.20)
CoreWLANKit: 11.0 (1101.20)
Menu Extra: 11.0 (1121.34.2)
System Information: 12.0 (1100.2)
IO80211 Family: 11.1 (1110.26)
Diagnostics: 5.1 (510.88)
AirPort Utility: 6.3.6 (636.5)
Interfaces:
en1:
Card Type: AirPort Extreme (0x14E4, 0x2123)
Firmware Version: Broadcom BCM43xx 1.0 (7.21.95.175.1a6)
MAC Address: 6c:71:d9:46:b5:5c
Locale: FCC
Country Code: US
Supported PHY Modes: 802.11 a/b/g/n/ac
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165
Wake On Wireless: Supported
AirDrop: Supported, Channel 149
Status: Connected
Current Network Information:
CMMP-5G:
PHY Mode: 802.11ac
BSSID: e0:3f:49:f1:6a:dc
Channel: 52,1
Country Code: US
Network Type: Infrastructure
Security: WPA2 Personal
Signal / Noise: -54 dBm / -93 dBm
Transmit Rate: 300 <--------------------------- ?????????
MCS Index: 7

Above was triggered via turning wifi off and back on but any form of sleep/wake will also produce the same result. It does it with out fail every time, the only way to get system to reconnect at 867bps is to reboot or live with 300 bps.

Wake for network access unchecked in energy saver ..

I using your latest fork of BrcmPatchRAM (BrcmPatchRAM2.kext & BrcmFirmwareRepo.kext both in /S/L/E) and your fakepci kexts ( FakePCIID.kext & FakePCIID_Broadcom_WiFi.kext also in /S/L/E ) all other patches applied by clover, all works (wifi & BT) except for this issue of 5G WiFi reconnecting at 300bps after first disconnect. I think the issue may be the firmware that my AW123CH is using. 2.4Ghz wifi is unaffected and always connects at 145bps.

As you can see from above Sys info dumps firmware is Broadcom BCM43xx 1.0 (7.21.95.175.1a6) which i think is quite old, i believe that most hacks are now using version Broadcom BCM43xx 1.0 (7.21.149.34.1a7) or later ....

I think something odd is going on with BrcmPatchRAM during boot/kext load ...

cat /var/log/system.log | grep -i brcm[fp] produces following from log file ....

Sep 29 16:22:32 localhost kernel[0]: BrcmPatchRAM2: Version 2.2.7 starting on OS X Darwin 15.6.
Sep 29 16:22:32 localhost kernel[0]: BrcmPatchRAM2: Published new IOKit personality for BrcmFirmwareStore.
Sep 29 16:22:32 localhost kernel[0]: BrcmPatchRAM2: Published new IOKit personality for BrcmPatchRAMResidency.
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM: Loaded firmware "BCM20702A1_001.002.014.1443.1479_v5575.zhx" from resources.
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM: Decompressed firmware (29713 bytes --> 70105 bytes).
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM: Firmware is valid IntelHex firmware.
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM2: [13d3:3404]: USB [6C71D949489A v274] "BCM20702A0" by "Broadcom Corp"
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: readCompletion - Unknown error (0xe00002bc)
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Firmware upgrade failed.
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Published new IOKit personality.
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: Processing time 6.421 seconds.
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: Version 2.2.7 starting on OS X Darwin 15.6.
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: USB [6C71D949489A v274] "BCM20702A0" by "Broadcom Corp"
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Firmware upgrade completed successfully.
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Found existing IOKit personality "com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport".
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: Processing time 0.519 seconds.
MacBook-Pro:~ Jay$

Not sure if this indicates an issue or not as at first it fails but then says it's successful ?
Any thoughts or suggestions much appreciated ?

IO Reg and all other files attached ....

Cheers
Jay
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,950
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Did you disable "Wake for network access" in SysPrefs->Energy Saver?
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,808
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Yes, as detailed in OP

Wake for network access unchecked in energy saver ..
Cheers
Jay
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,808
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Is the error ...

Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Firmware upgrade failed.

Something i need to worry about ... ? or is that only for BT which is working fine ?

Cheers
Jay
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,950
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Is the error ...

Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Firmware upgrade failed.

Something i need to worry about ... ? or is that only for BT which is working fine ?

Cheers
Jay
Indicates something is wrong with your USB setup...
Not related to WiFi.
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,808
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Indicates something is wrong with your USB setup...
Not related to WiFi.
Hummmm .... Thats what i figured ...

I've been trying to fix this for ages now, having my wifi speed drop by 2 thirds after sleep really slows down internet and downloads ... all other AC devices work fine and always connect at 876bps on wake up .. so i know its not my router ..

Have tried three different mPCI cards (all AW-CE123H) but all give the same problem .. as detailed in O/P i'm suspicious of the BCM4352 firmware being out of date ... most people who have posted AC success are running firmware version BCM43xx 1.0 (7.21.149.34.1a7) or later ....

But all my cards show firmware version BCM43xx 1.0 (7.21.95.175.1a6) which i think is quite old.

Have tried searching for a way to update the wifi firmware on the card but cant find anything at all ...

Do you (or anyone else) know of a way to update the wifi pci firmware on these cards ?

Cheers
Jay
 
Top