Contribute
Register

Is Pike's AppleGraphicsDevicePolicy needed with WhateverGreen/Lilu?

Status
Not open for further replies.
Joined
Jan 4, 2011
Messages
617
Motherboard
Asus Z170 Hero VIII
CPU
i7-6700K OC @4.6GHz
Graphics
RX 580
Mac
  1. iMac
Hi there,

Running El Capitan (audio build in sig) and about to swap from a nvidia 980 to AMD R9 380 to hopefully fix a GFX glitch. I have this in my config:

Code:
            <dict>
                <key>Comment</key>
                <string>AppleGraphicsDevicePolicy (board-id) Patch (c) Pike R. Alpha</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                Ym9hcmQtaWQ=
                </data>
                <key>Name</key>
                <string>AppleGraphicsDevicePolicy</string>
                <key>Replace</key>
                <data>
                Ym9hcmQtaXg=
                </data>
            </dict>

Should that be removed if using WhateverGreen and Lilu? Going to uninstall the nvidia web drivers of course. The config is attached, is there anything else that needs changing?

Would really appreciate some pointers :¬)

Ross
 

Attachments

  • Yoga-config.plist
    4.3 KB · Views: 46

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,570
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Hi there,

Running El Capitan (audio build in sig) and about to swap from a nvidia 980 to AMD R9 380 to hopefully fix a GFX glitch. I have this in my config:

Code:
            <dict>
                <key>Comment</key>
                <string>AppleGraphicsDevicePolicy (board-id) Patch (c) Pike R. Alpha</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                Ym9hcmQtaWQ=
                </data>
                <key>Name</key>
                <string>AppleGraphicsDevicePolicy</string>
                <key>Replace</key>
                <data>
                Ym9hcmQtaXg=
                </data>
            </dict>

Should that be removed if using WhateverGreen and Lilu? Going to uninstall the nvidia web drivers of course. The config is attached, is there anything else that needs changing?

Would really appreciate some pointers :¬)

Ross

It should not be needed, especially if it was used for the Nvidia card. You can test using Clover Configurator app and checking the disable box next to the patch. The card has device ID 0x69391002? It has drivers in the 9000Controllerkext and the 4000kext so it should work under the Tonga family.

Screen Shot 2020-01-16 at 7.54.00 AM.png
 
Joined
Jan 4, 2011
Messages
617
Motherboard
Asus Z170 Hero VIII
CPU
i7-6700K OC @4.6GHz
Graphics
RX 580
Mac
  1. iMac
It should not be needed, especially if it was used for the Nvidia card. You can test using Clover Configurator app and checking the disable box next to the patch. The card has device ID 0x69391002? It has drivers in the 9000Controllerkext and the 4000kext so it should work under the Tonga family.

View attachment 445260

Thanks Gigamaxx, appreciate the reply. I think it was for a black screen with MacPro 6,1 definition:


Looks as if WhateverGreen bypasses the need for it, I'll try without.
 
Status
Not open for further replies.
Top