Contribute
Register

Intermittent Black boot. GTX 780 6GB. El Capitan. Mac Pro 3,1.

Joined
Jul 9, 2018
Messages
1
Mac
Mac Pro
Greetings!

Please read this entire post in context, as there's more going on here than what can be deduced at first glance.

I've searched far and wide and have yet to find another person having the issue I'm having.

Intermittent black screen at boot after installing the latest version of El Capitan - OS X 10.11.6 (15G21013), and the corresponding NVidia driver update (Web Driver: 346.03.15f15).

(This MacPro 3,1 is a bit of a "Frankentosh" - GTX 780 and 32GB of 667 MHZ RAM - Windows 7/Mac OS X Dual Boot - no BootCamp)

All HDD health tested and appears in perfect shape. No issues like this before these updates. After said updates, my tried and true "temp fix" routine was, for a couple weeks, to boot to safe boot, reinstall video driver, reboot - perfect. But after a little while, it booted (only twice now) to black screen in safe boot! The reason I do this is it seems almost in line with the idea that the web driver is not loading, even though it is set to do so. I say this because, with this card and setup, if no web driver, it boots straight to black screen boot cycle in NM.

In the current configuration, it should be noted that the computer "blacks out" during the boot process, sometimes after desktop is shown for seconds, but it is obviously still loading the boot sequence data. Sometimes this happens before password entry, sometimes after, sometimes it shows all black but password box is visible and loads after entered, but generally shows desktop before blacking out, if it's going to black out. (By "black out", I mean that the screens go black, all USB devices lose power, except mouse oddly illuminates laser if button pushed - otherwise computer is down but with fans running.)

You'll probably want to take a look at my profile to see the full specs of this machine. I also have 1 extra HDD for windows 7, with a shared SSD. Windows works flawlessly, running Doom 2016, Witcher 3, etc. on ultra settings. No boot issues, no hardware conflicts. I must say that on rare occasion, when certain background processes are running in windows, it will drop the NVidia driver for a second, error, and restart the driver. Apparently this is a common problem with win 7 and the GTX 780, according to my research, however, and it has not caused me much trouble. Nothing like what happens in OS X boot.

In OS X however, once the computer boots properly, everything is completely stable for as long as I have it on, days even. I can run several desktops, full of tabs, be rendering a video in 4k in FCP, watching 4k YT video, and playing a 3D game on the other screen - no problem. It's just scary and super inconvenient to have this boot issue.

To be clear, I have to boot to safe mode, reinstall the driver, in order to reliably get into normal mode. When I do this, it will always (so far) boot straight into normal mode right away afterwards. After I am securely in NM, I can reboot as many times as I want, no problem until I power down and unplug the system (during electric storms and such). If I try to boot to NM from power off state, it might boot after 3 or 4 attempts, so I just go into Safe Mode, which NORMALLY boots up the first try.

I'm sorry this is such a long post, but I am trying to include all the little quirks to see if anyone has any suggestions for me.

Another note, when the OS X 10.11.6 (15G21013) update came out, I was new to having a GTX 780, and wasn't thinking about the issues it could cause. I installed the update before NVidia had a new driver available, so I had to follow one of your guides on how to change the build number in the system driver's plist file. That worked fine, until it started booting to a black screen suddenly (likely the first time I'd powered the computer down and unplugged it.) I then installed the driver from NVidia, as it came out that same day I first had the issue. Same thing. Worked fine until unplugging the system. I've uninstalled it, reinstalled, researched - all to no avail in fixing this weird issue. I've backed up, of course, but am just doing the weird things I have to do to keep all of my projects running, as I don't have the time at this juncture to stop and format/reload, (which I don't think will make a difference, since I believe this to be a driver/build type issue...) I also changed the PRAM battery, no dice. I've been working on computers for over 15 years here and there, have worked for some tech companies, but this one is really strange to me. I greatly appreciate any help that you can offer!

Kind Regards,
- Worldi
 
Last edited:

ModBot

Super Moderator
Staff member
Joined
Jan 9, 2011
Messages
1,501
Motherboard
01010
CPU
10101
Graphics
01010
Moved to correct forum.
 
Top