Contribute
Register

Intel UHD 630 Graphics (0x3e918086 i3-8100) Native support with GfxId Injection

Joined
Jan 7, 2012
Messages
26
Motherboard
ASUS PRIME Z370-P
CPU
i3-8100
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
No I don't have external one.
 

Attachments

  • Screen Shot 2018-01-18 at 01.39.50.png
    Screen Shot 2018-01-18 at 01.39.50.png
    69.7 KB · Views: 623
Joined
Mar 20, 2016
Messages
62
Motherboard
Asus Maximus Ranger z170
CPU
intel i7 6700K
Graphics
Asus GTX 960 4GB
Mobile Phone
  1. iOS
No I don't have external one.
It seems wrong device id is set. can you test if correct EFI drive (config.plist) is being used, I basically change the autostart timeout and see if it is correct at boot.
 
Joined
Dec 6, 2017
Messages
5
Motherboard
ASRock Z370M-ITX/ac
CPU
Intel Core i3-8100 Coffee Lake
Graphics
Intel UHD630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi thevolt, did you try?

10mania, sorry for the late reply on this. I did try to use your whole EFI folder but it did not work for me either..
 
Joined
Mar 20, 2016
Messages
62
Motherboard
Asus Maximus Ranger z170
CPU
intel i7 6700K
Graphics
Asus GTX 960 4GB
Mobile Phone
  1. iOS
10mania, sorry for the late reply on this. I did try to use your whole EFI folder but it did not work for me either..
Ok I will do a fresh install and update the thread. There is sth missing in the guide I forgot.
 
Joined
May 15, 2011
Messages
238
Motherboard
ASrock z370 Fatal1ty Gaming mini-ITX/ac
CPU
Intel Core i7 8700K @ 3.7GHz (4.7GHz Turbo)
Graphics
Intel UHD630/Gigabyte GTX 1070 Mini ITX
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
For those who wants to use Gen8 i3 intel gpu without using HD530 skylake fix, I managed to use it by modifiying Rehabman's FakePCIID_Intel_HD_Graphics.kext

intel 8th gen i7-8700k is supported natively with device id 0x3e928086 but 8th gen i3 models have different device id which is 0x3e918086. By default mac os sees the gpu but acceleration does not work. So I did inject the 8700k device id with clover.

So, to get i7-8700k IGPU to work, do I need the FakePCIID_Intel_HD_Graphics.kext and this device id (0x3e928086) injected? What else?
 
Joined
Mar 20, 2016
Messages
62
Motherboard
Asus Maximus Ranger z170
CPU
intel i7 6700K
Graphics
Asus GTX 960 4GB
Mobile Phone
  1. iOS
So, to get i7-8700k IGPU to work, do I need the FakePCIID_Intel_HD_Graphics.kext and this device id (0x3e928086) injected? What else?
I didnt try 8700k but it should work out of the box, because its device id is present inside KBL kext files. What we do with 8100 is to make it seem like 8700k.
 
Joined
Mar 20, 2016
Messages
62
Motherboard
Asus Maximus Ranger z170
CPU
intel i7 6700K
Graphics
Asus GTX 960 4GB
Mobile Phone
  1. iOS
Went ahead and pushed the changes required to FakePCIID_Intel_HD_Graphics and uploaded a new build.
So now people with the hardware can experiment without needing to know how to build it...
Hi rehabman, as intel 8100 owners we do have problems with playing videos after sleep/wake. Do you have any suggestions on this matter.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,465
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Mar 22, 2011
Messages
26
Motherboard
Gigabyte Z370N Wifi
CPU
i3 8100
I also have an i3 8100 and got sleep and video acceleration working. See my original post Success- Coffee Lake i8700k GA-Z370N-wifi:

I had to set the machine to iMac 17.1, otherwise I had some occasional video errors (I had to reboot due to a shaky screen/flickering using Safari and Calendar, but it seems unpredictable)

My build is a

Board: Gigabyte Z370N Wifi
CPU: i3 8100
Memory: 16GB DDR4 2400MHz Crucial Technology
Drive: Seagate 320GB 5400.6 RPM formatted with Journaled HFS+ GPT
Clover: Classic Edition 4.60.0.0
Kexts: (I just copied everything lazily from the Clover USB stick)
AppleALC.kext
CodecCommander.kext
FakePCIID.kext
FakePCIID_Intel_HD_Graphics.kext
FakeSMC.kext
IntelGraphicsFixup.kext
IntelMausiEthernet.kext
Lilu.kext
NvidiaGraphicsFixup.kext
Shiki.kext
SmallTreeIntel82576.kext
USBInjectAll.kext
WhateverGreen.kext
XHCI-200-series-injector.kext

For the accelerated graphics, which I just got working...like I came here with excitement to this forum...I changed the default config.plist by adding IntelGFX 0x59168086 under Devices and ig-platform-id 0x59120000 under Graphics.

For the cause!
 
Last edited:
Top