Contribute
Register

Intel UHD 630 Graphics (0x3e918086 i3-8100) Native support with GfxId Injection

Status
Not open for further replies.
Joined
Nov 26, 2018
Messages
14
Motherboard
GIGABYTE Z370-HD3
CPU
i7- 8700K
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Hello Goliaf,
Hi I am new to hackingtosh. I want to install mac os Mojave to my PC but I am unable to boot from my USB.
every i boot from usb after apple logo loading the display goes turn off. Just like display disconnected.
I follow a guides about intel graphics framebuffer patch (https://www.tonymacx86.com/threads/guide-intel-framebuffer-patching-using-whatevergreen.256490/) but I am unable to complete guide because i didn't understand the guide.
here i attached my EFI folder from usb. Can you please help me out to give a proper guide please... I do not have any external GPU.
Hi @nobin118960! Im not pro in hackintosh too, but I think your problem in this. (see screenshot)
Config trouble Intel.png

Check this box. I fixed it for you. Try this config and write here - work or no.
P.S. I think for first install your config is very big and hard.
 

Attachments

  • EFI.zip
    4.4 MB · Views: 97
Joined
Dec 19, 2013
Messages
29
Motherboard
Gigabyte Z390 Gaming SLI
CPU
i7-8700K
Graphics
Intel UHD 630
Mobile Phone
  1. Android
Thanks a lot now its work...
 
Joined
Jan 13, 2017
Messages
267
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
  1. iMac
  2. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Hi Is someone fix i7 - 8700K with UHD 630 (0x3E918086) to work on Catalina ? and SMBIOS 19.1 or 19.2 ?
 
Joined
Jan 5, 2020
Messages
25
Motherboard
Asus ROG crosshair VIII EXTREME
CPU
Ryzen 9 5950X
Graphics
GT 710 (RTX 3090)
Mac
  1. Mac Pro
Mobile Phone
  1. Android
does not work for me probably because I have an i7 instead of i3. How can I find out what will work for my i7-9750H ?
 
Joined
Jan 13, 2017
Messages
267
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
  1. iMac
  2. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Joined
May 28, 2020
Messages
18
Motherboard
Dell Optiplex 5060 Micro
CPU
i5-8500T
Graphics
UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
so after update 10.15.2 i7 8700K UHD630 stop work.
any with same problem ?
when my computer boots after the applp logo i have to turn my monitors off and back on, even when the computer sleeps and wakes up have to turn monitors off and back on, i cant figure it out it is annoying but this might help you out, if someone has a fix please let me know.
 
Joined
May 28, 2020
Messages
18
Motherboard
Dell Optiplex 5060 Micro
CPU
i5-8500T
Graphics
UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
The Apple Mac mini 8,1 (Late 2018) was initially introduced on October 30, 2018. The starting model is coming with the advanced “Coffee Lake” 3.6 GHz Intel Core i3 processor, the Mac is equipped with 128 GB SSD storage and an Intel UHD Graphics 630 graphics processor. I dont understand why this graphics card is giving so many issues, you would think that it would be alot more friendly with it natively integrated in the mac mini 8,1.
 
Joined
Apr 20, 2012
Messages
36
Motherboard
GA-Z370M-D3H
CPU
Core i3 8100
Graphics
UHD 630
Mobile Phone
  1. iOS
The Apple Mac mini 8,1 (Late 2018) was initially introduced on October 30, 2018. The starting model is coming with the advanced “Coffee Lake” 3.6 GHz Intel Core i3 processor, the Mac is equipped with 128 GB SSD storage and an Intel UHD Graphics 630 graphics processor. I dont understand why this graphics card is giving so many issues, you would think that it would be alot more friendly with it natively integrated in the mac mini 8,1.
Try this boot parameter

igfxonln=1

do not update to 10.15.5, there is a problem with weg and framebuffer patching that has to be solved.

Regards
 
Joined
May 28, 2020
Messages
18
Motherboard
Dell Optiplex 5060 Micro
CPU
i5-8500T
Graphics
UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
Try this boot parameter

igfxonln=1

do not update to 10.15.5, there is a problem with weg and framebuffer patching that has to be solved.

Regards
im on 10.15.5 i am working on getting a time machine backup, and copying other files then going back to 10.15.3, things broke since 10.15.4 and tried 10.15.5 to see if possible to fix the graphic issue.
 
Joined
Apr 20, 2012
Messages
36
Motherboard
GA-Z370M-D3H
CPU
Core i3 8100
Graphics
UHD 630
Mobile Phone
  1. iOS
im on 10.15.5 i am working on getting a time machine backup, and copying other files then going back to 10.15.3, things broke since 10.15.4 and tried 10.15.5 to see if possible to fix the graphic issue.

Hi, I just solved the issue.

In 10.15.4 you have to add igfxonln=1 boot parameter, so your working 10.15.3 EFI folder will work if you add this to Clover or OpenCore.

In 10.15.5 the things get more difficult, but solvable. You have to use this ig platform ID 3E9B0000 instead of 3E9B0007 and make sure you have a proper Framebuffer connectors patch.

Now I'm writing from 10.15.5, don't give up, you can solve it.

 
Status
Not open for further replies.
Top