Contribute
Register

Intel UHD 630 Graphics (0x3e918086 i3-8100) Native support with GfxId Injection

Joined
May 22, 2016
Messages
40
Motherboard
Gigabyte GA-Z370N-WIFI
CPU
i3 8100
Graphics
UHD630
Mobile Phone
iOS
Joined
Jul 25, 2015
Messages
17
Motherboard
H370 Bazooka
CPU
i3-8100
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
hi guys,

I got myself an h370m bazooka and a intel core i3 8100 my systems running on 10.13.6. I'm using WEG+Lilu but only got 31MB VRAM. does anyone have this issue?
 
Joined
Jul 23, 2018
Messages
13
CPU
i7 7500U
Graphics
HD 620
Mac
MacBook Pro
Mobile Phone
Android
My profile settings shows my first build. Recently I made another build:

Intel i3 8100
Asus Prime z370-A
16Gb ram - Corsair Dominator 2400Mhz
Samsung evo 250gb SSD
(No external GPU)

I am using Display Port for a 4K philips monitor and had issues with monitor wake after monitor sleep with skylake hd 530 fix. This was the main reason that pushed me towards a different solution. Now monitor sleep/wake is ok, transparency and acceleration seems ok. I will test for some days and update this thread in the following days if I have issues or not.

During my tries, I changed smbios setting a few times, lastly it stayed as 18,3. I will lower it to 18,2 and try since my cpu is very likely with 7500. what do you think?

Thanks
My devices info:
CPU:i7 8700K
GPU:UHD630
No external GPU

I install 10.13.3 in my computer and when the GPU was not be driver.It has signal in HDMI and DP. When I use drive the GPU and then the port on HDMI and DP can't output signal. Any solution?
 
Joined
May 22, 2016
Messages
40
Motherboard
Gigabyte GA-Z370N-WIFI
CPU
i3 8100
Graphics
UHD630
Mobile Phone
iOS
Joined
Jul 25, 2015
Messages
17
Motherboard
H370 Bazooka
CPU
i3-8100
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
hey there, nope I did not use the FB patcher...thought I would be smart to try to update on 10.14 for OOB graphics support...now stuck on the apfs driver...tried to use the MacMini8,1 SMBIOS
 
Joined
Jan 24, 2019
Messages
6
Motherboard
Gigabyte B360M D3H
CPU
Core i3-8100
Graphics
GTX 1050
Mobile Phone
Android, iOS
hello.

I'm about to give to make uhd 630 work on my desktop pc with gigabyte b360m d3h and core i3 8100 on mojave 10.14.3
I attached my efi folder here.Please help me :(
 

Attachments

Joined
Nov 27, 2018
Messages
6
Motherboard
GIGABYTE Z370-HD3
CPU
i7- 8700K
Graphics
UHD 630
Mac
Mac mini
Mobile Phone
iOS
intel 8th gen i7-8700k is supported natively with device id 0x3e928086 but 8th gen i3 models have different device id which is 0x3e918086. By default mac os sees the gpu but acceleration does not work. So I did inject the 8700k device id with clover.
10mania, big thanks for this device id. Im used 0x3e928086 and my UHD630 in my 8700K has been detect (with 7 mb RAM)
But I went ahead and chose 0x3E9B0007 (3rd point in clover configurator for UHD630 (ig-platform-id)) and this works very nice!
Now I have 1536 mb for my UHD630.
 

Attachments

Last edited:
Joined
Jul 4, 2019
Messages
4
Motherboard
Msi 370m Bazooka
CPU
i3 8100
Graphics
uhd 630
Did you use the framebuffer patching method? It is mentioned here (not so clearly though) https://www.tonymacx86.com/threads/guide-intel-framebuffer-patching-using-whatevergreen.256490/

After using the FB patching method I'm able to use the i3 8100 to drive my TV @4K 60Hz

Hey man!
i have msi h370m bazooka
intel i3 8100

i have same problems like you.

my efi is default installed version.
config.plist. too

i have 6 mb vram on uhd 630...
and im using high sierra..
but im not at that hackintosh things..
can you send me your efi or config for my use..?

i
 
Top